Jump to content


Sir BillyBob's Content

There have been 67 items by Sir BillyBob (Search limited from 27-January 20)


By content type

See this member's


Sort by                Order  

#524772 Bug Report for 0.53

Posted by Sir BillyBob on 13 October 2011 - 05:43 AM in Classic Adventures


Thanks for info guys. Now for other strange things I noticed: when I massacred kobold clan ( poor Meepo ) I get my hands on key for barred door. Behind it I encountered Jot ( very nice xp ) and Dragon priest. After each blow I delivered to priest there was message in blue: Dragon priest use a scroll. After he goes down I pelted him with six or seven acid arrows before he finally goes for good. Then I went second route and I finished Silver princess quest. No journal entry, I refused to take gem and let go of Chaarna ( she goes of her own ), no xp reward, nothing. Is it supossed to be like this or I missed something important?

I encountered the same issue with the Dragon Priest. In addition I got ".... uses a potion" over and over in many different parts of the game. For example, I kicked Paraway out of the party when he was injured (told him to wait so he didn't go anywhere). I think he still had the healing potion he starts the game with. Every time I was on the same screen as Paraway I kept getting "Paraway uses a potion" until I finally took him back into the party .... and hey, waddayano, he still had the healing potion and was still injured.


The priest has a scroll of healing. He will attempt to use it, and usually does.

Being a jerk to the ghost and not helping gives you no experience. Hey, you didn't do anything, why get XP for it? There are several cases of this throughout the game. Deciding not to do something doesn't mean it won't get done, but it also means you may not get any XP. Your decision.

Potion/scroll bugs seem to be a problem with the game engine. Usually, an NPC will consume a potion if their HP is below a percentage. It should not happen otherwise. However, for some strange reason, they use it but the potion doesn't go away. Therefore, they think they can use it again and again. It doesn't happen all the time but when it does, it will continuously. Also, there are some potions that actors will try to use even though they don't meet the requirements to use it. You may find some orcs will try to use potions of Intelligence even though the requirement is that they must have INT > 14. Orc don't but they try to use it anyway. It is as if the game engine runs through scripts for some creatures and not for others, or ignores conditions for some and not for others.



#524770 Bug Report for 0.53

Posted by Sir BillyBob on 13 October 2011 - 05:35 AM in Classic Adventures



Captain Girana (TCSLGIR.dlg) in area TC1007 - tavern in Westgate docks will never turn hostile if you have
certain persons in your party. Can't remember exactly who those people are, but it surely is a bug.
You need to fix blocks 36, 37, and 38

I also ran into this problem, and I don't see anything in Sir B's reply addressing it. In TCSLGIR.D, I see:

IF ~~ THEN BEGIN FinalScenePara1.1
  SAY ~We shall see about that, wild elf!~
  IF ~~ THEN EXIT
END

IF ~~ THEN BEGIN FinalSceneAesd1.1
  SAY ~*smirks* Blame it on your foolishness in following a dumb leader.~
  IF ~~ THEN EXIT
END

IF ~~ THEN BEGIN FinalSceneRiv1.1
  SAY ~Your pathetic blade skill is no match against mine.  I shall show you what true sword fighting is!~
  IF ~~ THEN EXIT
END

Note that the statements "SetGlobal("TCSlaverTalk","TC1007",2) SHOUT(ALERT_79) Enemy()" which occur with other characters are missing for these three.


Fixed.



#524191 Secret of BoneHill v2.75b

Posted by Sir BillyBob on 05 October 2011 - 04:05 PM in Secret of BoneHill

Graoumf and his coworkers have updated this mod to include a French translation. They have also included a few bug fixes based on issues reported here. I have uploaded for everyone, however, I am not the person to contact for support. Sorry folks but I still need to get the next CA version.

Here is the link : SOBH v.275b

Here are some of the updates they included:

Apart from the French translation, here are the change we made:
1. inclusion of fixes provided in the BiG Fixpack v10.1 various fixes to tra files (invalid keywords and stuff) fixes for three small problems mentioned in the Bonehill v275 bug report thread
2. a complete rewrite of the readme (english and spanish), using the latest SHS model.
3. BH0111.ARE, both for BGT and Tutu: changed the charge of RNDTRE01.ITM in the container to 0 (it seems this value is used elsewhere for random items)
4. BHQUENEX.d: added a text reply before EXIT in the unconditionnal reply of the first state. The text used is not optimal but avoids adding a new text (reused text for the exit case in state 12)
5. BHMARTIN.d, both for BGT and Tutu: added a reply when "BHGnollQuest" is 1. I reused a reply for when it is 0, which is not optimal either (but the ogre mage is not dead yet anywhere, so the task is not finished).
6. Finally, I changed the readme handling in the tp2 file, aside from adding the French language. They used to be copies of the English readme in other directories, so that the AT_EXIT command would work with the %LANGUAGE% variable. Instead I used the README command, which allows to set a name with %LANGUAGE%, with a fallback if the file is not found, in this case it will display the English version. Additionally, this means the readme will be proposed at the beginning of the installation. I checked the behaviour will all languages.



#523006 Bug Report for 0.53

Posted by Sir BillyBob on 19 September 2011 - 04:57 AM in Classic Adventures

Depending on other globals, you may be successfully setting TellCouncil to 1, but something else then sets it to 2. To verify, use the console to GetGlobal("TCLizTellCouncil","GLOBAL") and this should show you what the global is currently at or if it even exists.

Lu -
IDS file corrected. Never noticed this before but since I don't use that command, never had a problem. Corrected now just in case. Thanks.



#515508 Help

Posted by Sir BillyBob on 22 May 2011 - 04:49 PM in Classic Adventures

You didn't do a full install of SoA or ToB. Both have to be fully installed because we use some area graphics from the original game.



#515189 Bug Report for 0.53

Posted by Sir BillyBob on 16 May 2011 - 04:41 AM in Classic Adventures

The Glab is actually that way in the original game, nothing we have changed. In fact, of the three versions of the Glabrezu, only the summoned version has XP. Which is reverse of logic because usually summoned creatures don't have XP and regular creatures do. So I may have to fix all of them.

In the original mod, Elmo dies. We added an option to save him if Candella is in the party. She will beg for Rurik or Blush to heal him. We may expand it later but for now, she needs to be in the party for you to continue that story line.



#515040 Bug Report for 0.53

Posted by Sir BillyBob on 13 May 2011 - 04:07 PM in Classic Adventures

Stalker - fixed (should have been fixed before)
Quest - have to look at
TC3300 - fixed in 0.54
TC3706 - didn't know those arrows even existed, not sure what they are for - fixed
TC3052 - fixed in 0.54 by using Infinity Animations now



#514521 Plan for an update?

Posted by Sir BillyBob on 06 May 2011 - 08:14 AM in Classic Adventures

Working on it. Probably still another month or two out. We have a couple more maps to build for Castle Amber. Once I can do a full run through that mod, I'll see about getting this out to everyone.



#511975 Another bug ?

Posted by Sir BillyBob on 30 March 2011 - 03:25 PM in Classic Adventures

Not sure how the quest got so buggered. The only thing to do at this point is fix your Globals by using the CLUAConsole.

Global("TCLizTellCouncil","GLOBAL",1) - this sets up the dialog to tell her what happened with the lizardmen.
Global("TCLizTellCouncil","GLOBAL",2) - this is what she should set so you can't repeat the dialog. She will also set:
Global("TCCouncilAgrees2Liz","GLOBAL",1) - this runs the timer for 1 day before you can talk to her again about the lizardmen.
Global("TCCouncilAgrees2Liz","GLOBAL",3) - this is her dialog option to say the council agrees to help the lizardmen. So set this to fix your bug.



#511729 Another bug ?

Posted by Sir BillyBob on 26 March 2011 - 04:03 PM in Classic Adventures

Hmm, the mayor should have already been arrested at this point. You did clear out the haunted house, correct? You should be talking to the militia captain now, not the mayor.

For the lizardmen, you have to have them give you the quest, go to the captain and tell her. She will give you an update in 24 hours. Go back to the Lizardman King. He opens your map to the area where the battle for their home is. You can then go there to help them fight.

If TCCouncilAgrees2Liz doesn't exist, the captain hasn't gotten approval yet. She asked you to give her 1 day. So wait.



#510596 Screenshots

Posted by Sir BillyBob on 13 March 2011 - 12:25 PM in Classic Adventures

Future mods we are working on are the Giants series, G-1-2-3. The first is with Hill Giants. So, in version 0.54, we plan to add some of the first maps for this area. It won't be finished but it should give some of you another area or two to explore. Be prepared for some serious fights.
G1 Giants.jpg



#510412 Bug Report for 0.53

Posted by Sir BillyBob on 11 March 2011 - 08:23 AM in Classic Adventures

You can't kill Calcryx. He wears an item like Imoen's belt in SoA. Once he talks to you about giving up, you have an option to continue trying to kill him. Otherwise, he surrenders. This was the only way to keep the party from killing him before the cutscene. If you ever say you plan to kill him, he "should" drop the item that makes him unkillable.

Sir Braford will not attach due to a bug in Belak's dialog (I thought we covered this already?). Just frag him with a fireball/potion of explosions. It will be corrected in version 0.54.



#510237 Bug Report for 0.53

Posted by Sir BillyBob on 09 March 2011 - 06:28 AM in Classic Adventures

Dialog option 2 and 3 (I have been tasked...) both go to the same dialog block where he says "we shall see" so there is no difference in how the dialog runs the fight. You have probably just encountered the same problem for why Aleigha doesn't always parlay with you but Cath seems to every time. Oh, Sanbalt and Icar do it some times as well. For now, all I can say is save your game before those fights.

I have tested the idea that their scripts don't always get a chance to check their HP amount to then jump to the next dialog. I haven't found a solution yet that is consistantly working.



#509876 Bug Report for 0.53

Posted by Sir BillyBob on 04 March 2011 - 02:13 PM in Classic Adventures

Or you could use Global("FAALT","LOCALS",1) trigger and SetGlobal("FAALT","LOCALS",2) action instead, since in the previous banter between Fala and Althon the value of local variable FAALT is set to 1


Okay, I'm going to use the LOCALS of 2 for the second dialog. Otherwise, there is a risk of the dialogs running out of order.

Rivian moves to 1201 in the next version.

Capt Beril issue isn't major. This is to remove him from the area if he is standing out on the docks. Fixed for next version.

Sharp Eye's dialog was corrected a few weeks ago due to her and Saltmarsh Captain conflicts. Global now only goes to 5, so dialog will allow you to purchase items even if you decline the quest.

Kessa actually has 2 dialogs here. So both needed to be updated. They will now only trigger if she is in the party and can detect the PC.



#509269 Bug Report for 0.53

Posted by Sir BillyBob on 25 February 2011 - 06:50 AM in Classic Adventures

Masterwork arrows - okay you lost me here. What proficiency penalty? It is just an arrow with a +1 THAC0, same as in IWD where it comes from.
Bullets - not sure when that was added. BG2Fix actually removes this from the magical bullets but not from the normal one. So I removed the BULL01.ITM file out of our install. As far as I know, the sling is what lets you add strength, not the ammo.

Rurik's wand of hard knocks - I think I have this fixed now but I will need to test.
Bathis dialog - where does it break? There was an older problem with Paraway in the party but that was fixed awhile ago. Who is in your party and who was the last person talking?

Priest healing scrolls work fine for me. Some attack ones do as well but not all. Need further digging.
Barford - always attacked me but I do see a bug in the dialog that could be why he isn't always attacking. Fixed.

Rescuing Saltmarsh Kids - Journal should update to remove active quest and post completed quest. I think I fixed this several months ago but you all don't have that version yet. No XP for this quest and nothing really for seeing the barrels of wine/spirits in the mayor's home. What? You plan to feed it to the starving refugees? I guess that would take away their troubles but not much of a proper food - unless it was Guiness. We do have some small areas where the story just ends. The idea was to leave hooks for future modders to add their stories. Consider it as Unfinished Business for Classic Adventures.



#509109 Bug Report for 0.53

Posted by Sir BillyBob on 23 February 2011 - 02:30 PM in Classic Adventures

Mistmoor - okay, now I understand what you are talking about. Fixed.

Candella and thieves - Don't know that to tell you. Normally a party starts off with Shadow and can add Candella (or replace Shadow with her). Fala'stra is our third thief and we didn't see a need to add another one. There is Buranta but she is an assasin and not found until after Westgate. So while in Sembia for the first 2 chapters, you could get Ned from the haunted house but he was never supposed to stay with the party or have any banters outside of the house. You could always respawn Candella by creating TCCANDE.

Leaving coordinates are usually from cut-and-paste without modifying for a new location. Most leaving dialogs need to be updated to handle Chapter 3 in Westgate and Chapter 4 in Selgaunt. Most of the original characters haven't been updated for that.

Priest scrolls - I thought that was just me doing something wrong. So you see it also? Something to try to track down.

Rivian - dual class because we couldn't create a good multi-class that we liked.

Week vs. tenday - I went ahead and updated the lizard king but that also required updating the minister and Saltmarsh captain. I'm sure you will see this term used elsewhere in the mod as well. BTW, there is no game timer for this dialog, you can really take as long as you want. No penalties for taking longer.



#508823 Bug Report for 0.53

Posted by Sir BillyBob on 20 February 2011 - 05:56 AM in Classic Adventures

Rivian is a dual class fighter/mage. That would be why no one ever called out the "bug".

Durnn has no proficiencies, just like about 99% of other monsters in the game. I have been giving some Bioware creatures proficiencies just to make them harder. No rule saying I have to not not have to.

Morale codes? They are the settings that the NPC had when it was created as a player character and then converted to a CRE file. So that would be the same morale setting your character has.

Cath - don't know what happened there. 32 in Mace proficiency? Very strange but now corrected to 4. 2 in dual weld.

Nothing wrong with Mistmoor Inn - I hide the mage items in that room (this area is from IWD if you don't know). Later after the slaver quests, Fala'stra will be able to show you the items or you may find them yourself. But for now you can't access the room.

Althon's sword - corrected.

TCSCEPT2 - corrected.

Jak - corrected.



#508761 Bug Report for 0.53

Posted by Sir BillyBob on 19 February 2011 - 10:22 AM in Classic Adventures

The dragon priest holds a healing scroll, so he knows how to use it if he can.

Not helping the Silver Princess is going to net you nothing (why should you get XP for not helping?). However, I can't remember if we give XP for helping. So you may not get any either way. I'll have to see and give some XP for doing the right thing.

BTW, if I recall the ghost doesn't reappear to attack you even though she says he will. Something else I need to look at.



#508629 Bug Report for 0.53

Posted by Sir BillyBob on 18 February 2011 - 06:51 AM in Classic Adventures

Candella bug already found and correct for next version. My latest test with her has several banters now working as they should.

I believe that list of romances is correct. I can't think of anyone else. Several are much further along than others.



#508460 Bug Report for 0.53

Posted by Sir BillyBob on 16 February 2011 - 08:37 AM in Classic Adventures

I think I have the Meepo problem fixed. There was an issue with his dialog file and also with area TC0014's script.

I can now have him join, leave, and rejoin as he should. There is also the dialog option to rest with him watching over you. That was only in one of his dialogs, not the other. I also found a map point error on TC0014 which is now fixed as well.

Thanks for finding this bug.



#508454 Bug Report for 0.53

Posted by Sir BillyBob on 16 February 2011 - 06:01 AM in Classic Adventures

Get closer to the snake and you will find out.

They use the same script as bears. You have to be less than 10 feet away for them to attack.  And the party member that close can't be a druid or ranger else they still won't attack.

Yes, the varg creature animation was in a goblin slot. It isn't anymore since I have added several PST creatures to IA. That doesn't mean my list is the same as the "official" IA animation slot list, but it is what I am using for now. I'll update it as the official version gets updated. What this should mean for players is that version 0.54 shouldn't have these animation problems with Aurora or any other mod as long as it uses the official IA animation list (I've just added to it, not modified what is already there).



#508427 Bug Report for 0.53

Posted by Sir BillyBob on 15 February 2011 - 07:36 PM in Classic Adventures

Meepo? I haven't encountered this error before. I will have to try to duplicate it.

Duchess - your error message claims the MakeGlobal() command isn't valid, but it is. In fact, I use it for these 2, Rilithar, Chaarna, Meepo and others to move them around the areas as if they were NPCs. This is for situations where you didn't have them join but I need to make sure they appear in multiple locations without creating and then destroying their CRE files over and over again. I just ran Duchess and Can's dialogs through DLTCEP and it still shows everything is valid. Of course, it may be that I fix something a few months ago after releasing .53a and forgot I now have it fixed but you don't.

Stirge animations must have been changed from another mod. Hopefully this won't be a problem in .54 since the Aurora mod and CA both support Infinity Animations.

Paraway has had his class changed a few times over the years but I don't think it was in the last couple of versions.



#508240 Bug Report for 0.53

Posted by Sir BillyBob on 14 February 2011 - 05:56 AM in Classic Adventures

I have no idea what half of the mods you installed do. Anything that modifies the EXE file of the game has a chance of not working because we modify this file several times ourselves. Even more so in the next release. Any mod that adds items or changes what is in containers is probably not going to do anything noticable in this game because they change default areas of BG2 which we don't use. However, if you plan to use ShadowKeeper to add these items to your team, than it will work fine.



#508239 Bug Report for 0.53

Posted by Sir BillyBob on 14 February 2011 - 05:50 AM in Classic Adventures

I encountered an issue tonight, which I see from older posts on this forum that it had come up several years ago with two other users.  I completed the part with the pirate ship, and the guard captain back in Saltmarsh told me to go to the swamp, and my world map was updated.  The swamp area showed up, yes, but it was grey and unable to be selected, so I couldn't actually go there.  I tried leaving from both the top of the screen (leads to the map) and the bottom (leads to the haunted house).  Also tried going to two other screens (the home town area and the Tinker's place) to see if I had to approach from one of those maps, but that didn't work either, and you don't seem to have intended that anyway.

In the end, I followed the advice listed in the other posts, which was to use the CLUA console to teleport to the swamp, after which the map worked correctly.  Just letting you know it happened.

Because you needed to go out the Southwest gate and off the West edge of the map. South takes you to the haunted mansion, but West takes you to the swamp, Mistmoor, and Selgaunt.



#508164 Bug Report for 0.53

Posted by Sir BillyBob on 12 February 2011 - 06:50 PM in Classic Adventures

Duchess and Candella work fine for me and always have. Candella is currently in my party, so this does work. Not sure what is triggering incorrectly in your game. Pls list any other mods you may have installed, maybe one of them is a problem or conflict.

Aleigha and Cath are both hard to have join because everyone has low HP and any good solid hit will kill them. They both wear an invisible item which should keep you from killing them but I still have had it happen.  Aleigha just needs a couple of Dirbert's arrows in her to trigger her dialog. Same with Cath.  However, if you used any poison or other lingering damage, it is possible for them to stop fighting but die anyways.  My best suggestion is to take out the dwarves first.

BTW, Aleigha and Candella are in my current party.