Jump to content


Photo

Bug Reports


25 replies to this topic

#21 Isaya

Isaya
  • Modder
  • 294 posts

Posted 10 November 2009 - 11:46 AM

The reason why I stated to change the variable in a specific area is because this variable value will cause the area script to remove the effects. I'm afraid removing an effect with SK will not be enough.
I would like you to send me one or two save games so that I can figure out what your problem is. I'm looking for a save game prior to starting the mission and one when reaching the castle, either before leaving the sky area or in the castle area itself. In any case I want it before you made your changes with SK.
Please use the e-mail address provided in the readme file since you want be able to upload anything in the forum if you're just a guest.
Also clarify if you have ToB, which patch you have and which version of the mod you're playing.

Thank you very much.

#22 Graoumf

Graoumf
  • Member
  • 594 posts

Posted 10 November 2009 - 11:53 AM

Oh, and there are no experience points for secondary objective completed ( like in the pirates mission ). Bug or purpose?

There is no reward for the secondary objective indeed. It's not a bug. But you've got a lovely dialogue instead. :D

#23 -my very bad english-

-my very bad english-
  • Guest

Posted 11 November 2009 - 08:20 AM

I am sorry about save games but I'm afraid I can't provide them. After I completed fourth mission I ended in tough bar fight( you know which don't you ) :lol: . Result : four death on my side ( with PC ) versus two of them. So I decided to try something else so now I playing battle at Helm's deep. About removing poly effect with SK it worked perfect, but I tryed your way first and that didn't worked. When you land on drop off point nothing happens, changing variable the way you described doesn't help. I have ToB and latest patch and that it. ( 26498 ). EE was 1.0.0.4. Mod is heavy but interesting ( that Lord Denton is one ( no, two! ) tough cookie ) and my only serious objection is shortage of potions of extra healing for buying ( playing without them is masohistic in my opinion ).

P.S.
I didn't see that lovely dialogue on my sorrow, hopefully next time with that bug removed. :cheers:

#24 Isaya

Isaya
  • Modder
  • 294 posts

Posted 14 November 2009 - 03:00 PM

Thank you for your nice comments.

I wouldn't mind adding things to make the mod easier to play as it's far too difficult for me so I can't play it without heavy cheating. However it was never my intention to change aspects of the original mod, merely to fix bugs if possible. I guess such changes could be made optional, in a "ease of play" component. I don't have much time for any kind of modding these days, so I'm afraid somebody else should take over the mod for any such changes. Anyone interested in taking over may contact me.

I checked the mod scripts concerning the transformation back from pseudo-dragon. What I thought was the area script is only a proximity script. The consequence is you really need to be in the small camp (where the Arnise guards await you in the original area) to be changed back to normal. So, if it fails and you want to try and change the variable I mentioned, you need to be in that small camp.
Try as I might, I couldn't find any reason why this would fail : when you reach the area, that's precisely in that camp you land. I'll have to check if something could be causing the proximity script not to trigger in some cases.

#25 -Sinistrism-

-Sinistrism-
  • Guest

Posted 19 March 2010 - 08:38 PM

Hi, I seem to be having some rather strange issues with Epic Endeavors, and I have no idea why at this point.

I have a full install of SoA and ToB with the latest patch installed, and I used the setup file which was provided in the post about version 1.04 having a trojan since my anti-virus was also detecting the regular download as a virus. Epic Endeavors is the only mod I have installed and I haven't really done anything else to the game.

Everything starts out fine, I begin in Irenicus' dungeon and everything seems to go as it should. However, once I try to use the portal to leave, I always end up in Galvena's festhall in Brynnlaw- so once I'm there everything is just the same as it is in SoA. All the exits are the same and once I leave the place, I end up in Brynnlaw. I really don't know what to do.

#26 Isaya

Isaya
  • Modder
  • 294 posts

Posted 21 March 2010 - 10:38 AM

I dont know why the installation would succeed and then game fail like that. I can only make a guess.

My guess is that you installed something AFTER Epic Endeavours, which overwrote the AR1608.ARE file, the festhall from Galvena and the area you end up after leaving the starting area in Epic.
Both Baldurdash and BG2 Fixpack change this file. So if you installed any of these mods after Epic Endeavours, you may have brought back the area links from BG II. That would explain why you reach Brynlawn when you leave the area.

Checking for BG2 Fixpack installation is easy : you can have a look at the WeiDU.log file in the game directory, it will appear there and the order of the mods will reflect the installation order.
For Baldurdash installation, check dates of files in the Override directory of the game : if you find anything from 1995, they are from Baldurdash. If the file AR1608.ARE does not have a date and time matching your installation of Epic Endeavours (take a reference with files such as lh2HS1.itm, specific to Epic Endeavours), some other mod changed it.



Reply to this topic