Jump to content


IWD2 Choppy Gameplay Thread


  • Please log in to reply
22 replies to this topic

#1 -Guest Lucas-

-Guest Lucas-
  • Guest

Posted 01 March 2007 - 07:11 AM

I did quite some research, but couldn't find the answer myself. My problem is the following:

No matter what I do. The game plays 'choppy'. It is definetely not my specs. Well, actually, it is. Newer systems and drivers seem to have a problem with IWD2's engine.

Some fixes I found:
1) Set everything on low: works, but come on. Who wants to play quite an old game like that on low settings.
2) Disable DirectDraw: works like a charm, but makes your cursor flicker. This is not something I like to adjsut everytime just to play this game.

Does anyone here know a real fix for this problem? It sucks that Black Isle had to rush this game, and now it doesn't support newer systems. Not even 3D acceleration.. :ph34r:

Any help is appreciated!

#2 Rastor

Rastor

    Yes, I really am a dragon. Yes, I am a jerk. Live with it.

  • Member
  • 1998 posts

Posted 01 March 2007 - 04:18 PM

There's a fix for this at Sorcerer's Place.

It's a known bug :).
Home of Kitanya, Improved Asylum, more...

Posted Image

#3 -Guest Lucas-

-Guest Lucas-
  • Guest

Posted 02 March 2007 - 01:08 PM

I don't mean the slowdown in the two or three areas mentioned in that fix.
It starts in Targos, everywhere in the game.

On many other forums people with somewhat better specs can't run this game well. I think this game is poorly optimized or something. I was just hoping for some kind of fix. :(

#4 Anomaly

Anomaly
  • Member
  • 562 posts

Posted 11 March 2007 - 06:19 AM

I have the same problem with IWD : this game is very slow on my new computer, whereas it runs at full speed on an older system.

For IWD2, the keyboard does not work on this computer ! If I hit 10 keystrokes, one letter only will appear. On the older system, I have no problem with that. I don't know if the game is also slow, since without my spacebar for pause, I can't play.

On the same computer, NWN runs fine with maximized settings. BG2 runs fine, but only with 3D-Acceleration enabled.
French translator of: BG2 FixPack, BG2 Tweaks, Baldur's Gate Trilogy-WeiDU, BGT-Tweaks and some minor mods.

#5 Archmage Silver

Archmage Silver

    Master of The Art

  • Member
  • 6654 posts

Posted 11 March 2007 - 02:55 PM

Strange... I have no problems running IWD or IWD 2 on my current setup which is quite modern, link.

I can also run all Baldur's Gates well, and even the Fallout games run without any problems.

#6 Anomaly

Anomaly
  • Member
  • 562 posts

Posted 11 March 2007 - 03:34 PM

I should have said that my current system is a laptop... This may explain some things, even if I don't know why. It's a Intel Core Duo T2300 (1.66 Ghz dual core) with 1 GB of RAM, Geforce Go 7400 and Windows XP Media Center. Way below your configuration, Archmage Silver.

Why NWN, which should require more computing power, runs perfectly on this computer and IWD 1/2 does not is beyong me.

The older system (on which IWD 1/2 runs perfectly) is a desktop computer with AMD Athlon XP 1500+ (1.33 Ghz) with 256 MB of RAM, Geforce FX 5200 (previously Geforce 2 Ti) and running Windows 2000.
French translator of: BG2 FixPack, BG2 Tweaks, Baldur's Gate Trilogy-WeiDU, BGT-Tweaks and some minor mods.

#7 Archmage Silver

Archmage Silver

    Master of The Art

  • Member
  • 6654 posts

Posted 11 March 2007 - 05:41 PM

There shouldn't be any major differences between running IWD on a laptop or a desktop if the hardware is roughly equal, or the laptop has better hardware. There is one possible answer here though: IWD wasn't built to support dual-core CPUs, and just because it runs smoothly under my AMD dual-core CPU doesn't mean it does that with every dual-core CPU out there.

You can try this simple trick:

1. Start the game
2. When at the start menu, minimize the game to get back to your windows desktop
3. Ctrl + Alt + Delete to get the Windows Task Manager up and go to the "Processes" tab
4. Find the IWD process, for example IWD2.exe
5. Right-click on it to get the options, then click "Set Affinity..." and de-select CPU 1 so the game process uses only CPU 0
6. Exit windows task manager and play the game

Edited by Archmage Silver, 11 March 2007 - 05:44 PM.


#8 Anomaly

Anomaly
  • Member
  • 562 posts

Posted 06 April 2007 - 10:36 AM

For IWD2, the keyboard does not work on this computer ! If I hit 10 keystrokes, one letter only will appear. On the older system, I have no problem with that.

I found a solution for this specific problem : I needed to kill the "Apoint.exe" process (it is a process related to the touchpad). The touchpad still works :unsure:, but now the keyboard works very well in IWD2.
French translator of: BG2 FixPack, BG2 Tweaks, Baldur's Gate Trilogy-WeiDU, BGT-Tweaks and some minor mods.

#9 Kissaki

Kissaki
  • Member
  • 7 posts

Posted 14 May 2007 - 07:07 AM

I don't know if this was mentioned before.

Try lowering Path Search Nodes to 4000 (Path finding is bad anyway so i set it low).

I think it helped me a lot. Especially in hoard fortress.

#10 -Erik Veston-

-Erik Veston-
  • Guest

Posted 16 July 2011 - 03:37 PM

Hello. I just installed IWD and then IWD2 on my laptop and have been trying many of the various suggestions to fix the choppy gameplay to no avail. The game installed and plays correctly although, the entire game (even menus prior to loading a saved game) will freeze for a second or two randomly about every 5-10 seconds. It is completely playable still but a total buzz kill when it takes minutes vs. seconds to complete simple mouse clicks and commands. Its comparible to playing a first person shooter with HORRIBLE lag...

The laptop and OS in question here are :

Dell Inspiron 1764
-intel core i5 (M430 2.7ghz x2)
-4gb ram
-500gb hdd
-win 7 ultimate (64bit), sp1

There is a compatability mode utility built into this version of windows where it will trying running software in various ways simulating older versions of windows (ie. xp, 2000, vista) but, this doesn't change the choppy gameplay problem I'm having. I've tried different video resolutions, I've tried lowering the path search to 4000, I've tried running the game windowed using D3Dwindower, I've checked that it was only running the game on one processor (which it already was)...

So, here I am groveling for some more ideas or links to some magical fix that has GOT TO EXIST somewhere to fix this crap. I cannot believe the computer geeks and creators of IWD, IWD2, BDG, & BDG2 are just gonna watch these games become extinct due to newer PC's and OS's.

#11 -david allen-

-david allen-
  • Guest

Posted 11 August 2011 - 03:23 PM

try this, it worked for me

Hi all,

I managed to fix this problem for baldur's gate in vista by enabling software directdraw. Maybe it also works in XP and for other infinity engine games, I haven't tried. It'll only work for the 2d rendering engine (OpenGL mode won't work). After you've applied the fix, the game is very fast and without any artifacts. The fix is permanent. You don't need loader scripts or stuff like that.

Here's how to:
1. Download and install the microsoft application compatiblity toolkit:
http://www.microsoft...;displaylang=en
2. Start the 'Compatibility Administrator' with administrator rights.
3. Click the 'New' Button
4. Right click the new database. Select 'Create new application fix...'
5. Name your program and vendor however you like. Browse to your bgmain2.exe file. Click next
6. Select 'None' for operating system modes. Don't select additional compatibility modes. Click next
7. Tick the 'ForceDirectDrawEmulation' compatibility fix.
8. Click next and finish.
9. Save your database.
10. Right click the database and select install. This will install the database.
11. Close the compatibility administrator and start baldur's gate. It should work correctly in 32bit mode without any ingame rendering fixes. You don't need to run the compatibility administrator again.

#12 -Erik Veston-

-Erik Veston-
  • Guest

Posted 01 August 2013 - 06:21 AM

After a long time... I have come across some more details about the glitchy gameplay.  Supposedly it is due to the embedded intel graphics card in certain computers.  Supposedly, the game will play find on a system with any other graphics card.  I have not had the time or determination to try it out yet but, just thought maybe this info might help somebody else at least.



#13 aqrit

aqrit
  • Member
  • 132 posts

Posted 01 August 2013 - 08:01 AM

http://bitpatch.com/ie_ddrawfix.html



#14 -James-

-James-
  • Guest

Posted 09 February 2015 - 05:46 PM

@aqrit 's post- that worked perfectly.



#15 -Norter-

-Norter-
  • Guest

Posted 04 July 2015 - 01:33 PM

@aqrit thanks so much for that! I can finally play this game again! Option 2 fixed the issu for me. btw. i have the same slow down problems with Arcanum wonder if this patch could be aplied there hmm



#16 konva

konva
  • Member
  • 730 posts

Posted 07 July 2018 - 09:11 AM

Hi, i am forced to play IWD2 in wondowed mode, but still lagging... How could I fix that? Mine spec is:

CPU intel core i7-5820k 6x core, 12x threads, 2x RX 580 GPU, 32GB ram, 64-bit windows.

Why windowed mode? In fullscreen screen flickers, graphically unplayable, with windowed mode playable with large lags.

DDfix cant install, since its for 32bit software.



#17 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4602 posts

Posted 07 July 2018 - 09:49 AM

How could I fix that?
Reinstall the game into your Windows profile folder if you use the C drive, aka:
Windows 10; C:\Users\<konva>\Games\Icewind Dale\ ... the <konva> being the windows profile name you log into the computer. The "Games" folder can be named that, or "Pelit" or whatever you use as the same term on your language...
Win Vista; C:\Users\<konva>\Documents\Games\Icewind Dale\
...
The 32bit software works in Windows ... it just needs to be installed correctly, aka in the correct folder, as you don't have a full write permissions to non profile folders because Microsoft put a ring around the Operation System install folder, which is why you don't have a software usage licence, but end user licence.

Other methods you should look into, if you mod the game a LOTS, is to perhaps use Generalized Biffing.

Edited by The Imp, 07 July 2018 - 09:53 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#18 konva

konva
  • Member
  • 730 posts

Posted 07 July 2018 - 06:38 PM

well, i use tons of mods so C: folder isnt good, right? When i had previous graphic, it was R9 290 and it runs without problems, the problems started when I upgraded to 2x RX 580.



#19 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4602 posts

Posted 07 July 2018 - 10:58 PM

well, i use tons of mods so C: folder isnt good, right?
Well, the usage of the C drive is only tied to the Windows self intrests, in trying to protect the install drive from various hacks, rather than actual viruses.
But like said, if you use the user profile folder for your install, then it's ok. If you don't want to do that, then you need to use a different drive. And without this, mods won't even work. Cause they alterations made by mods are saved into a C:\Users\<konva>appdate\roaming\<install folder> files which only 64bit .exe's access when they run games, as in the old game is not a 64bit one, so it doesn't.

K, then, when you do that, and you can't think of further things to do, open up the .ini file(should be icewind2.ini or something like that) in the game directory with Notepad, copy paste the files content to a post, I'll look at it. This is the games internal configuration file, and we can see what we are dealing with.

Edited by The Imp, 08 July 2018 - 12:29 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#20 konva

konva
  • Member
  • 730 posts

Posted 08 July 2018 - 09:49 AM

okay, here is the config file:

Spoiler

For sure I also attach weidu log. Currently I can play game in windowed mode, with some compatibility options but its so small.. Without compatibility mine windows setup doesnt change but game lags

Attached Files