Jump to content

Nalia mod not working correctly? *small spoiler*

  • Please log in to reply
5 replies to this topic

#1 -Guest-

  • Guest

Posted 26 May 2007 - 11:26 AM

The problem:

So I started a new game killed the trolls in Nalia's keep and got control of it
(Once outside some love talk popped out about trying to comfort her about her father's death)

Saved the slaves in the 2 areas of the slums
(it says somewhere in the forums that I should do this to get the ball rolling but Nalia didnt say anything new that she didnt already say before the mod)

Went to her fathers funeral (*But Isea never came to abduct her afterwards*)

Did 3 keep quests (I finished the one where the priest of tempus wants to set up shop)
-the 4th quest is suppose to start when some on asks me to return to the keep immediately but this never happened yet and its been a long time (I spammed the rest button and forwarded to like 3-4 weeks and walked around in diffrent places) :S

Then after a few talks about Joseph, Nalia tells me about John being in trademeet
After the event in trademeet, Nalia tells me to go to the Noble Order of Radiant Heart (Temple District)

Once there Paladin Ryan Trawl tells me to go to Small Teeth Pass to find Joseph
(btw Ryan Trawl didnt tell me to do this until after I did the fallen paladin quest)

After the even in small teeth pass, Joseph asks who I (the PC) was and Nalia says something me and her having a marriage of convinence etc....
only we never did, I recall saying somethign about this when Nalia asks me to take control of the keep only she turns me down :S

So I'm thinkin something went wrong here....


1) When exactly is this marriage of convenience suppose to take place?

2) I still havent gotten Imoen back (I wanted to get a bit farther with the romance before I went to spellhold) am I suppose to get her back for romance stuff to kick in, like maybe there are somethigns that happen in the underdark to prgoress the romance?

3) Does this mod change the way that Nalia's quests work (since the 4th quest and the quest where she gets abducted by Isaea never kicks in)

4) Arnel's Site won't let me download the original (Non-Weidu) mod, dead link :S - I wanted to try this out to see if there was something wrong with the way the Weidu format of the mod got installed - is there anywhere else that I could get it?

What I did to try to fix it:

DSimpsons FAQ (IGN) says that sometimes the abduction sometimes doesnt trigger correctly (this problem not related with the mod) and that I could use CLUAConsole:CreateCreature("isaea") to trigger this event so I load an older save (before joseph in small teeth pass) and spawn Isaea and then Nalia gets abducted, after getting Nalia back I get some talk saying something about the marriage of convenience we had (only we still havent had it :S)

So I figured maybe somethign got messed up in installation (and when multiple mods get installed)

I havent done a full reinstall of the game yet, but I have made a clean back up
(ie AFTER installing the game and the official patch, and BEFORE installing mods, backed up the following files: baldur.ini, bgmain.exe, chitin.key, dialog.tlk, and the ENTIRE override folder. I red soemwhere awhile back that to restore the game to its original, unmodded state one can simply delete weidu.log and the ENTIRE override folder from the game directory, then copy the contents of the backup folder to the game directory, overwriting existing files.

After this I reinstalled only the nalia mod (the game seem to work ok) and I kill the trolls in her keep and then she asks me to take control of it, I suggest marriage of convenience and get turned down... again ... :(
Then I get the same talk about comforting her with her father's death but still no marriage of convenience...

PS: My main is a Fighter(berserker) "with charisma greater than 8" and I do have ToB installed
I am planning to do a full reinstall of the game but want my questions above answered so I can tell right away if the mod works correctly or not :S

Thanks for your time ill check back in a bit :D

#2 Oldwolf

  • Member
  • 141 posts

Posted 26 May 2007 - 11:53 AM

You don't have the needed files to do a restore with the files you backed up. This is where the list of files to back up can be found http://www.shsforums...showtopic=22966 and you don't have the Data folder backed up so I don't think you'll be able to restore cleanly. As for the rest of the info I can't help you with that. I don't install Nalia romance now but did you happen to install concurent romances and/or multiple strong holds? That might cause some problems. You might want to post your current Weidu log it'll help those who know spot possible problems.

#3 -guest-

  • Guest

Posted 26 May 2007 - 12:56 PM

The link u sent says:

Backing up large DATA folder is not ALWAYS necessary, but many mods check for biff files present there. If you're short on space or don't want to waste time copying it, then instead of deleting your current DATA folder you'll have to open it and manually delete only those biff files which were created by mods you have installed.

I guess whatever/wherever I red before (about clean restores) omitted that part so i have to reinstall :(

As for the weido log I deleted it as per the clean restore instructions :S
I figured clean restore + installing only the nalia mod itself would clear up any multi-mod install problems but as u said maybe it wasnt a clean restore.

No I didnt have any multiple stronghold/romance mods installed (I never have)

Ill post again once I've done a full reinstall and tried out Nalia mod again maybe something got messed up from a previous "clean" restore I've done.

btw thx for the link :D

#4 -guest-

  • Guest

Posted 26 May 2007 - 01:58 PM

So I uninstalled + Deleted all files inside BG2 Folder

Restarted Installed SoA + ToB + Patched

Made New Clean Back Up

After running the Setup-LuvNalia.exe I noticed something odd it says:


The modder uses \ in the wrong position in LuvNalia\BAF/VAMPAMB.BAF

The modder uses \ in the wrong position in LuvNalia\BAF\New

The modder uses \ in the wrong position in LuvNalia\Language/%s/BAF.TRA

Compiling 41 scripts ...

SUCCESSFULLY INSTALLED [Install Weidu version Arnel's Nalia Romance 1.06]

Press ENTER to exit


I can scroll up on the window and theres alot more lines all sayign the same thing about the wrong usage of the \

Not sure what it means :S

PS. Id still like questions in opening post to be answered :P

#5 -Guest-

  • Guest

Posted 26 May 2007 - 02:33 PM

tested Nalia's romance after the install and it works we got hitched after her father's funeral ;p

#6 Sir BillyBob

Sir BillyBob
  • Modder
  • 5315 posts

Posted 28 May 2007 - 06:21 AM

The Weidu install error messages are based on version changes of Weidu. The version I provided in this mod is now way out of date and the installer has changed some directory naming structures. It still works fine, just chucks up some error messages that aren't true. At some point, I may have to repackage this with a newer version of Weidu so the messages go away. Also, it seems that some journal entries are wrong due to some string reference problems. So I will have to clean that up as well.

Tired of Bhaal? Try some classics mods instead:
Classic Adventures
Official Classic Adventures Website