Jump to content


Photo

IE games and NVidia Series 8 video cards


341 replies to this topic

#1 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 17 December 2007 - 11:53 AM

Here is a list of the issues you'll encounter when playing any of the IE games with a NVidia 8 series card, and their resolution. It is possible that similar issues might arise even with other NVidia cards (apparently, 58xx and higher), but I haven't any experience with them, so I can't guarantee that they'll help
For all these games, I use the most powerful settings in the "Hardware" sliders (if you have a NVidia 8 series card, you likely have a 300 Mhz CPU ;)

BG2 and HoW (TotLM) are fixable directly from their config program:
BG2(SoA+ToB, including Tutu, Classic Adventures, and Big Mods): there are various graphical issues (black boxes and/or randomly-colored lines across the screen), which are solved with the following tweaks in BGConfig: Hardware -> Enable 3D Acceleration. Display -> 32 bit. 2d & 3d options: enable 3D Animations, 3D Acceleration and 32 bit textures, disable the Disable Vertex Padding option.
IWD1+HoW(with or without TotLM): I don't know if there are issues in this game; however, Graphics -> enable all save Sprite Mirroring didn't cause glitches.

For fixing BG1, IWD1 (without HoW), IWD2 and PST you can install this fixer utility (programmed by Eddy, WeiDUed by me): Attached File  nvidia_fix.zip   703.43K   35686 downloads
If you use this fixer utility, don't forget to remove the application profile in the Compatibility Manager (if you're using it, remove the profile like this: start -> programs -> Microsoft Application Compatility Toolkit -> Compatibility Administrator -> Installed Database -> right click and remove on the item you created) or stop using the .vbs launcher.

Ghostdog suggests to use a program called D3DWindower instead of the fixer - however, said program is not fully in english, and requires you to run said program every time you want to play. See instructions here.

Additionally, if you set up a profile for all applications in your Forceware Control Panel, you might want to set up a rule for your IE games so that every graphical option is "Application controlled" (for example Anti Aliasing) or Disabled (Triple Buffering).

Many thanks to the people who have provided solutions (even if they were later obsoleted):
Modron (VBS launcher)
Dazzle (Compatibility Administrator)
Eddy (.dll fix)
Ghostdog (D3DWindower)

Edited by the bigg, 23 December 2009 - 11:59 AM.

Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#2 berelinde

berelinde

    Troublemaker

  • Modder
  • 4916 posts

Posted 17 December 2007 - 03:56 PM

This applies to the Baldur's Gate series, the Icewind Dale series, and Planescape: Torment.
"Imagination is given to man to console him for what he is not; a sense of humor, for what he is." - Oscar Wilde

berelinde's mods
TolkienAcrossTheWater website
TolkienAcrossTheWater Forum

#3 Dinkleberry

Dinkleberry
  • Member
  • 3 posts

Posted 21 December 2007 - 03:31 AM

Hi, I'm going through an IE phase at the moment and I've just completed BG (First normally, then in Tutu, doing the ToTSC quests) and started on Planescape this morning. I'm running a 1.4Ghz Core 2 Duo Dell Vostro 1500 laptop with a Nvidia 8400 GPU. I'm having visual transparency issues which seem are resolved by the above method of turning on Software Transparency. However, doing this make the game quite sluggish - but only in full screen mode. When it's windowed I find it annoyingly small, but it works ok. Is there any hack to make it less jerky in full screen with that option enabled? I've just tried the Widescreen mod but it didn't seem to change much.

#4 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 21 December 2007 - 03:34 AM

Sorry, not much that can be done - Software Transparency Rendering is CPU bound, so there isn't much chance of this not being irreparably slow :(
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#5 Dinkleberry

Dinkleberry
  • Member
  • 3 posts

Posted 21 December 2007 - 03:55 AM

Ok doke. Cheers for the quick response. I'll dig out an old PC at some point and play it on there.

#6 Dinkleberry

Dinkleberry
  • Member
  • 3 posts

Posted 21 December 2007 - 06:23 AM

I just downloaded some graphics drivers that are only a week old and they seem to have fixed a lot of the transparency issues I was having. Instead of the inventory being almost unusable, there are black boxes bounding item icons - a minor issue. The clock in the lower left of the UI also used to look messed up but it has improved a little. The only major problem seems to be the fog of war occasionally becoming solid black squares, but flipping the map view on and off solves it. I recommend others to check the drivers out but as I'm on a laptop, the NVidia drivers were only available from the dell site for that laptop (NVidia have got a funny policy regarding drivers for portable cards).

#7 -Pater-

-Pater-
  • Guest

Posted 22 December 2007 - 08:19 PM

I get square-patterned lines if I enable 3D acceleration:

Posted Image


My BGConfig.exe don't seem to allow me to enable 32 bit and software rendering at the same time, so I've tried to follow the advices in the opening post here by editing the baldur.ini file. I've tried lost of ini switches, but I can't seem to be able to get rid of the lines if 3D acceleration is active.

I'm using this week's 169.71 drivers with an 8600GT Nvidia card. This is my baldur.ini:

[Program Options]
Installing=0
Install Type=1
BitsPerPixel=32
Font Name=
Double Byte Character Support=0
Drop Capitals=0
3D Acceleration=1
16Bit Textures=0
Display Frequency=85
Resolution=1024
Maximum Frame Rate=30
Path Search Nodes=400000
Tooltips=60
Translucent Shadows=1
Sprite Mirror=1
Gamma Correction=1
Brightness Correction=1
Backwards Compatible 3d=0
Volume Movie=100
Volume Music=100
Volume Voices=100
Volume Ambients=100
Volume SFX=100
SoftSrcKeyBltFast=0
SoftBltFast=0
SoftSrcKeyBlt=1
SoftBlt=1
SoftMirrorBlt=1
Strref On=0
First Run=0
GLSetup Driver=0
Force 50 Percent Transparent=0
Disable Brighten=0
Display Subtitles=1
Full Screen=1
Disable Vertex Padding=1

I'm a bit lost without the GUI. Can I try something else in the ini? What settings might be useful with the lines issue?

Regards

#8 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 23 December 2007 - 02:03 AM

Disable Vertex Padding=0.

bg2_graphics.PNG
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#9 -Pater-

-Pater-
  • Guest

Posted 23 December 2007 - 06:53 AM

I have it setup as in your screenshot and still seeing the lines. Weird.

#10 -Pater-

-Pater-
  • Guest

Posted 23 December 2007 - 12:47 PM

I have it setup as in your screenshot and still seeing the lines. Weird.


It was a matter of antialiasing. I have in Nvidia's control panel "4x" for "Antialiasing setup" and "Override application settings" for "Anatialiasing mode" as defaults for all applications. I set it to "Application controlled" for BGMain.exe and the lines are gone :rolleyes: Setting it to everything else save "Override application settings" is working here. So this setting seems to be the culprit of the squared lines here.

Maybe you can add to the first post that setting antialiasing mode to "Override application settings" with Nvidia 8 series cards may lead to lines in some cases.

Regards.

#11 -Sir Unimaginative-

-Sir Unimaginative-
  • Guest

Posted 22 February 2008 - 01:15 AM

Quick question: Is this problem isolated to the 8x00/8x50 series, or will it appear in any nVidia-driven PC which uses newer drivers?

#12 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 22 February 2008 - 08:58 AM

The games work fine with my brother's 4200Ti, and I only have a 8800 to test on, but I remember reading reports as back as the 58xx.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#13 -Penfold-

-Penfold-
  • Guest

Posted 06 March 2008 - 04:50 AM

I recently installed a 9600GT with drivers 174.16, and am getting the black boxish Fog of War, and the black corners around the time paused/unpaused rotating deal. I tried a lot of different settings in the nvidia control panel to try to get it working as normal. Software rendering works, but makes the game run painfully slow in places, which boggles my mind as I've got a Core2 Duo, and this game has minimum requirements of around a PII 300mhz. I've given up on trying to isolating it to a specific nvidia control panel setting. My current best fix that I use is below, and is similar to the first post, but turned down even further:

Display properities > Settings > Advanced > Troubleshoot > Hardware accelleration > None .--.--Y--.--.--. Full.

In this way the game runs as I'm used to, fast and no quirks at all. This wasn't necessary with my 7900GS, though it used slightly older drivers. IF YOU DO THIS, just remember, when you go to open your new games, and they don't open, it's because you need to crank up the accelleration back to Full. If its set as above for me, UT3, RS:V, etc simply won't open.

#14 -Penfold-

-Penfold-
  • Guest

Posted 06 March 2008 - 04:54 AM

Sorry, forgot to mention, the above is in regard to Icewind Dale 2 running on WinXP(32) SP2 Pro, but probably applies to many of the games using this engine when using 174.16 with the 9600GT i'd guess.

#15 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 06 March 2008 - 05:25 AM

Software rendering works, but makes the game run painfully slow in places, which boggles my mind as I've got a Core2 Duo, and this game has minimum requirements of around a PII 300mhz.

Well, there's an abyssal difference between softare (CPU) rendering and 'normal' (GPU) rendering. Your PII uses GPU rendering, which means the CPU tells the GPU to copy the 144x78 sprite starting at address 0x12356 into the image buffer at 234x432 and then goes on to calculate that monster's AI (and the GPU has multiple cores specialized in copying sprites, meaning that it'll do its work quickly), whereas in CPU rendering it's the CPU that has to copy the sprite in the correct position inside the image buffer and then send it all to the GPU (which takes a long time, and, to make matters worse, IE games don't take advantage of multiple cores and thus lock the 'smart' CPU in doing the 'stupid' GPU's work).

Regarding affected games, BG1 (w/ and w/o expansions), IWD1 (w/o expansions), IWD2 and PST use 2d rendering only, which is buggy in NVidia drivers and requires the slow workaround. BG2 (w/ and w/o expansion) and IWD1 (w/ expansion) has the option to use the non less buggy 3d rendering, thus making the games play great without too much tweaking.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#16 -Broseybrose-

-Broseybrose-
  • Guest

Posted 10 March 2008 - 06:38 AM

i have an 8800 and used the widescreen patcher and it installed no problem. i set the resolution to 1920x1200. the problem is that the majority of the screen is black, while the game runs in the little 640x480 corner in the upper left hand corner of the screen. is there a fix for this?

#17 -Broseybrose-

-Broseybrose-
  • Guest

Posted 10 March 2008 - 06:40 AM

i have an 8800 and used the widescreen patcher and it installed no problem. i set the resolution to 1920x1200. the problem is that the majority of the screen is black, while the game runs in the little 640x480 corner in the upper left hand corner of the screen. is there a fix for this?

oh the game is PS-Torment. thanks!

#18 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 10 March 2008 - 07:41 AM

I'm pretty sure that the documentation for WSM says explicitly what you do and don't get.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#19 -broseybrose-

-broseybrose-
  • Guest

Posted 10 March 2008 - 06:42 PM

I'm pretty sure that the documentation for WSM says explicitly what you do and don't get.

sorry for the double post.

im not sure what you meant by that, but i followed all instructions (full install, widescreen patch) to the letter. the widescreen patch says it will support any resolution greater than 800x600. so i entered in 1920x1200. im guessing by your response that you have no help to offer on this issue?

#20 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 11 March 2008 - 02:40 AM

You need to fully read the readme and the stuff it links to.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.



Reply to this topic