Jump to content


Photo

IE games and NVidia Series 8 video cards


341 replies to this topic

#21 -Klarth-

-Klarth-
  • Guest

Posted 12 March 2008 - 07:34 PM

BG1, 8600 card

I had the strange black boxes - advice from this thread got rid of them but resulted in unplayable framerates at every resolution I tried. Any suggestions, or do I just have to decide which is the lesser evil?

#22 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 12 March 2008 - 10:18 PM

Any suggestions, or do I just have to decide which is the lesser evil?

Yeah, or you could go with BGT, or BGTutu. But you need at least BG2:SoA (and BGTotSC and BG2:ToB, for BGT) for those.

I would go with the EasyTutu though, if you have the English version of the game, or with BGT. There is also a few fixes for them etc. , so read the ReadMe's and their forum stickies. Also patch the game.

The EasyTutu has the same basic things, that the BG1Tutu has, but it's just easier to install and uninstall and it creates it's own game so you can uninstall the BG1 and BG2 if you want, although it comes with only one language(english).

Edited by Jarno Mikkola, 13 March 2008 - 09:13 AM.

Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#23 -Klarth-

-Klarth-
  • Guest

Posted 13 March 2008 - 08:28 AM

Thanks for the advice.

Is EasyTutu something distinct from BGTutu or just another name for it or some setting within it?

#24 -Grateful DCameron-

-Grateful DCameron-
  • Guest

Posted 16 March 2008 - 11:31 AM

Just want to add that I'm using BG1+ToSC and BG2+ToB with an 8800GT. I followed the Config suggestions in the original post and achieved expected (but unsatisfying) results.

However, turning down Hardware Acceleration to the suggested level (the lower middle notch on the bar) gave perfect results in both games.

Definitely worth trying if you're having to decide between terrible perfomance or weird visual artifacts.

#25 -Guest-

-Guest-
  • Guest

Posted 16 March 2008 - 05:24 PM

I have an 8600m gs and I've got the black square fog of war. I found that turning on the first option in the game's visual settings, applying the change, then turning it back off removed the black square fog of war at least until you save or load. This does nothing for the black boxes around items, but that's something I can live with especially since my card doesn't support changing the hardware acceleration.

Anyway, I love the mod, so thanks for all the hard work.

#26 -Gavriel-

-Gavriel-
  • Guest

Posted 01 May 2008 - 12:04 PM

For people with NVIDIA 8x00 cards playing BGT:
I'd strongly reccomend using the Widescreen mod as it can set any resolution you want and some of them in windowed mode. There is just one problem I'll mention below. It seems that you get very low FPS even with those-so-mighty cards when you play in software rendered modes, so here is how to make vest use of both your card and WS mod:

First thing to do is to go in BGConfig and enable 3D in the last tab (makes the game run in 32-bit mode, so forget about software bliting mentioned above). Then enable 3D Animations and disable vertex padding below. Now run the test - if those color squares look ok then you are set. If you got heavy flickering, then do this:
- go to www.guru3D.com and download Riva Tuner from their download section. Hand downs this is the best NVIDIA tweak utility so far so please install it.
- after you run it for first time go to the software options (Main screen > Customize which is under Driver Settings > Open GL tab) and under VSync set the option to always off.
- you're set - run the BGConfig again and see if the squares flicker. If everything is good, hit apply and OK
- open baldur.ini (it is in the same BGII install folder as BGConfig) with Notepad or similar program and leave it opened for now

Now if you install the Widescreen mode, which is not good only for those of you with WS monitors but also for standard 5:4 (such as 17 and 19 inch TFTs) and set some resolution with it (it is rather self explanatory and has help, saves me some writing) everything that BGConfig wrote in baldur.ini. Now open baldur.ini again (do not close the old one) and see where there are diferences. In my config I set those in the newly opened baldur.ini

16Bit Textures=0
Resolution=1280BitsPerPixel=32
3D Acceleration=1
Disable Vertex Padding=1

Hit Ctrl+S (Save) and close the other Notepad window.

Run the game and hail whomever wrote that WS mod as it looks stunningly beautiful on Hi-Res screen w/o glitches. :Bow: :Bow: :Bow:

Hope that helps and please exuse my spelling, English is very far from being my native language.

gavriel <> neudobno.com

#27 -Gavriel-

-Gavriel-
  • Guest

Posted 01 May 2008 - 12:08 PM

Ican't edit this. Amongst other mistakes I've made I dropped this:
Now if you install the Widescreen mode, which is not good only for those of you with WS monitors but also for standard 5:4 (such as 17 and 19 inch TFTs) and set some resolution with it (it is rather self explanatory and has help, saves me some writing) everything that BGConfig wrote in baldur.ini will be gone.

#28 -hardyboy-

-hardyboy-
  • Guest

Posted 11 May 2008 - 11:01 AM

For people with NVIDIA 8x00 cards playing BGT:
I'd strongly reccomend using the Widescreen mod as it can set any resolution you want and some of them in windowed mode. There is just one problem I'll mention below. It seems that you get very low FPS even with those-so-mighty cards when you play in software rendered modes, so here is how to make vest use of both your card and WS mod:

First thing to do is to go in BGConfig and enable 3D in the last tab (makes the game run in 32-bit mode, so forget about software bliting mentioned above). Then enable 3D Animations and disable vertex padding below. Now run the test - if those color squares look ok then you are set. If you got heavy flickering, then do this:
- go to www.guru3D.com and download Riva Tuner from their download section. Hand downs this is the best NVIDIA tweak utility so far so please install it.
- after you run it for first time go to the software options (Main screen > Customize which is under Driver Settings > Open GL tab) and under VSync set the option to always off.
- you're set - run the BGConfig again and see if the squares flicker. If everything is good, hit apply and OK
- open baldur.ini (it is in the same BGII install folder as BGConfig) with Notepad or similar program and leave it opened for now

Now if you install the Widescreen mode, which is not good only for those of you with WS monitors but also for standard 5:4 (such as 17 and 19 inch TFTs) and set some resolution with it (it is rather self explanatory and has help, saves me some writing) everything that BGConfig wrote in baldur.ini. Now open baldur.ini again (do not close the old one) and see where there are diferences. In my config I set those in the newly opened baldur.ini

16Bit Textures=0
Resolution=1280BitsPerPixel=32
3D Acceleration=1
Disable Vertex Padding=1

Hit Ctrl+S (Save) and close the other Notepad window.

Run the game and hail whomever wrote that WS mod as it looks stunningly beautiful on Hi-Res screen w/o glitches. :Bow: :Bow: :Bow:

Hope that helps and please exuse my spelling, English is very far from being my native language.

gavriel <> neudobno.com


the game is still choppy, very low fps...didnt solve anything at all, only different resolutions. :unsure:

#29 -Bearclaw-

-Bearclaw-
  • Guest

Posted 12 May 2008 - 06:34 AM

For people with NVIDIA 8x00 cards playing BGT:
I'd strongly reccomend using the Widescreen mod as it can set any resolution you want and some of them in windowed mode. There is just one problem I'll mention below. It seems that you get very low FPS even with those-so-mighty cards when you play in software rendered modes, so here is how to make vest use of both your card and WS mod:

First thing to do is to go in BGConfig and enable 3D in the last tab (makes the game run in 32-bit mode, so forget about software bliting mentioned above). Then enable 3D Animations and disable vertex padding below. Now run the test - if those color squares look ok then you are set. If you got heavy flickering, then do this:
- go to www.guru3D.com and download Riva Tuner from their download section. Hand downs this is the best NVIDIA tweak utility so far so please install it.
- after you run it for first time go to the software options (Main screen > Customize which is under Driver Settings > Open GL tab) and under VSync set the option to always off.
- you're set - run the BGConfig again and see if the squares flicker. If everything is good, hit apply and OK
- open baldur.ini (it is in the same BGII install folder as BGConfig) with Notepad or similar program and leave it opened for now

Now if you install the Widescreen mode, which is not good only for those of you with WS monitors but also for standard 5:4 (such as 17 and 19 inch TFTs) and set some resolution with it (it is rather self explanatory and has help, saves me some writing) everything that BGConfig wrote in baldur.ini. Now open baldur.ini again (do not close the old one) and see where there are diferences. In my config I set those in the newly opened baldur.ini

16Bit Textures=0
Resolution=1280BitsPerPixel=32
3D Acceleration=1
Disable Vertex Padding=1

Hit Ctrl+S (Save) and close the other Notepad window.

Run the game and hail whomever wrote that WS mod as it looks stunningly beautiful on Hi-Res screen w/o glitches. :Bow: :Bow: :Bow:

Hope that helps and please exuse my spelling, English is very far from being my native language.

gavriel <> neudobno.com


the game is still choppy, very low fps...didnt solve anything at all, only different resolutions. :unsure:


No solution in this thread works, widescreen mod and bgsetup.exe isnt compatible, have you even tested it for real or are you just giving assumptions?

#30 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 12 May 2008 - 06:47 AM

No solution in this thread works, widescreen mod and bgsetup.exe isnt compatible, have you even tested it for real or are you just giving assumptions?

The two are compatible and I tested them.

And stop insulting me if you can't fix lag. If you want your whining to have any chances of bringing you a solution, whine in NVidia's general direction instead.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#31 -stewie-

-stewie-
  • Guest

Posted 12 May 2008 - 10:56 AM

No solution in this thread works, widescreen mod and bgsetup.exe isnt compatible, have you even tested it for real or are you just giving assumptions?

The two are compatible and I tested them.

And stop insulting me if you can't fix lag. If you want your whining to have any chances of bringing you a solution, whine in NVidia's general direction instead.


just to be sure, all i need to do is: install BGT whitch means i need to install both BGs with both expansions, then instal widescreen mod and then it will be playable - not choppy with no black squares. Is that right? Its just that i tried BG2:SoA+ToB with widescreen and it didnt work so i wanna know if BGT will fix that.
Thanks

#32 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 12 May 2008 - 12:39 PM

Just to be sure, all i need to do is: install BGT whitch means i need to install both BGs with both expansions, then instal widescreen mod and then it will be playable - not choppy with no black squares. Is that right? Its just that i tried BG2:SoA+ToB with widescreen and it didnt work so i wanna know if BGT will fix that.

No, it won't work that way, to get rid of the black boxes in BGT and other BG2 based mods, you need to:

BG2(SoA+ToB, including Tutu, Classic Adventures, and Big Mods(BGT)): there are various graphical issues (black boxes and/or randomly-colored lines across the screen), which are solved with the following tweaks in BGConfig: Hardware -> Enable 3D Acceleration. Display -> 32 bit. 2d & 3d options: enable 3D Animations, 3D Acceleration and 32 bit textures, disable the Disable Vertex Padding option.

Now, to do that start the just installed and patched game with the BGConfig.exe, put the options as said in the quote and check that they work with the game, by starting a new game. If they don't and you are using Windows Vista, you have this because you haven't disabled the User Account Control, so disable it. Now, once you have the original game working properly, you can use the mod.

And just that it becomes clear, if you use the Widescreenmod, it really doesn't matter what resolution you set with the BGConfig.exe, so it is best to leave it at the first standard setting, the 640x480! As you'll change it later with the WSM.

Edited by Jarno Mikkola, 12 May 2008 - 01:05 PM.

Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#33 -stewie-

-stewie-
  • Guest

Posted 13 May 2008 - 08:38 AM

Now, to do that start the just installed and patched game with the BGConfig.exe, put the options as said in the quote and check that they work with the game, by starting a new game. If they don't and you are using Windows Vista, you have this because you haven't disabled the User Account Control, so disable it. Now, once you have the original game working properly, you can use the mod.

And just that it becomes clear, if you use the Widescreenmod, it really doesn't matter what resolution you set with the BGConfig.exe, so it is best to leave it at the first standard setting, the 640x480! As you'll change it later with the WSM.


i did everything exactly as you told me to but i still get like 5 FPS :unsure: :crying:

#34 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 15 May 2008 - 06:03 AM

I did everything exactly as you told me to but i still get like 5 FPS :unsure: :crying:

Well, did you turn the Vertex sounds off?(all the way to the left in Sound Options) This has reported to cause huge lags on few areas. Other cures are getting rid of too many items on one stack(200-500+, including bags of holding, arrows etc.) Dropping items that have their own voice, dialog box etc.(Lilarcor)
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#35 -stewie-

-stewie-
  • Guest

Posted 15 May 2008 - 09:14 AM

I did everything exactly as you told me to but i still get like 5 FPS :unsure: :crying:

Well, did you turn the Vertex sounds off?(all the way to the left in Sound Options) This has reported to cause huge lags on few areas. Other cures are getting rid of too many items on one stack(200-500+, including bags of holding, arrows etc.) Dropping items that have their own voice, dialog box etc.(Lilarcor)


i tried turn all sounds off whitch helped a little but still low fps. Heres how the game looks with 3D acceleration off:
Posted Image
if there was way to get rid of those black boxes i would be happy :whistling:

#36 -DerbyCore-

-DerbyCore-
  • Guest

Posted 18 May 2008 - 03:45 AM

I was having significant problems playing BG1 on an 8800GTS (512MB version) game was unplayable, black boxes everywhere and rediculus fps. Now no problems at all so thought i'd post the process i took.

Full install all the games like Tutu says and get latest patches for ToSC and ToB. install EasyTutu.

My config settings are as followed:
Hardware:
Use 3D Acceleration [Enabled]
Automated Speed Adjustment [Enabled]
All Bars to Maximum

Graphics>3D Options:
3D animations [Enabled]
use 3d accleeration [Enabled]
Driver : Default OpenGL Driver
32 Bit Textures [Enabled]
Disable Vertex Padding [Disabled]

For me these settings are giving outstanding quality with no display faults and in up to 1024x768 excelent FPS.

I am currently using a very old monitor which is dying and will no longer support 1280x980 correctly for some reason although it should also run fine with these settings on that resolution



I am not saying that these settings will work with anyone else just that they work fine with my card, from what i have read these settings wll not work with older cards in the 8000 series but feel free to try.


-DC-

#37 -Skinny-

-Skinny-
  • Guest

Posted 27 May 2008 - 03:30 PM


Works with my 8800 GTS 640MB as well. Had to force Vertical Sync off in the Nvidia control panel going along with what Gavriel was saying. The main menu flickers but from there it's smooth sailing.

#38 -Jollyman-

-Jollyman-
  • Guest

Posted 30 May 2008 - 11:00 PM

Okay, unique problem here.

In BG2, I'm playing through it just fine at 1920x1200, no graphic problems or anything of that nature. Really, there aren't any problems at all with the game itself, the problem lies with the main menu screen:
Posted Image

It doesn't really interfere with the main menu, it acts like a mask overtop of the menu buttons. Luckily, I've played the game so much that I have it ingrained into my skull where the locations of the buttons are, but it's still a pretty large inconvenience. It only displays that blank window when I play at the native resolution. I don't want to play in windowed mode and I don't want to make everything blurry by playing in some lesser res.

I've followed all the other suggestions given in this forum and nothing works.

So... any ideas or thoughts?

#39 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3325 posts

Posted 31 May 2008 - 03:38 AM

Ouch. The menu gui files (such as that one) aren't touched by WSM, in any event. I'm going to do something uprecedented in the history of the modding comunity and suggest you to fully uninstall your game and reinstall from the disks :)
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#40 Elsok

Elsok
  • Member
  • 29 posts

Posted 10 June 2008 - 02:34 PM

Hail to "the bigg".!! I want thank you for this thread! Following your instructions has totally fixed BG TotSC for me on my new computer....I am running Windows Ultimate SP1 w/dual Nvidia 8800 gts in SLI mode.... I had the black squares on everthing from fog of war to birds flying in the air to interface control panel.....I followed your instructions to the letter and now the game is back to normal again......I also followed a link from one of the posters above and installed the BG Easy Tutu ToB and what can I say I am soooo blown away by how great the game visuals are now with this MOD.Again thanks for all your help!

Edited by Elsok, 10 June 2008 - 02:36 PM.




Reply to this topic