Jump to content


Photo

IE games and NVidia Series 8 video cards


341 replies to this topic

#41 -modron-

-modron-
  • Guest

Posted 17 June 2008 - 02:31 AM

Does anybody of a program like powerstrip or rivatuner, in which I can create a profile for the bgmain2.exe, so that I don't have to disable the directdraw/hardware acceleration manually each time I want to play the game? The both mentioned programs don't seem to have that option.

#42 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3327 posts

Posted 17 June 2008 - 02:42 AM

I don't know anything about them.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#43 modron

modron
  • Member
  • 2 posts

Posted 17 June 2008 - 11:06 AM

nevermind, I gave a try on easytutu, works great for me =)

#44 -evilsofa-

-evilsofa-
  • Guest

Posted 30 June 2008 - 03:12 AM

Turning off Vsync for BG2+ToB is KEY. This is likely true for all of the IE games but I haven't tried any of the others.

In the latest nVidia driver's Control Panel, you get to set up individual preferences for each application (don't need Riva Tuner anymore). For BG2+ToB, you'll want to force off Vsync for baldur.exe AND bgmain.exe at the very least.

If the initial screen where you select Shadows of Amn or Throne of Baal is flashing, you need to turn off Vsync for bgmain.exe.

It may be easiest to just go to the nVidia Control Panel's Global Application setting and force off Vsync there. When I do that, the flashing is gone even from the test in BGConfig. If you are playing other games for which you want Vsync on, you'll need to make sure that their settings in the nVidia Control Panel override the Global Application setting.

If you run BGConfig after installing the Widescreen v1 mod, the game will revert back to a non-Widescreen resolution (likely 800x600). To fix this, simply run the setup-widescreen.exe that you left in the main SoA folder again, and ®einstall the mod with the resolution you want. So, basically, set what you need to in BGConfig, then install the Widescreen mod and don't open BGConfig again.

I have not actually played into the game beyond the first moment I can save, so I have no reports on any other glitches yet. When I've played into the game some, I'll post more specifics. I'm running WinXP SP3 on an 8800GTX.

#45 -evilsofa-

-evilsofa-
  • Guest

Posted 02 July 2008 - 09:24 PM

I had one thing backwards - baldur.exe is the app where you get the choice between SoA and ToB; bgmain.exe is the actual game executable. This turned out to be important for setting up the Logitech G15 keyboard.

The widescreen mod alters at least some of the settings in baldur.exe, like Subtitles and More Feedback, so I have ended up just manually editing the baldur.ini file after installing (or re-installing) the widescreen mod.

I've played into the game awhile and everything seems to be working perfectly.

#46 -Guest-

-Guest-
  • Guest

Posted 04 July 2008 - 02:23 PM

What an awesome mod, mille grazie!

Using a 8800 GTS 640 MByte with the latest drivers and a middle of the road Dual Core CPU.

The key to error free display is creating a profile for each IE game you're playing and to turn every setting off in the Nvidia control panel.

Thanks again - gonna finally finish BG2 and ToB. :D

#47 -pogothemonkey--

-pogothemonkey--
  • Guest

Posted 10 July 2008 - 11:36 AM

Thanks so much for the mod, it made my last play through of BG2 great.

That said, I cant get it to work now. Since reinstalling the entire game, I cant find a resolution that works. Every resolution that is supported by my monitor comes out looking like this:
Posted Image
(1680x1050)

I have a 7800 GTX and am running XP with a 24" widescreen (16:10) monitor. I dont have any of the black box problems and my framerate is fine. I just cant find a resolution that works in fullscreen.

#48 -pogothemonkey0-

-pogothemonkey0-
  • Guest

Posted 10 July 2008 - 11:41 AM

Sorry to double post, but I have something else to add.

I have trouble changing my resolution settings through the mod. I run the setup.bat, and select reinstall. This however, starts a chain where it uninstalls and reinstalls every mod I have. It is a very lengthy process and makes changing my resolution (I have to change often because none work) very painful.

I am sure there is some very obvious solution that will make me feel like an idiot though.

#49 Icendoan

Icendoan

    "An Infinite Deal of Nothing"

  • Member
  • 1723 posts

Posted 10 July 2008 - 12:05 PM

Yeah. Either install last or get rid of your other mods.

Icen
Proud member of the 'I HATE Elminster!' Club!

Mods in development: Keeping Yoshimo

#50 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 10 July 2008 - 12:52 PM

That's uninstall the widescreen mod from the middle first, and then install it as the last mod. You'll get that kind of picts where the GUI is messed up when you install, a GUI alteration mod. :doh:
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#51 -Oggranak-

-Oggranak-
  • Guest

Posted 22 July 2008 - 07:48 PM

I see much of this thread focuses on Baldur's Gate. My problem is with Icewind Dale II. Doing everything stated does allow me to eliminate graphical glitches, but not the framerate is horrendous. I noticed mods and the like played a large part in make Baldur's Gate playable- do such things exist for Icewind Dale II?

#52 -Oggranak-

-Oggranak-
  • Guest

Posted 22 July 2008 - 07:49 PM

now*

Sorry for the double post.

#53 MrToughGuy

MrToughGuy
  • Member
  • 31 posts

Posted 22 July 2008 - 08:57 PM

From the looks of things, I seems the key to overcoming the black box issue in BG without the framerate dropping is to use Tutu. I guess I'll try that tomorrow. Otherwise, it's a great mod. :cheers:
Posted Image

#54 -digibron-

-digibron-
  • Guest

Posted 02 August 2008 - 05:54 AM

I recently installed a 9600GT with drivers 174.16, and am getting the black boxish Fog of War, and the black corners around the time paused/unpaused rotating deal. I tried a lot of different settings in the nvidia control panel to try to get it working as normal. Software rendering works, but makes the game run painfully slow in places, which boggles my mind as I've got a Core2 Duo, and this game has minimum requirements of around a PII 300mhz. I've given up on trying to isolating it to a specific nvidia control panel setting. My current best fix that I use is below, and is similar to the first post, but turned down even further:

Display properities > Settings > Advanced > Troubleshoot > Hardware accelleration > None .--.--Y--.--.--. Full.

In this way the game runs as I'm used to, fast and no quirks at all. This wasn't necessary with my 7900GS, though it used slightly older drivers. IF YOU DO THIS, just remember, when you go to open your new games, and they don't open, it's because you need to crank up the accelleration back to Full. If its set as above for me, UT3, RS:V, etc simply won't open.

I found another (similar) solution.

I'm running a Dell Inspiron 1520 with 2.4Ghz dual processor, 3GB RAM and a GeForce 8600M GT graphics card. My problem (it sounds like it's a common one) was trying to run Baldur's Gate TotSC with the widescreen mod smoothly and without any video glitches. After spending most of the day trying to fix it, I was just about resigned to the fact that I'd have to choose between:

1. Full screen with jerky character movement but no visual glitches (transparency turned on)
or
2. Full screen with smooth character movement and visual glitches (transparency turned off)

And I didn't want to try tutu because I love the BG GUI. (Fond memories and all that!) Anyway, at the end of a long day, I found a solution:

Keep software transparency on, but run dxdiag and disable DirectDraw Acceleration.

It works like a charm for me! I tried Penfold's solution as well, to compare, but I found it made horizontal and vertical scrolling flickery.

Hope this is useful to someone!

Bronwen

#55 modron

modron
  • Member
  • 2 posts

Posted 03 August 2008 - 02:25 AM

I've made a little vbs script for turning the directdraw acceleration off before starting the game, and after you quit it it will become activated again:

set bgdx = CreateObject("Wscript.shell")

bgdx.run("dxdiag.exe")
wscript.sleep 5000

bgdx.sendkeys ("{TAB}{RIGHT}{RIGHT}")
wscript.sleep 500

bgdx.sendkeys ("{TAB}{TAB}{TAB}{TAB}{TAB}{ENTER}")
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 500

bgdx.Run "bgmain2.exe", 1, True
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 1500

bgdx.sendkeys ("%{F4}")



The delays might have to be adjusted to your computer, but it should work.
Copy the code into a bg.vbs file and place it in your BG directory.

=)

Edited by modron, 03 August 2008 - 02:41 AM.


#56 the bigg

the bigg

    2083 is a prime number.

  • Modder
  • 3327 posts

Posted 03 August 2008 - 02:36 AM

Added to top post.
Italian users: help test the Stivan NPC!

Author or Co-Author: WeiDU - Widescreen - Generalized Biffing - Refinements - TB#Tweaks - IWD2Tweaks - TB#Characters - Traify Tool - Some mods that I won't mention in public
Maintainer: Semi-Multi Clerics - Nalia Mod - Nvidia Fix
Code dumps: Detect custom secondary types - Stutter Investigator

If possible, send diffs, translations and other contributions using Git.

#57 -Guest-

-Guest-
  • Guest

Posted 23 August 2008 - 01:56 AM

Verry strange... I used both 6600GT and 8600GT and never had one of these problems, never! recently tested your mod with the 6600GT -> nothing wrong. I've got all hardware settings on maximum, I think. I might look at this further.

#58 -Penfold-

-Penfold-
  • Guest

Posted 29 October 2008 - 12:42 AM

I read that the widescreen works with the BG1 expansion. I've installed the expansion using "custom" and checking every box. But when I run the setup program, it prompts me with a BG _2_ expansion folder, that of course, doesn't exist. When I select the BG1 folder (expansion installs to original folder) the CMD window gives an error about not finding a BG _2_ file...

How do I force the program away from it trying to install BG _2_ mod and toward installing the BG _1_ expansion? (FTR, the dropdown box only lists the BG2 expansion directory)

#59 Icendoan

Icendoan

    "An Infinite Deal of Nothing"

  • Member
  • 1723 posts

Posted 29 October 2008 - 01:39 AM

I have no problems with a 9300GX.

Icen
Proud member of the 'I HATE Elminster!' Club!

Mods in development: Keeping Yoshimo

#60 -Guest-

-Guest-
  • Guest

Posted 01 November 2008 - 11:52 AM

I've made a little vbs script for turning the directdraw acceleration off before starting the game, and after you quit it it will become activated again:

set bgdx = CreateObject("Wscript.shell")

bgdx.run("dxdiag.exe")
wscript.sleep 5000

bgdx.sendkeys ("{TAB}{RIGHT}{RIGHT}")
wscript.sleep 500

bgdx.sendkeys ("{TAB}{TAB}{TAB}{TAB}{TAB}{ENTER}")
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 500

bgdx.Run "bgmain2.exe", 1, True
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 500

bgdx.sendkeys ("{ENTER}")
wscript.sleep 1500

bgdx.sendkeys ("%{F4}")



The delays might have to be adjusted to your computer, but it should work.
Copy the code into a bg.vbs file and place it in your BG directory.

=)
How do you make this bg.vbs file



Reply to this topic