Jump to content


Can't talk to annah


47 replies to this topic

#41 scient

scient
  • Modder
  • 1010 posts

Posted 25 October 2008 - 11:22 AM

I think the issue is caused by Qwinn's banter accelerator conflicting with the engine's own banter code. If this is the case then yes next release will fix it. I located where banter code is handled in engine and can effectively disable it. It will only be disabled if you opt to install Qwinn's banter accelerator. However, Qwinn prob has a better idea of what is causing this then I do.

Edited by scient, 25 October 2008 - 11:22 AM.

Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#42 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 25 October 2008 - 02:44 PM

The next version will change the way banters are done altogether. Principally, it's going to disable the way the original game produced banters (via the engine) altogether, replacing it with my system. No, I was not able to determine what caused the problem, but I do suspect it was the engine banter system that did it (or the way the engine system and my system interacted), and so I'm hoping that it won't be a problem in future versions.

Qwinn

#43 Alkenphial

Alkenphial
  • Member
  • 2 posts

Posted 06 March 2011 - 05:29 AM

Hello, to whomever I may ask the question at this point. I'm not sure if this is the best place to put this. I don't mean to necrobump an old thread, but I am hoping to find an answer, or perhaps a link to the proper place. I can't seem to find any places where someone has asked this before now.

I am using all of the most recent fixes. PST-Fix 4.11 as well as the most recent versions of PST:T, and PST:UB. It isn't a crash, but some NPC's won't talk to me. Ebb Creakness for example. In the Smoldering Corpse Bar he would talk. Though, when I entered the Carceri Warehouse he refused to talk. Regardless of how many times I left the Warehouse(AR0902) and returned. TNO would only walk up to him in the warehouse and no dialogue would start. I don't think Ebb Creakness has a banter file, but I may be wrong.

I beg pardon if I am posting this where it doesn't belong. I am fairly new to this forum.

#44 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 04 September 2011 - 01:10 AM

Creakknees in Carceri has been a continuous problem, really thought I had it sorted in the last version. He's actually kinda buggy even without my mods. Sorry that I responded so late, but if you do see this, some info like what your alignment was and what factions you had joined and left would be helpful in figuring out what combination of events is setting that off - he's got a pretty complex set of conditions for his opening dialogue based on those things and a few other variables. I think the big one is, did you ever join and piss off the anarchists in Sigil, did you piss off the printer by talking lawful such that he throws you out, or did you betray the anarchists even if you didn't join (which my fixpack enables), etc. Thanks in advance.

#45 Adamaxis

Adamaxis
  • Member
  • 1 posts

Posted 06 September 2012 - 04:51 PM

Hey, thanks Qwinn. I had the stopped-up dialogue problem with Morte - he wouldn't talk to me at all and after I dismissed him from the party, I couldn't talk to him at all - your BANTER.BAF thing fixed it.

#46 Alkenphial

Alkenphial
  • Member
  • 2 posts

Posted 30 September 2012 - 12:11 AM

Wow, this was about a year ago, I don't remember, but maybe it was that I pissed off the anarchists. I think my guy went neutral good or lawful good. Details are rather foggy. I did run into some errors at the end of the game though that I can remember. My guy glitched into a black screen with the last boss, and once I killed the boss then the game crashed to desktop, it was weird.

#47 Ward Dragon

Ward Dragon
  • Member
  • 1 posts

Posted 18 January 2013 - 04:48 AM

Hello.  First of all I wanted to thank you for making the tweak pack, and for continuing to support it :D

 

I had a similar problem which was driving me crazy, but after a few hours of searching I found this thread and was able to fix the problem by following the steps in Post #38.  I figured it might be helpful if I gave you the details of what happened in case it helps you to troubleshoot the issue (or in case anyone else is having the same problem and didn't realize that the issue was Grace not being able to speak).

 

I followed the mod installation guide on GOG so I have pstweak_v412 installed, along with pstfixpack_v413, pstub_412, ws_crash_fix, and GhostDog's-PST-UI. 

 

My problem involved Grace not speaking which prevented a critical dialogue scene from playing and made it impossible to continue the game with her in the party.  It's near the end of the game so I'll put it in spoiler tags :)

 

Spoiler

 

That's when I searched and found this thread.  The earlier banter fix did not work, but the file in Post #38 did the trick and I've now gotten past that part of the game without having to leave Grace behind :D


Edited by Ward Dragon, 18 January 2013 - 04:54 AM.


#48 -miezulcarpatin-

-miezulcarpatin-
  • Guest

Posted 07 August 2014 - 11:16 AM

Hi. Sorry for bringing back such an old topic, but I seem to encounter the same problem. After merging with TTO and resurrecting Annah, she approaches me and dialogue does not initiate and so the others don't resurrect as well.

 

I first noticed this issue just before entering through the portal in the FoR. I tried reforming my party, but if I left Annah behind, I couldn't talk to her anymore.

 

The fixes on this thred did not help, sadly :)

 

Any assistance would be appreciated





Reply to this topic