Jump to content


Photo

Please report crashes here


257 replies to this topic

#1 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 25 November 2008 - 07:10 PM

Before there were any mods, people with the 2 disc version of the game have been reporting crashes entering the Curiosity Shoppe and the Apothecary.

Platter's Fixpack -may- have resolved this problem by putting those area files in the override directory. My mod does also, as well as thebigg's widescreen mod. Is it still a problem? We don't know. Testing with the 2CD version seems to indicate it's not a problem. Recent reports of similar problems have been contaminated by issues such as modding the game after those areas were already entered and became part of save games, which is not a good thing to do and is expected to cause crashes.

So - is there anyone out there who -has- had these crashes with any of the relevant mods installed? If so, please let us know. For the time being, until we can get a confirmed report of this crashing still happening, and we can confirm there weren't any nasty side issues like mid-game modding that would explain it, I'm going to consider this issue closed.

If it -is- happening to you, please let us know. It's not that we don't care. It's that we don't want to beat our brains out trying to fix a problem that we can't duplicate.

Thanks all.

Qwinn

#2 scient

scient
  • Modder
  • 1010 posts

Posted 25 November 2008 - 07:35 PM

I'm also interested if anyone experiences crashes related to entering the Mortuary. Specifically saved games. I'm not sure if this is still present after Qwinn's mods or not.
Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#3 -The_Secret-

-The_Secret-
  • Guest

Posted 24 January 2009 - 05:38 AM

I also have crashes when I am entering the curiosity shop. I also moded the game AFTER I visited this place.

#4 taplonaplo

taplonaplo
  • Member
  • 90 posts

Posted 24 January 2009 - 06:03 AM

do you have the widescreen mod installed? it requires a new game for some area related reasons (like the curiosity shoppe).

#5 scient

scient
  • Modder
  • 1010 posts

Posted 24 January 2009 - 07:40 AM

You can try the two patches here but the best solution like tap said is to start a new game.
Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#6 gothemasticator

gothemasticator
  • Member
  • 54 posts

Posted 25 January 2009 - 11:25 PM

CTD when casting Elysium's Tears at Many-As-One.

I think his leaving the area coincided with the beginning of the spell animation. I couldn't reproduce it, but wanted you to know.

gothemasticator

#7 scient

scient
  • Modder
  • 1010 posts

Posted 26 January 2009 - 10:54 AM

CTD when casting Elysium's Tears at Many-As-One.

I think his leaving the area coincided with the beginning of the spell animation. I couldn't reproduce it, but wanted you to know.

gothemasticator


Do you remember if it gave any error code or line number? Or was it crash with no error? I think sometimes when there is a crash it creates a log file in PST directory.
Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#8 gothemasticator

gothemasticator
  • Member
  • 54 posts

Posted 26 January 2009 - 12:42 PM

Crash with no error. Sorry, not much to go on.

Also, I played through that scene several more times last night and really couldn't reproduce the behavior. On subsequent tries, if the spell animation started as Many-As-One was leaving, he would just leave and the spell animation would quit. No crash, though.

gothemasticator

#9 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 26 January 2009 - 12:56 PM

Are you using an NVidia card?

The same issues that cause graphic problems casting spells on NVidia cards also occasionally produces CTD's.

Qwinn

#10 gothemasticator

gothemasticator
  • Member
  • 54 posts

Posted 26 January 2009 - 04:25 PM

I am using an NVidia graphics card. That explains it, huh?

gothemasticator

#11 -Poetic planescape-

-Poetic planescape-
  • Guest

Posted 31 January 2009 - 07:03 AM

The game plays perfectly BUT whenever I exit the game, it shows a windows has encountered an error crash.

Crash on exits aren't a big deal but they are sometimes the symptoms of a more serious bug. :huh:

#12 -Poetic planescape-

-Poetic planescape-
  • Guest

Posted 01 February 2009 - 05:35 PM

:crying: No ideas as to how to fix the crash on exit ? Do I have to just live to with it?

#13 scient

scient
  • Modder
  • 1010 posts

Posted 01 February 2009 - 06:39 PM

What OS and do you have an NVIDIA card? Are you running any mods besides fixpack/UB/tweak pack say like UI mod? Does it always crash even if you don't load up a game? Say you start game up and then exit out from menu without loading or starting a game. Lastly, have you tried doing a reinstall?
Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#14 -Poetic planescape-

-Poetic planescape-
  • Guest

Posted 01 February 2009 - 08:22 PM

What OS and do you have an NVIDIA card? Are you running any mods besides fixpack/UB/tweak pack say like UI mod? Does it always crash even if you don't load up a game? Say you start game up and then exit out from menu without loading or starting a game. Lastly, have you tried doing a reinstall?



Windows Vista 32. I'm suspecting that Vista is the culprit. I'm not using an Nvidia card.

I'm only using Quinn's fixpack/ub/tweak and the widescreen and UI mod. I've already tried uninstalling both the widescreen and the UI mod, and it still crashes on exit. Maybe this means that those mods are not the issue?

Yes, it ALWAYS crashes on exit even if I don't load or start a game. :(

#15 scient

scient
  • Modder
  • 1010 posts

Posted 02 February 2009 - 04:02 PM

Have you given PST the proper permissions? I believe it needs access to windows folder. The mods have already been tested on a vista box so I'm pretty sure it's an issue specific to your setup. I personally use XP so perhaps someone with more vista knowledge can help you out.
Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.

#16 gothemasticator

gothemasticator
  • Member
  • 54 posts

Posted 05 February 2009 - 11:06 AM

I've had two CTDs in the Fortress of Regrets. 1) when Ignus and TTO appear on screen 2) when Dakkon is overwhelmed by shadows. No error reports either time, just CTD.

I'll try the Fortress again tonight, see if there's any new info.

gothemasticator

#17 -Nicopathe-

-Nicopathe-
  • Guest

Posted 07 February 2009 - 11:15 AM

In Ps:T, installed with Fixpack, Tweaks, UB and Ghostdog's UI, i got a crash with the cranium rats :
First, the rats graphics are absent, i only see the red outline around them... then when i click upon the "invisible" rats, the game crashes very often. :angry:

Any idea of the problem? I got a Nvidia Graphics 7600.

Thanks for help!

#18 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 07 February 2009 - 04:39 PM

No idea, I'm afraid. I don't do anything to the rat graphics in the game. I also have an NVidia 7600 (GS).

I would guess a file got corrupted during install?

Qwinn

#19 gothemasticator

gothemasticator
  • Member
  • 54 posts

Posted 08 February 2009 - 06:20 PM

FYI, I just played through the fortress/endings half a dozen times. No crashes and everything seems to be working just great!

gothemasticator

#20 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 09 February 2009 - 03:09 PM

Glad to hear it!

So, since you're done now, any opinions / suggestions / criticisms overall?

Qwinn



Reply to this topic