Jump to content


Photo

CD-check problem


  • Please log in to reply
37 replies to this topic

#21 -Guest-

-Guest-
  • Guest

Posted 15 March 2009 - 01:15 PM

OK, after a bit of searching around, I found that the generic IE patcher does not work with Qwinn's Fixpack ; however, mofo's 1.1 patcher, also widely available, will do the trick !

Fred

#22 Ieo

Ieo
  • Member
  • 7 posts

Posted 23 March 2009 - 03:09 PM

I do use a no-CD patch, applied after the 1.1 patch and before any mods, to save wear and tear on my disks (I have to do a lot of reinstalls for real, so), and I applied the widescreen and ghostdog's UI mods first, -then- my 3 mods,


Hi Qwinn,

first, thanks for those great mods : the game really benefits from all those fixes and restorations !

I've tried what you described in order to be able to keep my CD in its box, however, there seems to be a glitch : I install PsT, patch it to 1.1, then apply a no-CD, followed by widescreen+PST UI. I am then able to launch the game without the CD2 check. However, as soon as I install your fixpack, the check reappears ! This is on a fresh install, using a generic infinity engine patcher for the no-CD.

Any ideas of why it wouldn't work on this setup ? Am I doing something in the wrong order ?

Thanks in advance,
Fred


Alright, I'm running into this problem now that I downloaded and installed the 3.02 fixpack as well. I have the 2-CD version of PST and used the 2-CD nocd crack (running on laptop), but as soon as I used the fixpack, it asked for CD2.

I have various parts of the Tweaks/UB mods installed as well. Neither Platter 2CD crack nor the mofo patcher worked for me after applying the fixpack; scient's tip up there didn't work either.

I don't know what sort of edits were made to the torment.exe itself with the fixpack, but I've reverted to my old, original 2-CD cracked version for now. Hopefully that won't cause problems down the line.

#23 scient

scient
  • Modder
  • 1010 posts

Posted 23 March 2009 - 06:07 PM

Alright, I'm running into this problem now that I downloaded and installed the 3.02 fixpack as well. I have the 2-CD version of PST and used the 2-CD nocd crack (running on laptop), but as soon as I used the fixpack, it asked for CD2.

I have various parts of the Tweaks/UB mods installed as well. Neither Platter 2CD crack nor the mofo patcher worked for me after applying the fixpack; scient's tip up there didn't work either.

I don't know what sort of edits were made to the torment.exe itself with the fixpack, but I've reverted to my old, original 2-CD cracked version for now. Hopefully that won't cause problems down the line.


Tried a reinstall? Done a full install or made sure ini paths are correct to files? You will get none of the engine fixes if you do that and could easily cause problems with morale. The one time I loaded a saved game post patch into vanilla game there were issues with npc's going perma yellow. Since I rewrote the system from scratch it is not compat with vanilla game. Also, any morale gains above or below 10 for PC's like Dak will be reverted to 10.

The patched exe works fine with all existing no cd patchers both Qwinn and I could find. It asking for disk is indication of another problem.

Edited by scient, 23 March 2009 - 06:11 PM.

Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.


#24 -frustrated-

-frustrated-
  • Guest

Posted 27 March 2009 - 04:04 PM

I just installed all four BG full installs (BG1, bg114315 patch, TotSC, BGTalesUS5512 patch, BG2, Baldur'sGateII-ShadowsofAmnPatchENGLISH patch, ToB, BGII-ThroneofBhaal_Patch_26498_ENGLISH patch), the latest EasyTutu, and the latest WideScreen patch.

I then ran the Hermes BG2ToB 26498 NoCD patcher and it said it patched it.

But I try to run EasyTutu and I get the CD check for the Expansion CD. ARGH.

I have tried a lot of Google searching to find a better NoCD (preferably one that works) but no luck, even using words I've seen in this forum like "mofo" and "KenTeamBG", but with no luck. :(

#25 -frustrated-

-frustrated-
  • Guest

Posted 27 March 2009 - 04:23 PM

btw, BG2 seems to play just fine, it appears it is BG1 (and specifically TotSC) that needs a NoCD patch so I don't have to put the disc in the drive.

#26 Qwinn

Qwinn
  • Modder
  • 3092 posts

Posted 28 March 2009 - 01:00 AM

Frustrated:

Sorry, I can't be of much help there, I haven't modded BG or BG2 at all. You might try posting about your issue in one of the BG2 forums, this forum is about PS:T.

Qwinn

#27 rtr86

rtr86
  • Member
  • 46 posts

Posted 28 March 2009 - 05:23 AM

I've done a full install a few times now on a desktop and laptop with always success:

This was taken from a guide on how to do the best full install for PS:T. I'll post it as it may have some relevance to the trouble the OP is having?

..........However, if you do this, to load a game saved in an area where cd3 or above is required, -even with using the crack-, it will ask for the CD. Because of how the cache-check works, the workaround for this is to select 'New life' in the main menu, and then load the later save file once in the mortuary.

There's a much simpler and therefore better way to do the full install though, which keeps the game running smoothly without ever asking for the CDs, once the crack is run. In torment.ini, set CacheSize=1. That's all you have to do. Now, it doesn't copy the ar*.bif's into the cache directory, but runs them from the "cds" - your other directories. That's the easiest way to do the Full Install.

The CDs have a few megabytes of files in common, so if there's a desire to shave that off, you can go ahead and move everything into one directory, overwriting when doubles are revealed, and have torment.ini's CD= entries all point towards it.


The only thing I did notice recently was when I was installing UB onto my laptop. After doing a full install and applying the 2cd nocd I was asked to insert my CD into drive (this was during the install process of UB). I inserted it and it worked fine - don't know if this has any relevance but just thought i'd mention it as I could not remember doing this on my desktop?

Edited by rtr86, 28 March 2009 - 05:25 AM.


#28 -NamelessOne-

-NamelessOne-
  • Guest

Posted 15 May 2009 - 07:52 AM

Tried a reinstall? Done a full install or made sure ini paths are correct to files? You will get none of the engine fixes if you do that and could easily cause problems with morale. The one time I loaded a saved game post patch into vanilla game there were issues with npc's going perma yellow. Since I rewrote the system from scratch it is not compat with vanilla game. Also, any morale gains above or below 10 for PC's like Dak will be reverted to 10.

The patched exe works fine with all existing no cd patchers both Qwinn and I could find. It asking for disk is indication of another problem.

Sorry to contradict you but the generic IE patcher does not work with 3.02 version, while there were no compatibility issues with v2.0. Checked with PS:T 2cd, fresh and full install.

#29 scient

scient
  • Modder
  • 1010 posts

Posted 15 May 2009 - 02:18 PM


....

The patched exe works fine with all existing no cd patchers both Qwinn and I could find. It asking for disk is indication of another problem.

Sorry to contradict you but the generic IE patcher does not work with 3.02 version, while there were no compatibility issues with v2.0. Checked with PS:T 2cd, fresh and full install.


Whoever setup generic IE one did a crap job then. Any number of ones posted on various sites work just fine. And v2.0 doesn't include any engine patches.

Edited by scient, 15 May 2009 - 02:43 PM.
Removed links to crack.

Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.


#30 -Enemjay-

-Enemjay-
  • Guest

Posted 30 April 2015 - 07:51 AM

I can't guarantee if this won't mess up the area or area map but you can patch these bytes to prevent the crash. I tested the patches with a saved game that would crash on entering Mebbeth's hut and it seems ok. This is basically disabling the error checking for sizes that exceed the limit. Use something like Hex Workshop to do a hex search and then replace the values in bold. You might want to make a backup of file before doing this. Also, these patterns will work on either 2/4 CD versions of exe.

search: 83 C1 07 3B C1 76 14
replace: 83 C1 07 3B C1 EB 14

search: 83 7D 0C 00 77 14
replace: 83 7D 0C 00 EB 14

In Hex editor, should I...

a.) just search for the 76, and the 77 and replace all of those with EB, or...

b.) do I need to search those whole strings (83 C1 07 3B C1 76 14, and 83 7D 0C 00 77 14) and with only the hits that show up with 76 or 77, change those to EB?



#31 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4792 posts

Posted 30 April 2015 - 08:19 AM

B, yes indeed.
b.) do I need to search those whole strings (83 C1 07 3B C1 76 14, and 83 7D 0C 00 77 14)
The and is actually "or", not "and"... as one is for the 2 CD version, and the other is the 4CD version.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#32 scient

scient
  • Modder
  • 1010 posts

Posted 30 April 2015 - 09:20 AM

This was meant to be a stop gap solution. Are you experiencing crashing still? What version of widescreen mod are you using? Is this with a new saved game?

 

It looks like there were some fixes to widescreen mod that should solve this problem with v3.06 (wallgroups) so I'm curious if anyone has been using them.

 

http://www.gibberlin...widescreen.html


Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.


#33 -Enemjay-

-Enemjay-
  • Guest

Posted 30 April 2015 - 09:35 PM

Thank you The Imp for your reply :o)

 

And scient - I installed the WeiDU version 23700, I'm using the 2 cds, and I do believe I started a new save game after installing it - only I did go back and change the UI interface after starting a new game to a larger size as it was too small with my original choice. I get the crashes now and then, but it hasn't been game breaking until now. I've had no trouble with the art gallery, the blue tiefling's shop in clerks ward or the linguist's house - only area that does not but crash the game is the Sandoz chamber where one becomes a Godsman.

 

Ghostdog had advised uninstalling WSmod, finishing the Godsmen business and then reinstalling WSmod. This seems like the easiest way to do it but I'm concerned because I installed a bunch of other mods at the same time as the WS mod.

 

a.) Is there any special way that I need to uninstall and reinstall the WSmod after doing my Godsmen business, or...

 

b.) Can I just run the WSsetup in console / simply (U)uninstall it / boot up the game (I'm assuming the save will work and the game will now be running in the resolution of it's original release) do my business / save and quit / run WSsetup once more, simply choosing (I)install and letting it go through it's motions / start up Torment again finding the WSmod active again.

 

Thanks all



#34 scient

scient
  • Modder
  • 1010 posts

Posted 01 May 2015 - 08:45 AM

Uninstalling/Installing sounds like a bad idea however GhostDog might know some nuances with new patches I don't know about. From my understanding, if you change the resolution you have to start a completely new game. Existing saved games will become broken and lead to crashes.

 

That's good to hear that the art gallery and other places are not crashing. This might be a completely different issue with Godsmen area. If you are willing to upload a few things, I can see exactly why you are crashing.

 

I need your WeiDU.log. It should be a text file that lists everything you have installed and their versions. I also need a copy of your saved game. You could upload it to someplace. You could zip both and put them on someplace like anonfiles or rapidgator. With both those in hand, I can see exactly what is causing the crash and either give you tailored patch. The one above if I remember correctly was if you tried to use a old saved game which it sounds like you didn't.


Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.


#35 -Enemjay-

-Enemjay-
  • Guest

Posted 01 May 2015 - 11:18 PM

http://www.mediafire...Torment_Problem

 

There you go, hope the link works ok.

 

Thanks a lot scient.



#36 scient

scient
  • Modder
  • 1010 posts

Posted 02 May 2015 - 10:01 AM

I was able to repeat the crash. It looks like it is a problem with one of UI packages, most likely widescreen. It seems to be something specific to the area (A0511F1). I don't have time right now to spend much more than a band-aid patch. This will get the area to load by bypassing the crashing code. Please be warned that this area (and others) might be affected negatively. My suggestion is to duplicate your exe, apply the patch below then use it to access the area. Once you are done, revert to your original exe without hotfix until a more permanent solution can be found.

 

search:  81 7D F0 00 01 00 00 0F 8D 34 01 00 00

replace: 83 7D F0 00 90 90 90 0F 8D 34 01 00 00


Edited by scient, 02 May 2015 - 10:02 AM.

Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.


#37 -Enemjay-

-Enemjay-
  • Guest

Posted 03 May 2015 - 03:30 AM

Thanks for taking the time to do that scient,

Yep, that got me past that little block and I was able to complete the Godsmen entrance quest. I'm back to using the original torment.exe file now. Hopefully there aren't too many other bad crash spots out there.

 

Again thanks for your help.



#38 scient

scient
  • Modder
  • 1010 posts

Posted 03 May 2015 - 06:07 AM

I'm glad to have helped. If you run into any other problems, please report them here. It would be useful in tracking down the issue. In a couple weeks I will poke around some more when I have more time.


Those interested in the classic TBS game Sid Meier's Alpha Centauri / Alien Crossover should check out the unofficial patch I work on here.