Jump to content


Photo

Ultimate Planescape: Torment installation guide


  • Please log in to reply
234 replies to this topic

#221 Drizzle

Drizzle
  • Member
  • 13 posts

Posted 10 September 2013 - 03:55 AM

Did you have a problem with Bigg's Widescreen Mod? There shouldn't be any need to change the resolution in-game after setting it with that mod and doing so can cause you no end of problems.



#222 -Xenois-

-Xenois-
  • Guest

Posted 10 September 2013 - 07:14 AM

Hi Drizzle,

 

No, it works fine. I set it on 1920*1080 and the UI is realy small. So i was thinking maybe i can change it to 1280*720. But like you said "no end of problems", might be better just to re-install the game and the mods so i dont have any problems afterwards.



#223 -ChosenUndead-

-ChosenUndead-
  • Guest

Posted 19 November 2013 - 11:52 AM

After having installed the GOG version of Torment, version 1.1, the widescreen, ghostdogs, fix pack, UB, and finally tweak, I find I'm reverted to the menu when in game constantly without any button presses on my part. HELP!



#224 -Boshua-

-Boshua-
  • Guest

Posted 29 November 2013 - 10:44 PM

is it possible to make the graphics better for PST?? As they are a bit old school....



#225 -Nii-san-

-Nii-san-
  • Guest

Posted 27 January 2014 - 11:49 AM

HI, 

 

I purchased a copy of Planescape torment, GOG version. I tried running it with all the following mods:

 

Bigg's Widescreen mod, Ghostdog's incredible UI mod, the Ultimate Fixpack, Unfinished Business, & Tweaks Pack

But when I try to run the game, I have a horrible glitch that keeps the hotkey mapper menu popping up. It makes playing the game impossible. It's like there is some shortcut for the hotkey mapper permanently stuck so it keeps automatically launching the damned menu. The only way to even get a chance to move my character around is to hold down some other botton, like shift or ctrl.  But there is nothing wrong with my laptop and I play plenty of other games without this issue. There are definitely no keys that are "sticking" on my keyboard so it's definitely a software issue. 

 

I have tried running the game without any mods and still I get the same issue. I have also tried running it as an administrator and in compatability mode for windows XP service pack 3. No dice. Tried patching the game to version 1.01 and running without mods, still I have the same issue. 

 

My laptop is a dell HP 630, 

Processor: Intel Pentium CPU B960 @ 2.20 GHz (dual core)

Intel® HD graphics

Memory:4 GB RAM 

Sytem type: 64-bit operating system running windows 7

rated: 3.7 on windows experience rating

 



#226 -Keldorn-

-Keldorn-
  • Guest

Posted 15 June 2014 - 01:05 PM

Hi, 

 

i have installed PS:T the 4disc version, patched it to version 1.1 and installed Biggs Widescreen mod and Ghostdogs UI mod and it works fine so far.

 

Now i tried to install the Fixpack, UB and Tweaks Pack but all 3 mods abort installation because wrong version of game.

 

What can I do ?



#227 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4812 posts

Posted 15 June 2014 - 01:19 PM

Now i tried to install the Fixpack, UB and Tweaks Pack but all 3 mods abort installation because wrong version of game.

 

What can I do ?

Open one of the setup-*modname*.debug -files with Notepad and copy paste the text, and someone will take a look.


Edited by The Imp, 15 June 2014 - 01:58 PM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#228 -Keldorn-

-Keldorn-
  • Guest

Posted 15 June 2014 - 02:12 PM

So here it is...

 

Torment.exe file is 5750333 bytes in size.
FAILURE:
Unknown version of game. Please seek assistance at the forums for this mod at Spellhold Studios.
Stopping installation because of error.
ERROR: [Torment.exe] -> [Torment.exe] Patching Failed (COPY) (Failure("Unknown version of game. Please seek assistance at the forums for this mod at Spellhold Studios."))
Stopping installation because of error.
Stopping installation because of error.


#229 -JohnnyW-

-JohnnyW-
  • Guest

Posted 05 September 2014 - 03:41 AM

As is explained in the guide, the mods will not work on cracked copies of the game.



#230 -Keldorn-

-Keldorn-
  • Guest

Posted 15 September 2014 - 04:08 PM

If I use a cracked copie I wouldnt ask such questions. :P

 

Any usefull comment ?



#231 -grue-

-grue-
  • Guest

Posted 23 November 2014 - 11:42 AM

I have the GOG version and I've installed it into C:\GOG Games\Planescape Torment\

 

My operating system is Windows 8.1

 

I successfully installed Bigg's Widescreen mod and Ghostdog's UI mod with only some minor hiccups dealing with compatability issues. I tried running the game at this point and it seems to load and run correctly.

 

Now I'm trying to install Qwinn's Ultimate Fixpack. The installer seems to hum along and succeed at patching hundreds of files. Then it throws the following error:

 

WARNING: internal label [41] not found in processed DLG [DJUSTFER]

ERROR: processing .D actions [PST-Fix/dlg/QwinnFix.d]: Invalid_argument("index out of bounds")

Stopping installation because of error.

Stopping installation because of error.

 

ERROR Installing [PS:T Ultimate WeiDU Ficpack, by Qwinn], rolling back to previous state

Unable to Unlink [PST-Fix/backup/0/OTHER.0]: Unix.Unix_error(1, "unlink", "PST-Fix/backup/0/OTHER.0")

Will uninstall 293 files [SETUP-PST-FIX.TP2] component 0.



#232 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4812 posts

Posted 23 November 2014 - 12:17 PM

I have the GOG version and I've installed it into C:\GOG Games\Planescape Torment\ ... Windows 8.1

Try to install the game to the Windows user folders... mine would be here:

C:\Users\Imp\Planescape Torment\

Wheehehehhe..

 

The thing is, it could fix it. But it's kinda ... still unlikely.


Edited by The Imp, 23 November 2014 - 08:02 PM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#233 punkdirt

punkdirt
  • Member
  • 1 posts

Posted 24 November 2014 - 06:37 AM

I've been having trouble installing the Fixpack in Windows 7 (32-bit). When I run the executable (Setup-PST-Fix.exe), It does this and then just quits:

pst install fail.png

 

Afterwards, the .exe file apparently deletes itself, but in a weird way where Windows doesn't realize the file is gone and just fails to access it. I have to wait a couple of minutes for it to remove the ghost file before I can try again. (I actually encountered this oddity when installing GhostDog's UI fix, but turning off my anti-virus fixed that.)

 

I've turned off MSE's real time protection and the UAC and the problem persists, and it looks like nobody else has run into it.. Any help would be appreciated. :(



#234 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4812 posts

Posted 24 November 2014 - 07:01 AM

...

Just update the file manually... aka, you delete all the setup-modname.exe's, download the latest weidu archive from here, and extract the weidu.exe from the archive(it's the Windows Binary for all the Windows users), and copy paste it a few times, then rename the weidu.exe's as the deleted setup-modname.exe's. The guide has all this, it's just skipped by most as it's mostly fine if you don't let the Anti-virus etc things to munch on what the computer actually calculates...


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#235 -Fill-

-Fill-
  • Guest

Posted 12 April 2017 - 12:46 AM

Hello,

Will you update this guide for EE version?