Jump to content


Photo

CLUAconsole


31 replies to this topic

#1 Marla Wolfblade

Marla Wolfblade
  • Member
  • 15 posts

Posted 28 November 2009 - 01:09 PM

I can't get CLUAconsole to work. When I try to to add Debug Mode=1 to baldur.ini it won't save and says access is denied. Is there anything I can do about it? I'm using Windows 7, dunno if that makes a difference.

#2 Yovaneth

Yovaneth

    The newly-appointed Master Builder of Baldur's Gate

  • Modder
  • 3040 posts

Posted 28 November 2009 - 01:24 PM

baldur.ini - Right-click | Properties. Check that Read-Only is not checked. If it is, uncheck it - problem probably solved. If it's not checked then Win7 is most likely pulling the same stunt as Vista, so you'll need to install BG anywhere *except* \program files.

-Y-

#3 Marla Wolfblade

Marla Wolfblade
  • Member
  • 15 posts

Posted 28 November 2009 - 02:16 PM

It would appear that it is indeed Windows 7 being arsey. I can't be bothered reinstalling BG and it would only encourage me to be lazy haha. Thanks for your help and quick reply :)

#4 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 28 November 2009 - 04:19 PM

It would appear that it is indeed Windows 7 being arsey. I can't be bothered reinstalling BG and it would only encourage me to be lazy haha. Thanks for your help and quick reply :)

Well, you could move/copy the whole game directory to another folder that is not in the Program Files folder, and then use the BGMain.exe to start the game... and then you can uninstall the primary BG2, so you'll then have the option to install the game, or just play...
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#5 Marla Wolfblade

Marla Wolfblade
  • Member
  • 15 posts

Posted 28 November 2009 - 05:12 PM

That would never even have occured to me. Thanks dude.

#6 Arianyr

Arianyr
  • Member
  • 16 posts

Posted 29 November 2009 - 01:11 AM

Windows 7 (just like Vista) protects .ini files located in Program Files.

Do this:
- move baldur.ini to somewhere else (for example, your desktop)
- modify it as you wish
- move it back

#7 Yovaneth

Yovaneth

    The newly-appointed Master Builder of Baldur's Gate

  • Modder
  • 3040 posts

Posted 29 November 2009 - 02:29 AM

Windows 7 (just like Vista) protects .ini files located in Program Files.

Do this:
- move baldur.ini to somewhere else (for example, your desktop)
- modify it as you wish
- move it back

...which is okay until you run the BGConfig utility and it can't save its own ini file. <sigh>. I do wish Microsoft wouldn't tell me what I can and can't do on my own PC.

[Edit] Typo. The older I get, the more of those I make.

-Y-

Edited by Yovaneth, 29 November 2009 - 02:29 AM.


#8 Marla Wolfblade

Marla Wolfblade
  • Member
  • 15 posts

Posted 29 November 2009 - 05:50 AM

I do wish Microsoft wouldn't tell me what I can and can't do on my own PC.


Completely agree with that. I find it very condescending of my laptop when it decides I'm not allowed to do something. It's like a nursery school teacher telling a 5 year old when it can have its juice.

#9 -Derrick-

-Derrick-
  • Guest

Posted 18 July 2010 - 06:15 AM

I was having the same problem. I was able to convince Nanny Windows to allow me to edit the .ini file, but it made no difference. It turns out that BG2 wasn't even looking at the .ini file that was located with the rest of the game. When the config utility runs, it saves a new baldur.ini in the (hidden) location "C:\Users\ [UserName]\ AppData\ Local\ VirtualStore\ Program Files (x86)\ Games\ BGII - SoA" (or something very similar, depending on where you istall the game... "Games\BG2 - SoA" for me, "Black Isle\BGII - SoA" by default). This is also the place where the save folder is located. If you edit the baldur.ini stored in this location, the debug mode works properly. You can leave the file where it is - the game knows how to access this hidden parallel universe.

#10 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 18 July 2010 - 06:48 AM

I was having the same problem. I was able to convince Nanny Windows to allow me to edit the .ini file, but it made no difference. It turns out that BG2 wasn't even looking at the .ini file that was located with the rest of the game. When the config utility runs, it saves a new baldur.ini in the (hidden) location "C:\Users\ [UserName]\ AppData\ Local\ VirtualStore\ Program Files (x86)\ Games\ BGII - SoA" (or something very similar, depending on where you istall the game... "Games\BG2 - SoA" for me, "Black Isle\BGII - SoA" by default). This is also the place where the save folder is located. If you edit the baldur.ini stored in this location, the debug mode works properly. You can leave the file where it is - the game knows how to access this hidden parallel universe.

Yeah, but that's without the use of the actual computers Administration account with Windows Vista and/or Windows 7... the account is actually only in use when you disable the User Account Control, like I always advice everyone that reads this...
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#11 -JR-

-JR-

    Machete-Wielding Historian

  • Staff
  • 337 posts

Posted 18 July 2010 - 09:27 AM

The only way I found to counteract this was to edit the file before opening Baldur's Gate for the first time.
"Education without values, as useful as it is, seems rather to make man a more clever devil." - C.S. Lewis

#12 Danilus

Danilus
  • Member
  • 21 posts

Posted 18 July 2010 - 05:56 PM

Ugh, I have this problem with Vista every time I re-install what I do is right click my BGII-SoA or Black Isle folder from Program Files then Properties - Security - Down to the Users Group (There you should see your computers name) then click on edit and tick full control.

As Arianyr said Vista/7 Protects .ini files and this solution should work just fine and has done for me many times.

#13 Ipsissimus

Ipsissimus

    [Insert witty statement]

  • Member
  • 356 posts

Posted 18 July 2010 - 06:33 PM

And disable User Account Control, useless piece of Microsoft bloatware that it is. You're better off not installing BG in Program Files in the first place though. I normally install it in C:\Games\Black Isle\[game name].
And the mirror, it reflects a tiny dancing skeleton, surrounded by a fleshy overcoat and swaddled in
A furry hat, elastic mask, a pair of shiny marble dice, some people call them snake-eyes, but to me they look like mice
-- "Nothing's gonna change my clothes", They Might Be Giants

#14 -Keiko-

-Keiko-
  • Guest

Posted 11 March 2011 - 05:22 PM

I was having the same problem. I was able to convince Nanny Windows to allow me to edit the .ini file, but it made no difference. It turns out that BG2 wasn't even looking at the .ini file that was located with the rest of the game. When the config utility runs, it saves a new baldur.ini in the (hidden) location "C:\Users\ [UserName]\ AppData\ Local\ VirtualStore\ Program Files (x86)\ Games\ BGII - SoA" (or something very similar, depending on where you istall the game... "Games\BG2 - SoA" for me, "Black Isle\BGII - SoA" by default). This is also the place where the save folder is located. If you edit the baldur.ini stored in this location, the debug mode works properly. You can leave the file where it is - the game knows how to access this hidden parallel universe.



Arigato :)

#15 -B-rye-

-B-rye-
  • Guest

Posted 02 February 2012 - 07:06 PM

I can't actually find my .ini file for BG1 totsw or BG2 soa, its a pain in the ass, im running on Win7 home premium 64 bit, if anyone can please help me i would be eternally grateful.

#16 quildyn

quildyn
  • Member
  • 1 posts

Posted 02 February 2012 - 07:17 PM

ok so im running on Win7 and i cant find the .ini file for bg1 and bg2 ive looked everyone, if anyone has insight as to where to find these so i can modify them please speak up

#17 Dakk

Dakk
  • Member
  • 398 posts

Posted 02 February 2012 - 07:25 PM

ok so im running on Win7 and i cant find the .ini file for bg1 and bg2 ive looked everyone, if anyone has insight as to where to find these so i can modify them please speak up

It's in your game directory, and called baldur.ini?

#18 hook71

hook71
  • Member
  • 275 posts

Posted 03 February 2012 - 07:03 AM

If you have installed the games in C:\Program Files, uninstall them and install in something like C:\Games instead. Otherwise I guess they might be hidden.

#19 -Petmya-

-Petmya-
  • Guest

Posted 12 January 2013 - 10:35 AM

i cant get it to work either.... i sucessfully edited the .ini file but when i go to the game and hit ctrl+shift i get nothing plz help?

 



#20 hook71

hook71
  • Member
  • 275 posts

Posted 12 January 2013 - 10:53 AM

It's [ctrl]+[space].





Reply to this topic