Jump to content


Photo

How to deal with the DDraw problems of PST and other IE games


  • Please log in to reply
82 replies to this topic

#21 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 30 March 2010 - 03:54 PM

Yeah, I forgot to mention I'm also using an ATI 4870. Before that I had an ATI2900HD and PST worked fine. Upgrading to the 4870 brought up the framerate problems.

#22 -Volo-

-Volo-
  • Guest

Posted 18 May 2010 - 09:34 AM

Hi everybody !

I am just discovering this wonderful forum. Firstly excuse my bad french english.

I have rencently re-installed Ps:T 4 CD on my laptop ( Windows 7, Geforce 240m ) and did all the recommended install :
Patch 1.1
Ultimate WeiDu Fixpack
Ps:T UB
Ps:T Tweak pack
Widescreen Mod
and finally Ghostdog's Ps:T User Interface

I read there are lot of problems with Nvidia cards but i can't understand if my bug is mentionned (my poor vocabulary maybe ^^ )

At the beginning i could see in game only the "aera-in-view" for the characters, the rest was black, the same when i moved my characters. When i checked the map, the aera discovered were well-displayed and when i came back in game, the black was vanished and the "aera-discovered-but-not-in-view" appears normally but when i move the screen, this aera is twinkling/flashing/winking (i don't know the true word) and it is horrible to play with that.

I checked your solutions and use D3DWindower as u explain : the game is windowed , very (very) slow and laggy and the flashing persists (and a strange grid displayed with some options).
I installed nvidia fix and run the game without D3Dwindower . Nowadays no blacked aera at the beginning, but directly the twinkling/glittering of the "discovered-aera-not-in-view"

Should i tried to disable DDraw manually ? (it is not easy with W7 at first sight)
Could we disable/remove the "fog of war" ? (i hope it is the true word, i don't mean remove the black which hides the no-discovered aera)


I hope being understandable, i would play this fantastic game !

Longue vie Black-Isle et merci d'avance :) !

Volo

#23 -Volo-

-Volo-
  • Guest

Posted 18 May 2010 - 09:54 AM

Hi everybody !

I am just discovering this wonderful forum. Firstly excuse my bad french english.

I have rencently re-installed Ps:T 4 CD on my laptop ( Windows 7, Geforce 240m ) and did all the recommended install :
Patch 1.1
Ultimate WeiDu Fixpack
Ps:T UB
Ps:T Tweak pack
Widescreen Mod
and finally Ghostdog's Ps:T User Interface

I read there are lot of problems with Nvidia cards but i can't understand if my bug is mentionned (my poor vocabulary maybe ^^ )

At the beginning i could see in game only the "aera-in-view" for the characters, the rest was black, the same when i moved my characters. When i checked the map, the aera discovered were well-displayed and when i came back in game, the black was vanished and the "aera-discovered-but-not-in-view" appears normally but when i move the screen, this aera is twinkling/flashing/winking (i don't know the true word) and it is horrible to play with that.

I checked your solutions and use D3DWindower as u explain : the game is windowed , very (very) slow and laggy and the flashing persists (and a strange grid displayed with some options).
I installed nvidia fix and run the game without D3Dwindower . Nowadays no blacked aera at the beginning, but directly the twinkling/glittering of the "discovered-aera-not-in-view"
(edit) in reality i mis-used D3Dwindower, now i can use it fluidly, but the problem of flashing stays, with or without nvidia fix.

Should i tried to disable DDraw manually ? (it seems not be the problem...)
Could we disable/remove the "fog of war" ? (i hope it is the true word, i don't mean remove the black which hides the no-discovered aera)


I hope being understandable, i would play this fantastic game !

Longue vie Black-Isle et merci d'avance :) !

Volo



#24 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 18 May 2010 - 12:32 PM

Disabling ddraw manually seems like your best option. D3dWindower seems to work better with ATI cards. Other than that you could try setting up a virtual machine with win98.

#25 -Volo-

-Volo-
  • Guest

Posted 18 May 2010 - 02:30 PM

Thanks for your fast answer.

I have bad news. It seems impossible to disable DirectDraw with windows seven, button you were speaking about are greyed or inexistant. I search on forums but the only response i found were DDraw is now fully included in the OS and cannot be disable.

I tried to launch the game with Windows 98 mod of compatibility but no way, the flashs are still alive.

Thanks for help, but i am alone with this probleme ?

#26 -flinx1-

-flinx1-
  • Guest

Posted 19 May 2010 - 03:33 PM

Try turning off triple buffering in the Nvidia driver. That fixed all the trouble I had when I had an Nvidia card.

#27 -hdp247-

-hdp247-
  • Guest

Posted 08 June 2010 - 12:49 PM

Hello, I am at my wits end with trying to get Torment working correctly, first (prior to finding all the wonderful goodies and mods) installed semi to lack luster problems with graphics relatively solved with switching to software rendering versus hardware ie. In-game graphics options. however once i picked up Dakon casting created flashing and mirrored tiles surrounding TNO. Well found out about widescreen mod from Biggs and also Ghosts really nice Ui installed and looked awesome, until i started to cast spells again, Tried the Comparability mode no success, then the D3dwindower (didn't work at first), then the Nvidiafix. Now just to be clear im running

System information

Intel® Core™2 Duo CPU T7500 @ 2.20GHz (2195 MHz)

Operating system:

Windows 7 Professional, 64-bit

Direct X version:

11.0

Graphics card information

Quadro FX 570M

Driver version:

197.16

Total available graphics memory:

2015 MB

Dedicated video memory:

256 MB

System video memory:

0 MB
Shared system memory:

1759 MB





I reinstalled Torment and was very careful about how I placed things and ordered of Mod installs, now it work well still flashes of light, used the cursor correction it worked great however I Really like the D3dwindow more because its cleaner and less graphics quarks, only problem is that i can't re-size the window and so the bottom part is cut off, my screen res is also 1680x1050 however, I tired to do ghosts res fix and it seemed to crash the game, now i might have done a step wrong but first reinstall Widescreen mod with ghostui, then set the res in D3DWindower to the 1664x1028 or do i need to do that with my computer resolution, because if you alt tab in Windows 7 you can forcibly move the window a bit to give you that extra inch at the bottom but that creates massive black grid patterns also occurs when i change the D3DWindower res it creates even more black grids.



Sorry kinda in a rush while writing it I'll probably make an account here shortly and alter this post to make a little more sense, just would really like to Play the game again with the mods recovering the lost quests, this game imo is the best RPG ever. Great message and standpoint behind it, hell i even got the tattoo on my back


Doug

#28 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 08 June 2010 - 01:38 PM

@hdp247:

If I understand correctly after you created the new custom resolution and loaded the game with D3Dwindower, PST crashed. Did you continue from an old save, perhaps ? If this is the case, then this is the cause of the crash. If you change the resolution of the widescreen mod then you must always start a new game. This is a known issue with the widescreen mod and it's mentioned in all the readmes.

Start a new game and see if it works fine.

#29 hdp247

hdp247
  • Member
  • 5 posts

Posted 08 June 2010 - 07:40 PM

Thanks for the quick response, I did start a new game after the crash, and that fixed the issue with crashing, my problem now is when i use a custom resolution and not preset 1680x1050 or other presets it crashes before it loads, Right now after reinstalling works great but i have to just use the Nvid fix with curser fix (which i hate but the tail i hate more). I got the D3d to work perfectly and hence would really love to use it, but it cuts off the bottom and when I change res for wide screen and ui, it crashes at start up. Now with your fix Ghost do you change the computer resolution with the custom resolution and wide screen and D3dwindower resolution tab or just wide screen and D3d and run those as a custom res?

My bottom line is I want to play it in D3d but it gets cut off on the bottom of the screen, tried a custom resolution didn't work with even a new game said non supported

so im just getting a little clarification on the Resolution tid bit

#30 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 09 June 2010 - 01:40 AM

The new resolution you want to use (let's say 1664x1028) is not supported by default by your graphics card. You must create the new custom resolution in order to be able to use it. Most ATI and NVIDIA cards can do that through their control panels, but there are also other ways to do it.

So, have you done the above ? If not, there is your problem.

#31 hdp247

hdp247
  • Member
  • 5 posts

Posted 09 June 2010 - 08:49 AM

The new resolution you want to use (let's say 1664x1028) is not supported by default by your graphics card. You must create the new custom resolution in order to be able to use it. Most ATI and NVIDIA cards can do that through their control panels, but there are also other ways to do it.

So, have you done the above ? If not, there is your problem.



Steps I took:

1. Went to Nvidia Control panel
2.Settings already set for advance
3. Display-> Change resolution ----> Add Resolutions.... (button)-----> Create 1664x1028
4. Reinstall widescreen-v2.31---> set res at 1664x1028
5. Reinstall PST_ui_mod_v2.01
6. Click Torment Icon---------->error "unsupported Resolution"
7. Try to open it in D3DWindower with changed resolutions---------->error won't open



After that trying different res i decided to go to a pree set res and use 1440x900
, i installed wide screen under that res left my Computers Res at 1680x1050 and then put the custom res 1664x1028 in the D3D. That aloud me to run the game but task bar was still giving me hell so I shrank it to 1680x950 and it works fine, just not as sharp. Since i keep restarting games i cant test magic very early on if i snag with magic (hopefully not or I'm just gonna render the damn game to 3d)
then I'll let you know, don't understand why I can create a custom res but Torment goes no

Attached Images

  • resolution pic.JPG

Edited by hdp247, 09 June 2010 - 08:50 AM.


#32 EntFFFF

EntFFFF
  • Member
  • 1 posts

Posted 09 June 2010 - 09:23 AM

The D3D utility didn't help me get rid of the stuttering in PS:T, but lowering the HW acceleration slider did, thanks! :)

Is there an easy way for this to be done automatically when Torment is started, and to be set back to normal afterwards?

And I love your UI. ;)


While this wont force the change automatically, it will cut down on the steps to force the change.

http://www.teslacore...e=HWAccelSwitch

I simply made two batch files to allow me to lower and raise the accel rate when needed. This way I don't have to keep going into the menu to change the setting.

Edited by EntFFFF, 09 June 2010 - 09:24 AM.


#33 hdp247

hdp247
  • Member
  • 5 posts

Posted 09 June 2010 - 10:30 AM

hmm this is an error i got when i saved the game and then reopened it

At this point no changes to resolutions were made, and Also what the hell is it asking for with Drive F? I don't even have one......

Attached Images

  • torrment error.JPG


#34 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 09 June 2010 - 02:49 PM

Assertion errors in torment are like that, the path they give doesn't point to an actual file. Anyway, this error looks like the usual crash you get when you've changed the resolution mid-game. If you haven't done that, I really don't know what the problem is. Maybe you could try using the d3dwindower at a lower resolution like 1440x900.

#35 hdp247

hdp247
  • Member
  • 5 posts

Posted 10 June 2010 - 02:41 PM

Assertion errors in torment are like that, the path they give doesn't point to an actual file. Anyway, this error looks like the usual crash you get when you've changed the resolution mid-game. If you haven't done that, I really don't know what the problem is. Maybe you could try using the d3dwindower at a lower resolution like 1440x900.



Most definitely, atm I've just rolling with cursor fix pack with out D3dwindower, I have an itch i need to scratch and beat the game completely, but I really want to explore more about it working properly on 7 without crashes and what not and possibly get into modding, so i can explore my other IE games in more detail, but I seem to have it stable almost to Buried Village part once i get to Drowned nation Im sure ill have enough spells to play with to see if the current graphic fixes hold steady.

also I'm wondering if its a issue on my system or something im missing but having an issue with the UI with text being smaller then i would like, I installed at 120% and in some parts it works well but the text in dialogue is posting at what looks to be normal 1680x1050 text which is doable but straining the eyes a bit, don't know if you have a thread already posted on that I can read or not or if its a easy fix but thanks again for the support so far its giving me a lot of opts

#36 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 10 June 2010 - 03:40 PM

A similar problem with dialog fonts not working correctly has been reported by some people. Uninstall the current fonts (only the fonts, not the core UI elements) and re-install the ones you want using a separate tool which you can find here

Edited by ghostdog, 10 June 2010 - 03:42 PM.


#37 hdp247

hdp247
  • Member
  • 5 posts

Posted 10 June 2010 - 09:58 PM

A similar problem with dialog fonts not working correctly has been reported by some people. Uninstall the current fonts (only the fonts, not the core UI elements) and re-install the ones you want using a separate tool which you can find here



thankie for the link

#38 mezule

mezule
  • Member
  • 1 posts

Posted 16 June 2010 - 11:31 PM

This cursor fix is wonderful!
Now it's kind of fun to play with the artifacts.
Is there any way to also change the "click" cursor as well?
It's so much better. Thank you!

#39 Sam Lake

Sam Lake
  • Member
  • 2 posts

Posted 18 June 2010 - 04:35 AM

Hey guys, even though I've been lurking here for quite some time, I basically registered now just to tell you about my solution.
I had DDraw problems with PST ("black boxes") like the majority of players here. I tried every possible solution I could think of, and even some I knew in advance to be pointless. Just yesterday, I finally gave up and began preparing myself to somehow endure looking at the damn glitches everytime I cast a spell. Then I noticed new Catalyst drivers had been released (10.6 - just two days old). Believe it or not, those new drivers fixed it.

So if you have an ATI card (mine is an old HD2600XT), this may help you too - no lowering down the hardware acceleration (which I couldn't try anyway, as I'm on Win 7), no third-party fixes. Just the drivers and everything works fine.

Oh, and my setup:
2CD version of Torment
Platter's fixpack
Widescreen mod (1280x720)
ghostdog's UI mod

Thank you for your attention, I hope you were able to understand my clumsy English.
"You wanna swap wives? You can have mine as soon as I get one." - Myron, Fallout 2

#40 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 18 June 2010 - 03:25 PM

Thanks Sam. ATI probably did this by accident, but it's good to know that these drivers may help.