Jump to content


Photo

problem with installation v2.1


16 replies to this topic

#1 melinne

melinne
  • Member
  • 2 posts

Posted 09 April 2010 - 08:53 PM

Hi!
I am new to the forum and first of all I want to thank ghostdog for this wonderful mod.
I have been using the v1.21 without any problem (WinXP), with the widescreen mod v2.2. Today I tried to install the new version 2.01 because I wanted bigger fonts and dialog box. I replaced the old files in the game directory with the new ones and I run the Setup-GhostDog's-PST-UI.
Towards the end (I think when patching the torment.exe file), the installation failed with the message:
  
no pattern for bmp patching found

Can someone help me with this? I attach the debug file.

Thank you

Attached Files


Edited by ghostdog, 18 May 2010 - 02:54 AM.


#2 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 10 April 2010 - 12:08 PM

Hi!
I am new to the forum and first of all I want to thank ghostdog for this wonderful mod.
I have been using the v1.21 without any problem (WinXP), with the widescreen mod v2.2. Today I tried to install the new version 2.01 because I wanted bigger fonts and dialog box. I replaced the old files in the game directory with the new ones and I run the Setup-GhostDog's-PST-UI.
Towards the end (I think when patching the torment.exe file), the installation failed with the message:

no pattern for bmp patching found

Can someone help me with this? I attach the debug file.

Thank you



It seems there is an error when the installer starts to patch the journal pics and the loading bar. There was another who had the same problem and we found a way around it.


Go into the GhostDog's-PST-UI\TPH folder in your torment directory. Open the Setup-GhostDog's-PST-UI.tp2 file and erase all the "INCLUDE ~GhostDog's-PST-UI/TPH/journalpics_loadingbar_fix.tph~" entries. There are 5 of them.
This will remove the bmp patching and thus the journal pics and loading bar will not be centered correctly, but you'll be able to play the game with the rest of the UI elements.


If after that the installation works, then you can try installing the fix as a separate installation. You can find it here : Journal_pics_loading_bar_fix.7z


This looks like a random bug. There is really no reason for the patch to fail, except if you have some antivirus/firewall that prevents multiple patching of the torment exe. But it doesn't really make sense. Anyway, let me know how it goes.

#3 melinne

melinne
  • Member
  • 2 posts

Posted 10 April 2010 - 04:49 PM

Thank you, both the installation and the fix worked perfectly  :) .



Hi!
I am new to the forum and first of all I want to thank ghostdog for this wonderful mod.
I have been using the v1.21 without any problem (WinXP), with the widescreen mod v2.2. Today I tried to install the new version 2.01 because I wanted bigger fonts and dialog box. I replaced the old files in the game directory with the new ones and I run the Setup-GhostDog's-PST-UI.
Towards the end (I think when patching the torment.exe file), the installation failed with the message:
  
no pattern for bmp patching found

Can someone help me with this? I attach the debug file.

Thank you



It seems there is an error when the installer starts to patch the journal pics and the loading bar. There was another who had the same problem and we found a way around it.


Go into the GhostDog's-PST-UI\TPH folder in your torment directory. Open the Setup-GhostDog's-PST-UI.tp2 file and erase all the "INCLUDE ~GhostDog's-PST-UI/TPH/journalpics_loadingbar_fix.tph~" entries. There are 5 of them.
This will remove the bmp patching and thus the journal pics and loading bar will not be centered correctly, but you'll be able to play the game with the rest of the UI elements.


If after that the installation works, then you can try installing the fix as a separate installation. You can find it here : Journal_pics_loading_bar_fix.7z


This looks like a random bug. There is really no reason for the patch to fail, except if you have some antivirus/firewall that prevents multiple patching of the torment exe. But it doesn't really make sense. Anyway, let me know how it goes.



#4 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 11 April 2010 - 02:37 AM

I'm glad it worked.

The funny thing is that the separate fix is exactly the same, the only difference is that you apply it afterwards.

#5 -Trykon-

-Trykon-
  • Guest

Posted 12 May 2010 - 02:43 AM

I posted this problem in http://www.shsforums...-installing-ub/ but got told this was the proper area to post it.
Been having an error when trying to install Setup-GhostDog's-PST-UI.


2CD version
ERROR: COPY ~Torment.exe~ ~Torment.exe~ FAILED: cannot open target
Stopping installation because of error.
Stopping installation because of error.

Error Installing [Planescape Torment User Interface], rolling back to previous state.
Will uninstall 1 files for [SETUP-GHOSTDOG's-PST-UI.TP2] component 0.
Uninstalled 1 files for [SETUP-GHOSTDOG's-PST-UI.TP2] component 0.
ERROR: Sys_error("Torment.exe: Invalid argument")
PLEASE email the file SETUP-GHOSTDOG'S-PST-UI.DEBUG to Mod forum: http//www.shs
forum.net/index.php?showforum=571 , email:
the_vampyri_lestat@hotmail.com

Install Component [Planescape Torment User Interface]?
[I]nstall, or [N]ot Install or [Q]uit?

WeiDU v 21300 Log

 C:\Black Isle\Torment\Setup-GhostDog's-PST-UI.exe
[./CHITIN.KEY] loaded, 179101 bytes
[./CHITIN.KEY] 388 BIFFs, 12141 resources
[dialog.tlk] loaded, 8095540 bytes
[dialog.tlk] 106876 string entries
[./autonote.ini] loaded, 9994 bytes
[./beast.ini] loaded, 10458 bytes
[./Keymap.ini] loaded, 4012 bytes
[./layout.ini] loaded, 18 bytes
[./quests.ini] loaded, 34667 bytes
[./Torment.ini] loaded, 1125 bytes
Possible HD/CD Path: [C:\Black Isle\Torment]
Possible HD/CD Path: [C:\Black Isle\Torment\CDALL]
Possible HD/CD Path: [C:\Black Isle\Torment\CDALL]
Possible HD/CD Path: [C:\Black Isle\Torment\CDALL]
Possible HD/CD Path: [C:\Black Isle\Torment\CDALL]
[dialogf.tlk] loaded, 8095540 bytes
[dialogf.tlk] 106876 string entries
[C:\Black Isle\Torment\Setup-GhostDog's-PST-UI.exe] Using scripting style "PST"
[dialog.tlk] claims to be writeable.
[dialog.tlk] claims to be a regular file.
WIDESCREEN/WIDESCREEN.TP2  0  0 Installed 
SETUP-PST-FIX.TP2  0  0 Installed 
SETUP-PST-FIX.TP2  0  1 Installed 
SETUP-PST-FIX.TP2  0  4 Installed 
SETUP-PST-UB.TP2  0  0 Installed 
SETUP-PST-UB.TP2  0 50 Installed 
SETUP-PST-TWEAK.TP2  0  1 Installed 
SETUP-PST-TWEAK.TP2  0 25 Installed 
SETUP-PST-TWEAK.TP2  0 22 Installed 
SETUP-PST-TWEAK.TP2  0  7 Installed 
SETUP-PST-TWEAK.TP2  0 14 Installed 
SETUP-PST-TWEAK.TP2  0 10 Installed 
SETUP-PST-TWEAK.TP2  0  5 Installed 
SETUP-PST-TWEAK.TP2  0  6 Installed 

Install Component [Planescape Torment User Interface]?
[I]nstall, or [N]ot Install or [Q]uit? 
Installing [Planescape Torment User Interface]

Checking if Bigg's Widescreen Mod is installed
Copying and patching 1 file ...
[torment.exe] loaded, 5718077 bytes
torment.exe copied to GhostDog's-PST-UI/Backup/0/torment.exe, 5718077 bytes
Copied [torment.exe] to [torment.exe]
Copying and patching 1 file ...
[torment.exe] loaded, 5718077 bytes
Copied [torment.exe] to [torment.exe]
Copying and patching 1 file ...
[Torment.exe] loaded, 5718077 bytes

2CD version
ERROR: COPY ~Torment.exe~ ~Torment.exe~ FAILED: cannot open target
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Planescape Torment User Interface], rolling back to previous state
[GhostDog's-PST-UI/Backup/0/UNSETSTR.0] SET_STRING uninstall info not found
Will uninstall   1 files for [SETUP-GHOSTDOG'S-PST-UI.TP2] component 0.
Unable to Unlink [torment.exe]: Unix.Unix_error(1, "unlink", "torment.exe")
  Restoring backed-up [GhostDog's-PST-UI/Backup/0/torment.exe]
Unable to Unlink [torment.exe]: Unix.Unix_error(1, "unlink", "torment.exe")
GhostDog's-PST-UI/Backup/0/torment.exe copied to torment.exe, 5718077 bytes
Uninstalled      1 files for [SETUP-GHOSTDOG'S-PST-UI.TP2] component 0.
WIDESCREEN/WIDESCREEN.TP2  0  0 Installed 
SETUP-PST-FIX.TP2  0  0 Installed 
SETUP-PST-FIX.TP2  0  1 Installed 
SETUP-PST-FIX.TP2  0  4 Installed 
SETUP-PST-UB.TP2  0  0 Installed 
SETUP-PST-UB.TP2  0 50 Installed 
SETUP-PST-TWEAK.TP2  0  1 Installed 
SETUP-PST-TWEAK.TP2  0 25 Installed 
SETUP-PST-TWEAK.TP2  0 22 Installed 
SETUP-PST-TWEAK.TP2  0  7 Installed 
SETUP-PST-TWEAK.TP2  0 14 Installed 
SETUP-PST-TWEAK.TP2  0 10 Installed 
SETUP-PST-TWEAK.TP2  0  5 Installed 
SETUP-PST-TWEAK.TP2  0  6 Installed 
ERROR: Sys_error("Torment.exe: Invalid argument")
PLEASE email the file SETUP-GHOSTDOG'S-PST-UI.DEBUG to Mod forum: http://www.shsforums.net/index.php?showforum=571 ,  email: the_vampyri_lestat@hotmail.com

Install Component [Planescape Torment User Interface]?
[I]nstall, or [N]ot Install or [Q]uit?


#6 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 12 May 2010 - 04:05 AM

This is strange. The mod tries to search for the resolution the widescreen mod is installed and it can't find it. Maybe there's something wrong with the widescreen mod installation. Does the game starts without my UI ? Anyway, I would suggest uninstalling everything and re-installing. Make sure you've done a correct "Full" installation of the game and then install the mods in the following order :

Fixpack -> UB -> Tweak Pack -> Widescreen -> UI.

Edited by ghostdog, 12 May 2010 - 04:12 AM.


#7 lac

lac
  • Member
  • 97 posts

Posted 12 May 2010 - 08:38 AM

1. Trykon -- you did this just right. But Ghostdog is a much better source of information than I am -- after all this is his mod.

2. Ghostdog -- you really want people to install fixpack, ub, tweaks and then widescreen and ui in that order? http://www.shsforums...allation-guide/ suggests widescreen, ui, then fixpack, ub and tweaks, so if this isn't how people should do things we should change the guide.

3. Googling around I found this. http://www.mydigital...-windows-vista/ It looks like actually setting up permissions in windows vista via the GUI is a terribly cumbersome thing. So maybe, Trykon, though you are trying to set up torment.exe with the correct permissive permissions, you left out something?

#8 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 12 May 2010 - 09:40 AM

. Ghostdog -- you really want people to install fixpack, ub, tweaks and then widescreen and ui in that order? http://www.shsforums...allation-guide/ suggests widescreen, ui, then fixpack, ub and tweaks, so if this isn't how people should do things we should change the guide.


The "recommended" installation order is the one mentioned in that guide, but in reality there shouldn't be any problem if you installed the widescreen+UI later (The fixpack/UB/Tweak order on the other hand, definitely matters). In fact I have them installed in that order on my pc, since I needed to make many tests and uninstalls/installs. I suggested installing the widescreen mod after Qwinn's mods since there may have been some problem with its installation.

Edited by ghostdog, 12 May 2010 - 09:41 AM.


#9 -Trykon-

-Trykon-
  • Guest

Posted 12 May 2010 - 11:56 AM

Fixed it. Apparently when you install the wide screen mod it puts everything it installed in a folder, and the Setup-GhostDog's-PST-UI doesn't know its there. What I did was removed everything from the folder and put it outside with the Torment.exe, and it patched just fine. Played the game and it works great. :) Thanks for the help guys!

#10 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 12 May 2010 - 12:40 PM

It seems, for some reason, the widescreen mod installation didn't finish correctly. Normally it should put all files it edited in the main folder, or in the override folder. I'm guessing the problem was with the biff files. Good to know you made it work.

#11 -Trykon-

-Trykon-
  • Guest

Posted 17 May 2010 - 09:08 PM

New Problem:

Spells and Spell effects

They do not cast properly. My game slows down terribly or crashes when spells are casted. Also the texture of the spells don't appear, appear as invisible cubes, or very crappy effects/textures.

Did I skip a step somewhere that fixes this issue? or game wasnt patched/modded correctly?

#12 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 18 May 2010 - 01:57 AM

@Trykon:

What you're experiencing is most likely due to your graphic card, it has nothing to do with the mods. PST has some problems with newer cards and they are more evident in high resolutions. Look here for possible solutions: link

Edited by ghostdog, 18 May 2010 - 02:13 AM.


#13 -Trykon-

-Trykon-
  • Guest

Posted 18 May 2010 - 02:48 PM

One quick question before I start the game (tired of starting from scratch all over again since I miss a mod or two). When mods are installed, they create their own folders, should I leave the folders be? or remove everything from inside them and put them where the torment.exe is?

#14 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 18 May 2010 - 05:21 PM

Leave them be.

#15 -Trykon-

-Trykon-
  • Guest

Posted 18 May 2010 - 10:00 PM

OK ghostdog, I really need to send you this debug file so you can fix the issue. the Setup-GhostDog's-PST-UI is not working again, and the old trick i did to fix it doesn't work anymore. Please give me a secure email so I can send it to you. I'm not a modder, so I don't know how to mess with it.

Comp. specs:
Windows 7 64-bit
GeForce GTX 260
8 gigs of RAM

#16 ghostdog

ghostdog
  • Modder
  • 552 posts

Posted 19 May 2010 - 12:12 AM

You can find the email in the readme.

#17 Robercletzon

Robercletzon
  • Member
  • 2 posts

Posted 12 June 2010 - 03:04 AM

I posted this problem in http://www.shsforums...-installing-ub/ but got told this was the proper area to post it.
Been having an error when trying to install Setup-GhostDog's-PST-UI.


2CD version
ERROR: COPY ~Torment.exe~ ~Torment.exe~ FAILED: cannot open target
Stopping installation because of error.
Stopping installation because of error.

Error Installing [Planescape Torment User Interface], rolling back to previous state.
Will uninstall 1 files for [SETUP-GHOSTDOG's-PST-UI.TP2] component 0.
Uninstalled 1 files for [SETUP-GHOSTDOG's-PST-UI.TP2] component 0.
ERROR: Sys_error("Torment.exe: Invalid argument")
PLEASE email the file SETUP-GHOSTDOG'S-PST-UI.DEBUG to Mod forum: http//www.shs
forum.net/index.php?showforum=571 , email:
the_vampyri_lestat@hotmail.com


The same problem here...
But i copy only the torment.exe to another folder, and copy him back to the folder overwriting the same file in the torment folder.
Its Works Greatly! Thanks!



Reply to this topic