Jump to content


Ghostdog's PS:T UI working with WINE on linux

  • Please log in to reply
2 replies to this topic

#1 Leopard Blanc

Leopard Blanc
  • Member
  • 1 posts

Posted 31 January 2011 - 03:39 PM

I've made a quick search and i didn't find this issue adressed, so here it goes.

While trying to install Planescape Torment + all cool mods (i never played it, was about time), everything worked painlessly except the Ghostdog's PS:T UI ™ mod. The windows exe crashes weirdly and while I used all the latest packages and had WeInstall in my path, i couldn't do it by hand. The Problem actually lies in the name itself because there's a quote sign (') that actually has a meaning in a linux command line.

So here's the solution :

First, make sure you've installed the WeiDU-Linux package and got it working. (we'll need WeInstall), and, of course, you should have installed the widescreen mod too...

  • download the latest version of the mod
  • extract it in your torment folder which on my computer is located there: "/mnt/raid/wine/planescapetorment/drive_c/torment" (i've read that it's better to install Planescape Torment there instead of in Program Files)
  • rename the folder "GhostDog's-PST-UI" to "ghostdog"
  • in the ghostdog/thp/ folder edit all .tph files where you'll replace every instance of "GhostDog's-PST-UI" with "ghostdog"
    open a terminal, cd to your torrent folder and issue this simple line :
    find ghostdog -name '*.tph' -exec sed -i -e "s/GhostDog's-PST-UI/ghostdog/g" {} \;
    which does the same, only slightly faster...
  • rename the file Setup-GhostDog's-PST-UI.tp2 to ghostdog/ghostdog.tp2
  • rename the file ghostdog/GhostDog's-PST-UI-README.txt to ghostdog/ghostdog-README.txt
  • once again replace every occurence of "GhostDog's-PST-UI" with "ghostdog" in the file ghostdog/ghostdog.tp2
    assuming you're in your torment folder
    sed -i -e "s/GhostDog's-PST-UI/ghostdog/g" ghostdog/ghostdog.tp2
  • Finally we can install by issuing the command :
    WeInstall ghostdog/ghostdog.tp2
  • Answer the questions and you should have this great mod working.

I hope someone finds that useful (as i'd have). It might be possible/interesting to post the "linux version" of this mod somewhere on the Spellhold Studios. Let me know...


PS: oh, and since i'm new here, i'd like to thank Ghostdog and all the modders for their beautiful work, thanks guys !

#2 ghostdog

  • Modder
  • 556 posts

Posted 01 February 2011 - 03:51 AM

Oh yeah, I think the issue with the " ' " in wine was mentioned somewhere before (it may depend on the wine version IIRC) but it's good to have this mini-guide here for people to easily find it. Thanks !

Edited by ghostdog, 08 February 2011 - 09:05 AM.

#3 wingnux

  • Member
  • 1 posts

Posted 11 December 2012 - 04:15 AM

Installed GOG version and can't get this to work:

wingnux@wingnux-desktop:~/jogos/torment$ WeInstall ghostdog/ghostdog.tp2
WeiDU --tlkout dialog.tlk --ftlkout dialogf.tlk --log setup-ghostdog/ghostdog.debug  ghostdog/ghostdog.tp2 setup-ghostdog/ghostdog.tp2 ghostdog/ghostdog/ghostdog/ghostdog.tp2 ghostdog/ghostdog/setup-ghostdog/ghostdog.tp2
[WeiDU] WeiDU version 22900
WARNING: unable to open log file [setup-ghostdog/ghostdog.debug]: Sys_error("setup-ghostdog/ghostdog.debug: No such file or directory")
ERROR: Unable to find CHITIN.KEY in:

FATAL ERROR: Failure("Unable to find CHITIN.KEY: run me in an Infinity Engine game directory")

I've double checked it and CHITIN.KEY is on my cwd. Also tested with WeiDU 2.31 and it still doesnt work.

Any help?

It was a matter of case sensitive files and running a "tolower" on both Planescape install dir and ghostdog dir solved the problem =)

Edited by wingnux, 11 December 2012 - 05:44 AM.