Jump to content


SoBH 275b, Worldmap v9 and erebusant WM v7 patch


  • Please log in to reply
8 replies to this topic

#1 -Greenhorn-

-Greenhorn-
  • Guest

Posted 04 November 2011 - 12:12 PM

Like the title says: if I plan to install newest SoBH with fresh WM on Tutu conversion do I still need to patch it with that 2 years old patch? I even tried it but instead overwriting files like patch for Drizzt saga 2.0 Worldmap patch it just create new folder Bonehill in my Tutu directory. By the way are there any new "hotfixes" beside Isaya's fixbusting? Thanks in advance.

#2 Isaya

Isaya
  • Modder
  • 294 posts

Posted 06 November 2011 - 01:32 AM

Like the title says: if I plan to install newest SoBH with fresh WM on Tutu conversion do I still need to patch it with that 2 years old patch? I even tried it but instead overwriting files like patch for Drizzt saga 2.0 Worldmap patch it just create new folder Bonehill in my Tutu directory. By the way are there any new "hotfixes" beside Isaya's fixbusting? Thanks in advance.

I don't think you need that old patch. If it targets the "bonehill" directory, it's a very old one related to version 2.45.
Version 2.75 was released in 2010, I think, and is likely to include the old patch. That version of Bonehill was assembled by Erebusant, who was also maintaining BG-BGT-Worldmap, so I assumed the old patch was included in Bonehill v2.75.

If nothing is announced here or in the mega mod forum, I believe there is no new hotfix.

#3 -Greenhorn-

-Greenhorn-
  • Guest

Posted 06 November 2011 - 09:14 AM

Version 2.30:
This version incorporates Worldmap support for Worldmap v7. The installer updated to WeiDU v208.

I found this in desperate poking through Readme, I rarely read version histories especially if they are extensive like atweaks and so on. Anyway I'll give it a try without the fix, hoping that all will turn well. But that patch really needs to go to archive if not relevant beacuse it can make things very confusing especially for rookies. I posted similar question in worldmap forum also. Thanks for help.

#4 Isaya

Isaya
  • Modder
  • 294 posts

Posted 06 November 2011 - 03:14 PM

Where did you find it (link please)? It's not mentionned here in pinned topics. In Worldmap forum?

#5 -Greenhorn-

-Greenhorn-
  • Guest

Posted 07 November 2011 - 03:49 AM

Where did you find it (link please)? It's not mentionned here in pinned topics. In Worldmap forum?


No, not in Worldmap forum, they said that WM doesn't changes conditions for erebusant v7 WM patches for Drizzt saga 2.0 and SobH, essentially these are changes to mods to make them compatible with WM which ideally should be incorporated in associated mods. While I am fairly certain that Drizzt saga patch is still needed, patch for SoBH caused me a headache. Link for my statement is in SoBH 275 readme, pinned just above this topic. It is in version history which is a bit messy beacuse there is a gap between changes made from versions 2.41 to 2.75 and I know for sure there was a 2.45 version with some patches. Same thing with newest v275b version read me. My saving throw against confusion failed me in this instance.
Anyway, hope this helps.

#6 Isaya

Isaya
  • Modder
  • 294 posts

Posted 07 November 2011 - 01:24 PM

Thanks for that clarification. I see your point.

If I remember correctly, v2.45 was a strange kind of patch. You had to install it after installation of v2.41. So it was actually another mod (you had two lines in WeiDU.log). Maybe that's why its changes failed to be reported in the main mod history.
v2.75 seems to be an integration of the separate v2.45 patch in the main line again, along with addionnal fixes.

In my opinion, the statement for v2.30 is to be understood as "you don't need any separate patch/mod for Worldmap 7 compatibility anymore". In my opinion, this still applies today since Worldamp 8 and 9 don't require any change in the others mods such as Bonehill so that they are compatible.

The v2.75b readme was rebuilt from the one in v2.75a, which was only mentionning v2.75 as latest history (basically the one still pinned today). I recovered the history for v2.75a from the forum discussion. So it doesn't fix the hole about v2.45 unfortunately. And it's not available directly from the forum. You need to download the mod to get it, unfortunately.

#7 -Greenhorn-

-Greenhorn-
  • Guest

Posted 07 November 2011 - 02:01 PM

No matter, it is a small thing. My foremost concern was about that damn patch, is it obsolete or not. Luckily that question is resolved now, that thing has to go to archive it seems. Phew, I read so much compatibility threads and orders of installations that I feel I can make BWP installation manually. Heh, just kidding. Thanks for help again.

#8 Wisp

Wisp
  • Modder
  • 1346 posts

Posted 07 November 2011 - 02:20 PM

My curiosity was piqued.
There are differences between the patch and the latest version. It is possible Bonehill will work without the patch, but someone should evaluate the patch and incorporate the good stuff into Bonehill proper.

Edited by Wisp, 07 November 2011 - 02:28 PM.


#9 Isaya

Isaya
  • Modder
  • 294 posts

Posted 27 November 2011 - 05:01 AM

The WM7 patch was more or less included in Bonehill v240. The only difference between the two is the location of the icon on the Worldmap on the Y axis. The file in v240 is newer than in the patch. These new values work fine in combination with Worldmap 8 and 9 (everything is located on Lendore island).

In v275, the locations chosen in v240 are maintained. There are a few changes : a flag for area BH2200 (Lake Lizard, set to 4, as for Garroten and Assassin's Grotto), and the travel time between BH0100 and BH1200, set to 1 instead of 2.
The files are also newer in v275 compared to the patch.

I assume the changes from the WM7 are probably intended. They don't look likely to break the game anyway.