Jump to content


My 25 constitution gets cancelled out for some odd reason in BG2

BG2 TOB Constitution canceling bug

  • Please log in to reply
No replies to this topic

#1 What is the Matrix?

What is the Matrix?
  • Member
  • 114 posts

Posted 10 February 2012 - 08:47 AM

Hey hey all :)

I was working on my sword in Baldurs gate 2, which grants 25 constitution to the wearer. I have tried making it also that once that sword is equipped, there is no way that the constitution could be drained (I made several other weapons which do drain different ability scores). HOWEVER, I did notice a really really strange bug... And I could scratch my head bald before I figure this one out; but - everytime I try to whack someone with the sword, the 25 constitution gets cancelled out!

The wielder of the sword needs only swing (not even land a successful hit) the sword, and the constitution gets cancelled out to normal. As soon as the attack animation starts - POOF - it's done.
Now... I do have several spells that are used on a target creature when it is being struck - all of which depend on your alignment, and class. Yes - this sword is quite complex. :P And the spells affect allies in various ways - say, you land a strike on target creature, all your allies within certain range will heal certain amount of HP (depending on your alignment), recover from poison, disease, have their saving throws increased for a certain amount of time. And also the minimum damage made is increased by 1 (if you're a fighter wielding this sword - then it does this).

Now... I have deleted usage of these spells one by one... and when I delete them all, the sword works as it should. Constitution works perfectly. A 25 it is, and doesn't move. BUT... if I have one of these spells on, it won't work. The Constitution bonus cancels out. I have tried just casting different priest/wizard spells which heal, and improve saving throws - on my character while he has the sword, and his constitution doesn't cancel out.

I really can't figure it out. I have checked the spells I was using to cast on my character while he has the sword on (Chaotic commands, Defensive Harmony, Heal) - and I can't notice I have done anything which could cause the problem in my own spells for this sword.

In fact, I have several other swords which raise different ability scores, and disallow lowering of that ability score - and they all work just perfect! Despite that they have even more EFF files involved than this one does. But this one doesn't work - and that puzzles me.

Plz to halp? :D Would be greatly appriciated. :) Thanks in advance!

[EDIT: Never mind! SOLVED IT!! :D I simply added 3 "constitution modifiers" simply increased constitution to 25. Not setting it. And it works like a marvel!!]

Edited by What is the Matrix?, 07 March 2012 - 12:00 PM.

Neo: Why do my eyes hurt?
Morpheus: You've never used them before.

Also tagged with one or more of these keywords: BG2, TOB, Constitution, canceling, bug