Jump to content

Immediately attacked upon entering Dead Nations for the first time

1 reply to this topic

#1 -Emanuele-

  • Guest

Posted 13 December 2012 - 02:49 AM

Hi all,

I've been playing PS:T for three days and am thoroughly enjoying the game. I am playing the Gog.com version (patched 1.1.0), with the Ultimate WeiDU Fixpack, Unfinished Business and the Tweak pack as well.

I have reached the Dead Nations and upon entering the room for the first time, I am immediately attacked (no cutscene triggers). My guess is that this is a savefile issue: yesterday I tried entering the room, the cutscene triggered, but I decided to attack them to see what happens. Then I got killed, and reloaded the previous game before entering the room. It seems, though, that the event got memorized somehow and now the game thinks I already entered there and attacked the ghouls.

I noticed a similar thing in at least two other occasions: 1) I needed to identify three objects, so I saved, then identified them, then decided that I didn't want them anymore and reloaded the game BEFORE the identification, and magically one of the three items was now identified. 2) Again, in an attempt to solve the Dead Nations issue, I went there, OPENED THE GATE, and got attacked; reloaded, saved inside the catacombs, went there, and got attacked even before opening the gate, as it was ALREADY open.

Is there a way to edit the save files so as to undo the event of entering Dead Nations somehow? I am ready to mingle with binary files and such, as long as I don't have to restart the game from a very old save state :(

#2 -Guest-

  • Guest

Posted 14 December 2012 - 12:55 AM

A quick update on how I "solved" this, FYI.

I downloaded the Infinity Engine Savegame Editor ver. (r21) from sorcerers.net, ran it and opened my save files. Luckily the tool allows to view and set global game variables related to events and such. I had a rather old save file and my corrupted save file: I exported the game variables from both save files to .txt (simple but very useful feature), and compared them with TortoiseMerge, the visual diff tool coming with TortoiseSVN. Apart from obvious differences coming from incomplete quests in the old save file, it all boiled down to the variable FROM_1400, which should be set to 1 for the cutscene to be triggered (I found out this by trial & error and by noticing that 1400 is the area code of the weeping catacombs).

Now, unfortunately this is not enough. This information is stored in the .gam files in the save directories, but there is other important information stored in the .sav files, which the tool seems to ignore (in fact, deleting the .sav files and running the tool again, everything runs smooth and everything is there). What happened by only editing the game variables was that the cutscene triggered, I was correctly imprisoned in the catacombs, but then the main menu was disabled (couldn't move, couldn't check inventory, couldn't quit, etc.) and my PCs where standing there waiting for Soego to show up, which he never did. Replacing the .sav file with the other one coming from the old save rectified the issue, but then I got the game state all mangled up with quests appearing again, rare items being available again (*two* pendants of Yemeth), witnessing the events a second time, and so on.

I finally decided to give up, and restarted the game from the old save. It was quicker than I expected though, since I quickly skipped long dialogues and didn't lose time killing thugs and selling 1CP items. Now I'm a happy, if tired, dweller of the Dead Nations. Might as well become the Silent King myself.

Reply to this topic