Jump to content


Photo

Quayle Project ReDone


  • Please log in to reply
41 replies to this topic

#41 MadeMeRegister

MadeMeRegister
  • Member
  • 5 posts

Posted 29 June 2020 - 11:01 AM

Okay, the old support thread is closed now so I'm asking here - I'm not sure if my Quayle is working right, when I kick him out he just says "get out of the way bumbling simpeltons(sic)" and the red "Quayle has nothing to say to you" pops up. I can't send him anywhere, and re-recruiting him requires ctrl+q which probably would break his scripts. Any idea how to fix this problem? 


Where were you ? In what game(BG1, BG2, BG1EE, BG2EE, EET, BGT-weidu, Tutu ... ), what chapter and so on. You can pusth the x -button during the game to get area code, which you should also post.

 

BGT, in BG2 section. It happens in every area, (that I've tried, including such commonly visited areas as AR0400 [the Athkatla Slums] AR0406 [The Copper Coronet], AR0702 [The Adventurer's Mart] and AR0700 [Waukeen's Promenade]),  same with if I transfer back to BG1 areas using the console. (the mod is only for bg2 quayle btw, the original bg1 quayle is a totally different .cre file and so is not the same quayle I met in my bg1 party. That quayle worked just fine, up until the end of BG1 when he gets removed during the BGT transition cutscene where Mae'var and his boys knock your party out. It's the new Quayle from this mod, that I recruit after fighting Kurvar and letting him kill Aerie, that has the issue I described.)

 

Additionally, it seems my Quayle is having other issues with his dialogue besides this. For example, during the Renal Bloodscalp/Mae'var questline, when first meeting Edwin after returning the Storm Necklace to Mae'Var, Edwin's introductory line is supposed to trigger a line from Quayle acknowledging him and calling him "Edwin Ocheeseron", or something to that effect. However, instead of the dialogue triggering correctly, when I press "continue", the dialogue simply ends and "Edwin has nothing to say to you" appears when I try to initiate dialogue again. There might be something wrong with my 1xquayj.dlg, or else my entire dlg.tlk, although if that was the case, I'd be seeing a ton more issues than this I'd assume. Any clue what might be going on and if this is possible to fix without a reinstall? 

Finally, I want to mention that I have seen Quayle's mod dialogue work at least once, during the Planar Prison quest, where he remarked on the mind control collars as he is supposed to. So at least SOME of my mod dialogue is working as intended. Maybe that dialogue is contained in a separate file, but I thought mentioning everything relevant may be helpful. I also did check if his dialogue somehow had "broken" between the planar prison quest and where I am now, but reloading a save from pre-Haer'Dalis days, immediately starting the Mae'Var questline and meeting Edwin still did not trigger Quayle's dialogue correctly. Killing Quayle and then talking to Edwin allows the dialogue to proceed as normal, with the main character being given 4 dialogue options rather than a continue prompt, since it is no longer trying to trigger Quayle's line. And the "bumbling simpletons, get out of my way" behavior happens as soon as I recruit Quayle, I tried reloading and letting Aerie die all over again, he still never gives me the dismissal dialogue like a normal companion. 


Edited by MadeMeRegister, 29 June 2020 - 11:23 AM.


#42 Endarire

Endarire
  • Member
  • 46 posts

Posted 15 September 2020 - 10:59 AM

How EET compatible is this?