Jump to content


Photo

BGT-WeiDU 1.18, Linux Install Oddities And MOS Warnings, Oh My!

BGT-WeiDU Linux WeiDU-Linux-64bit

  • Please log in to reply
No replies to this topic

#1 Tieren

Tieren
  • Member
  • 1 posts

Posted 07 January 2014 - 05:51 AM

After doing some questionable and probably stupid things with my former bgt-weidu install in wine, the sane way to get everything back to a working state was to simply blow away the installation and recreate it from scratch.

 

I was delighted to find that some time after my last install (1.09?) native linux support was added, grabbed a copy of 1.18, and set to work rebuilding. After hitting a few things with a wrench, I believe I have everything working (or at least everything turns on and I can start a game). I did, however, run into some warnings that I thought it would be prudent to ask about, and I found an interesting fail condition for the setup-bgt.tp2 script.

 

Dead Link:

When the setup-bgt.tp2 script fails it requests that I upload it to http://forums.spellh...p?showforum=261, which is a dead link. Presumably it's indicating I should throw it here, and so I am.

 

Install Failure:   Attached File  did-not-install-setup-bgt.debug   13.77K   320 downloads

This is what happened when I simply tried to run through the install. As it turns out 

Required binaries missing for your architecture. Please put tis2bg2, tisunpack and mosunpack into your system path and install again with system-path argument.

 is showing up due to %WEIDU_ARCH% in the script reporting amd64. I was able to get around this by throwing a symlink in bgt/install/unix pointing amd64 at x86.

 

I might have glossed over it in my enthusiasm to get bgt-weidu up and running again, but I didn't see anything listing issues with weidu-64bit. Looking through the weidu release notes both os/x and linux may report amd64 as of v232. Regardless, as soon as I swapped to a 32-bit weidu or provided the above symlink, it seems to work.

 

MOS (and a couple other) Warnings:   Attached File  mostly-worked-maybe-setup-bgt.debug   2.21MB   508 downloads

This is what happens when the script reports that it worked, but includes a small pile of warning messages that I frankly lack the knowledge to interpret if there's actually an issue I need to be concerned about:

tieren@fenrir ~ $ egrep -i '(warn|error)' mostly-worked-maybe-setup-bgt.debug | sort | uniq -c
     15 Warning : Cannot delete source area MOS file
      9 Warning : Cannot delete source area _HT.bmp file
      9 Warning : Cannot delete source area _LM.bmp file
     10 Warning : Cannot delete source area _SR.bmp file
     15 Warning : Cannot handle area MOS file
      9 Warning : Cannot handle area _HT.bmp file
      9 Warning : Cannot handle area _LM.bmp file
     10 Warning : Cannot handle area _SR.bmp file

For the sake of completeness, I tried redoing everything with a 32-bit WeiDU install, and again with the 64-bit weidu install, but using v236's mosunpack and tisunpack binaries instead of those bundled with bgt-weidu. Each time I received the same warnings on the same line number of the debug output.

 

Are these anything I need to worry about going forward? So far everything seems to be working properly, but I've only just started the game. The only changes made prior to installing bgt-weidu were patching TotSC to 5512, ToB to 26498, and applying the BG2Fixpack (assuming this is referencing http://www.gibberlin...net/bg2fixpack/).

 


Edited by Tieren, 07 January 2014 - 09:37 AM.






Also tagged with one or more of these keywords: BGT-WeiDU, Linux, WeiDU-Linux-64bit