Jump to content


Setup on BGII:EE for Mac?


5 replies to this topic

#1 -Novice Mac user-

-Novice Mac user-
  • Guest

Posted 28 January 2014 - 10:30 PM

Hi!

 

I just ran across Arath and he appears to be exactly what I was hoping to find! I was wondering if there's any straightforward way to setup the mod for BGII:EE on the Mac OS (version 10.7.5)? The .exe is clearly not the answer - but I didn't know whether relevant files can just be copied into the 'override' folder, or if more needed to be done in order to get everything working properly.

 

Thanks in advance for any clues that might be helpful - looking forward to meeting him :)

 

-Novice Mac user



#2 pro5

pro5
  • Modder
  • 722 posts

Posted 29 January 2014 - 08:25 AM

I don't own a Mac, so I can't give verified instructions. But I see Kaeloree included sox in the package and TP2 uses HANDLE_AUDIO to process audio, so in theory this should install on a Mac with a proper OS X version of WeiDU binary.

 

Try this:

1. Download OS X version of latest WeiDU from weidu.org.

2. Extract the WeiDU binary from the downloaded archive (it's in the "bin" subfolder), put it into your main BG2EE game folder (it should be the one containing the CHITIN.KEY file) and rename it into "setup-arath".

3. Download the .command file attached in a zip archive to this post and unpack it into the same folder. Double-click it to (hopefully) start the installation.

 

I'd like to know if this works too - I've recently added similar install instructions on Mac OS X and Linux to the readme of a mod I'm working on, but without having a Mac I can't verify they are actually correct.

Attached Files


Edited by pro5, 29 January 2014 - 08:29 AM.


#3 -Novice Mac user-

-Novice Mac user-
  • Guest

Posted 29 January 2014 - 11:53 AM

Yes, that works well!

 

I needed to move the 'Arath' folder, the renamed WeiDU and your .command file into the 'Resources' folder and then double-click the .command file.

 

That folder should be (with a default installation) found within the following directory path: Applications/Baldur's Gate II - Enhanced Edition/Game Data/00###/BaldursGateIIEnhancedEdition/Contents/Resources

 

Two things about it - 00### is replaced with different numeric values for different people, as I understand it (mine is 00783, for example) and to get past 'BaldursGateIIEnhancedEdition' you have to alt-click and 'show package contents'.

 

You get the prompt to install the mod, and then when you run the launcher, it says 'Local Changes Detected', but will launch without incident. Just invited him along in the Copper Coronet - I was past the slaver bit, so I got some retroactive dialogues, but that's my own fault - and glad I didn't miss the dialogues entirely!

 

Thanks so much for that file and the instructions! Hopefully other Mac users will find it similarly easy to set up in future.

 

Best wishes!



#4 -BitGirl-

-BitGirl-
  • Guest

Posted 14 February 2014 - 07:22 AM

Hi, I'm going to ask my question here, as it also involves a setup issue on my mac.

 

While trying to install using BG Mac mod installer v2_1, I keep getting seeing this in the terminal, and the mod is not functioning.

 

mbpvanadegraauw:Resources Angel$ cd '/Applications/BaldursGateIIEnhancedEdition.app/Contents/Resources/'
mbpvanadegraauw:Resources Angel$ ./setup-arath
[./setup-arath] WeiDU version 23108
This is a non-stable version. Unless you're sure about what you're doing, consider downgrading.
[./setup-arath] Using scripting style "BG1"
In state 86, I expected one of these tokens:
  [104] AND_EQUALS
  [205] DIVIDE_EQUALS
  [212] BXOR_EQUALS
  [218] PLUS_EQUALS
  [225] OR_EQUALS
  [227] TIMES_EQUALS
  [334] BLSR_EQUALS
  [342] BLSL_EQUALS
  [361] EQUALS
  [375] MINUS_EQUALS
Parse error (state 86) at ~~

[ARATH/ARATH.TP2] PARSE ERROR at line 407 column 1-20
Near Text: EXISTING
    GLR parse error

[ARATH/ARATH.TP2]  ERROR at line 407 column 1-20
Near Text: EXISTING
    Parsing.Parse_error
ERROR: parsing [ARATH/ARATH.TP2]: Parsing.Parse_error
ERROR: problem parsing TP file [ARATH/ARATH.TP2]: Parsing.Parse_error

FATAL ERROR: Parsing.Parse_error

Press ENTER to exit.

 

I reckon something in the file arath.tp2 is not quite right. It seems to point to line 407, but I have no idea what I'm looking for.

406: // Journals
407: ADD_JOURNAL EXISTING TITLE (#74337) @1644 @1651 @2148 USING ~arath/translations/%LANGUAGE%/lk#aratj.tra~
408: ADD_JOURNAL @1675 @1686 @1695 @1761 @1813 @1858 @1889 @1936 @1939 @1995 @1998 @2019 USING ~arath/translations/%LANGUAGE%/lk#aratj.tra~
 

But for all I know it could be something else entirely. I do have the latest weidu version. I made sure before posting this.
 



#5 pro5

pro5
  • Modder
  • 722 posts

Posted 14 February 2014 - 09:42 AM

ADD_JOURNAL was introduced in WeiDU v232, and you're trying to install with 231:

[./setup-arath] WeiDU version 23108

 

I don't know where/how BG Mac mod installer gets the OS X version of WeiDU it uses, but you need to make sure it uses latest version (v236) instead, see link in my previous post in this thread.



#6 -BitGirl-

-BitGirl-
  • Guest

Posted 14 February 2014 - 12:02 PM

I did download the latest version and replaced it with the one I had, I made sure before I posted. I have no idea why it would still be using v. 231?

I even tried your exact instructions, but I didn't have the proper rights to run the .command file. I tried to change the rights to the file, and even transfer the rights from the above directory, but that too didn't work. (weird, 'cause I already changed the rights of other setup files to ensure they would run)

 

So I started over. I downloaded the latest weidu again, and replaced the weidu already in my gamefolder. I also added a renamed "setup-arath"-weidu to my gamefolder and tried the BG Mac mod installer again.

This time it worked like a charm. :)

 

Since it is just slightly different from the instructions you posted, I decided to share it here, in case others have a similar problem.

 

Thank you for your time :)





Reply to this topic