Jump to content


Photo

User interface bug? Can't allocate stat points because mouse is al


  • Please log in to reply
6 replies to this topic

#1 YogSothoth

YogSothoth
  • Member
  • 4 posts

Posted 07 March 2014 - 11:47 PM

Late to the party here, but really looking forward to finally playing PS:T

 

I'm having a problem with something that seems like a UI bug to me.

 

Machine info: iMac 2.8 GHz, ATI Radeon HD 2600 Pro 256 MB, running OS 10.9.1

Running the GOG version of PS:T in a Wineskin wrapper.

 

Used the game mods listed here:

http://thunderpeel20...lly-modded.html

I added the mods slowly, testing after each. Everything worked. 

 

Then I added the widescreen mod - and got this update to work after realizing that I had to update the WeiDU file that masquerades as setup-widescreen.exe to version 23600. (Widescreen uses an earlier version)

 

In widescreen setup, I asked for 1280x900 resolution and installed Ghostdog's UI mod.

 

Started the game, which looks awesome, BUT...

 

When I get the stats screen to make a character, as soon as I click a mouse button to allocate points, the UI freaks out as if I was constantly clicking on "Accept" for the stats screen. The clicking repeats indefinitely. Since this throws a game error window which blocks the stats allocation, I can't get past it.

 

I tried other resolutions, and changing my monitor resolution, but no luck. Has anyone seen this?

 

Thanks for a great modding community.

 



#2 YogSothoth

YogSothoth
  • Member
  • 4 posts

Posted 08 March 2014 - 03:51 PM

Update -- resolved. After this, I started getting errors that I was out of system memory. Apparently all that testing ate it up and didn't release it. Restarted, removed and reinstalled 1280X800 and the problem went away, game looks great.

 

Of course, now I'm getting crashes when I go into a building in Sigil - it asks for CD number 255 (??) but that's a much different problem.



#3 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4792 posts

Posted 08 March 2014 - 04:44 PM

Of course, now I'm getting crashes when I go into a building in Sigil - it asks for CD number 255 (??) but that's a much different problem.

What does your torment.ini say about the CD's... copy paste the files test if you don't know what that means... and open the file with Notepad, or whatever Mac's TextEdit you use.

 

I wouldn't be sure your display can show the 1280x900 resolution, which was probably part of the problem.


Edited by The Imp, 08 March 2014 - 04:54 PM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#4 YogSothoth

YogSothoth
  • Member
  • 4 posts

Posted 09 March 2014 - 08:46 PM

Thank you very much for the reply.

 

The torment.ini says this about the game files:

 

[Alias]
HD0:=C:\GOG Games\Planescape Torment\Planescape Torment
CD1:=C:\GOG Games\Planescape Torment\Planescape Torment\data\
CD2:=C:\GOG Games\Planescape Torment\Planescape Torment\data\
CD3:=C:\GOG Games\Planescape Torment\Planescape Torment\data\
CD4:=C:\GOG Games\Planescape Torment\Planescape Torment\data\
CD5:=C:\GOG Games\Planescape Torment\Planescape Torment\data\
[Config]
...
 
Ah-ha.. You are right, thanks for the suggestion. I bet I need to put the current location of the patched and upgraded game here in the .ini file. I kept the GOG downloaded version unpatched and unedited so I would have something to revert to in case of errors. :)
 
The error Wine throws at me says that the game should be played on a 16 color bit depth screen. I'm not sure I can make that change anymore on Mac OS 10.9.. I looked / googled without success. It still seems to play though. 
 
I let you know if it works. Cheers!


#5 YogSothoth

YogSothoth
  • Member
  • 4 posts

Posted 10 March 2014 - 04:20 PM

Yep, everything seems to working now. Stoked! Thanks!



#6 -Chris-

-Chris-
  • Guest

Posted 27 February 2017 - 10:08 AM

HELP! Same problem here. Nothing works, tried everything...



#7 -Chris-

-Chris-
  • Guest

Posted 27 February 2017 - 10:59 PM

up edit: OMG, I'm speechless. Woke up today, turn on PC and... game works like a charm. I do nothing. It seems that after the installation (game + mods) reboot is required.