Jump to content


Photo

General issues and other shenanigans


  • Please log in to reply
12 replies to this topic

#1 Avallach

Avallach
  • Member
  • 25 posts

Posted 13 November 2014 - 05:19 PM

Hello!   So after like 200 years I have finally decided to reinstall, remod and replay BG2. However, I seem to have run into an issue regarding the Infinity Animations.   The installer keeps telling me that my ANSI Codepage is set to 0, and I also get an error about regedit not being the correct command name (in czech, since I am.. well, czech :D)?   I have restarted the computer after it supposedly set my regional codepage to 1252, but nothing changed, it still says 0. I also checked in regedit, and the value was 1252, but it still refuses to install...   So eh... any ideas?   Thanks in advance! :)


Edited by Avallach, 16 October 2020 - 03:30 PM.


#2 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5016 posts

Posted 14 November 2014 - 12:01 AM

It's likely that the Infinity Animations setup didn't have the needed approval rights to do the necessary change when you ran it, so it doesn't do a thing.

Now it's easy to manually do what's required, this was in the English windows 7, so yours is likely to be close to this but also not the exact same, as you have the OS language and all:

This can be done as follows on Windows systems:
* Start ->
* Control Panel ->
* Regional and Language Settings in Classic View OR:

Clock, Language and Region -> Region and Languages, in the fancy view ->

* Click on the Advanced or Administrative tab ->
* Then where it talks about non-Unicode programs, change the language to English(United States) -> Windows-1252 "ANSI"
* Then remember to click the Apply. And you need to restart the computer for it to actually take effect.

Also after you make the change, you HAVE to re-extract the Infinity Animations archives after the restart, because unfortunately the codepage also alters the file names written at the extraction. 

After you'll have these letters in them:

£/µ/Þ/ ...

Edited by The Imp, 14 November 2014 - 12:04 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#3 Avallach

Avallach
  • Member
  • 25 posts

Posted 16 November 2014 - 10:24 AM

I already did that control panel thing and it didn't worked..

 

... however I just tried it again out of boredom today, and it worked!.

 

So thanks anyway! :)



#4 Avallach

Avallach
  • Member
  • 25 posts

Posted 15 October 2020 - 05:05 PM

EDIT: nvm, solved.


Edited by Avallach, 15 October 2020 - 07:41 PM.


#5 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5016 posts

Posted 16 October 2020 - 05:12 AM

... however I just tried it again out of boredom today, and it worked!.

Likely a case of not having originally restarted the computer or re-extracting the archive after the change. As both are needed. Yes, a 6 year old reply.

 

You solved your issue... and what was it ? etc.

The Windows 10 guide is the exact same thing as the above for Windows 7. 

I am told that the next Infinity Animation update should solve this issue permanently, but until we get it, this is still an issue that can come up, and we don't know when the next update will be, as it's likely a time and EE game updates based, not just a mod makers want based one, as there's a likely crosscompatibility things to come up yet again that are unwanted.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#6 Avallach

Avallach
  • Member
  • 25 posts

Posted 16 October 2020 - 08:05 AM

... however I just tried it again out of boredom today, and it worked!.

Likely a case of not having originally restarted the computer or re-extracting the archive after the change. As both are needed. Yes, a 6 year old reply.

 

You solved your issue... and what was it ? etc.

The Windows 10 guide is the exact same thing as the above for Windows 7. 

I am told that the next Infinity Animation update should solve this issue permanently, but until we get it, this is still an issue that can come up, and we don't know when the next update will be, as it's likely a time and EE game updates based, not just a mod makers want based one, as there's a likely crosscompatibility things to come up yet again that are unwanted.


Well, basically I had an issue that some parts of the installation were skipped (genies, fiends, NWN1 anims), even though I already extracted them the correct way (English codepage, restart, use 7zip/Winrar without paths etc.).

 

It wouldn't recognize those files being in the content folder no matter what.

 

Then later on, I tried switching the Windows language interface to English (US), and that for some reason made it work. Just having the codepage set to 1252 wasn't enough, apparently.


Edited by Avallach, 16 October 2020 - 08:06 AM.


#7 jastey

jastey
  • Staff
  • 2392 posts

Posted 16 October 2020 - 09:42 AM

IE games forums is like the only place where you can have a discussion with a 6 year gap in between.

#8 Gwendolyne

Gwendolyne
  • Staff
  • 903 posts

Posted 16 October 2020 - 11:55 AM

This issue is definitively solved in the incoming version.


CARPE DIEM ....
 

In progress : Menace sur le Royaume de Diamant Éternel there.

#9 Avallach

Avallach
  • Member
  • 25 posts

Posted 16 October 2020 - 03:29 PM

Good to know!
 
...until then I am afraid there is unfortunately another issue. :D
 
After generalized biffing, the game just straight up crashes right after the character creation and first loading screen (so pretty much when the intro of Irenicus experimenting on us is supposed to play).
 
I narrowed it down to IA, since after removing the entire thing and re-biffing the folder again, the game progresses just fine. Any idea what could be causing it, in connection to said biffing? Maybe symbols getting changed again etc.?
 
Also, Throne of Bhaal new game works without issues, which leads me to believe it has something to do with the first area of SOA? (AR0602)
 
EDIT: Ok, after reverting back to 1252 and English interface again, I went section by section of IA to find out which one is causing the crash after biffing.
 
Turns out it's the "More Icewind Dale II Animations" part. Any idea why is it causing that after almost 10 years of it working just fine in the past? :blink:

 

EDIT 2: Alright, I kinda solved it by biffing my game first and then installing IA after that. Didn't really make that much of a difference, since it was usually near the end of the load order anyway. And at least the lag is gone now. :D


Edited by Avallach, 16 October 2020 - 04:59 PM.


#10 Endarire

Endarire
  • Member
  • 59 posts

Posted 16 October 2020 - 10:25 PM

I'm pretty sure other places experience multi-year gaps in conversations as well.



#11 Gwendolyne

Gwendolyne
  • Staff
  • 903 posts

Posted 17 October 2020 - 07:46 AM

Good to know!
 
...until then I am afraid there is unfortunately another issue. :D
 
After generalized biffing, the game just straight up crashes right after the character creation and first loading screen (so pretty much when the intro of Irenicus experimenting on us is supposed to play).
 
I narrowed it down to IA, since after removing the entire thing and re-biffing the folder again, the game progresses just fine. Any idea what could be causing it, in connection to said biffing? Maybe symbols getting changed again etc.?
 
Also, Throne of Bhaal new game works without issues, which leads me to believe it has something to do with the first area of SOA? (AR0602)
 
EDIT: Ok, after reverting back to 1252 and English interface again, I went section by section of IA to find out which one is causing the crash after biffing.
 
Turns out it's the "More Icewind Dale II Animations" part. Any idea why is it causing that after almost 10 years of it working just fine in the past? :blink:

 

EDIT 2: Alright, I kinda solved it by biffing my game first and then installing IA after that. Didn't really make that much of a difference, since it was usually near the end of the load order anyway. And at least the lag is gone now. :D


Very weird cause this has never been reported and has never occurred to me. I test the new version install one every two days in average and the game never crashed. Will try to reproduce it.


CARPE DIEM ....
 

In progress : Menace sur le Royaume de Diamant Éternel there.

#12 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5016 posts

Posted 17 October 2020 - 09:17 AM

...
Very weird cause this has never been reported and has never occurred to me.
With Gen Biff, this has... but I can't say for sure what the cause was there. Perhaps it's IA files being coded in Latin, getting used in Latin, and then being biffed again in non-Latin, which will break the game as it can't find the non-existent files.

Edited by The Imp, 17 October 2020 - 09:17 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#13 Avallach

Avallach
  • Member
  • 25 posts

Posted 24 October 2020 - 07:43 AM

Sigh, guess I spoke too soon.

 

Made my way to Waukeen promenade and there the game crashes straight to desktop (with no logs either in the baldur.err or TobEx), when I enter the first area of the circus (AR0600).

Only creatures there I know of are a Djinn, Werewolves and Shadows.

 

Uninstalling entire IA makes the are accessible.

 

I am enclosing my WEIDU log. Really strange, because I used pretty much the same load order/mod installation order in the past for a few years, and it always worked just fine.

 

Only thing that changed in 2020 is the fact that I am just using the newest versions of said mods. :

Attached Files


Edited by Avallach, 24 October 2020 - 10:45 AM.