Jump to content


Need help with Weidu on mac/installing BGT

mac

  • Please log in to reply
1 reply to this topic

#1 -Hereward-

-Hereward-
  • Guest

Posted 16 January 2015 - 05:17 PM

Hello, I have run into several problems trying to install BGT on mac. I am afraid my knowledge of coding and modding is quite limited.

I have BG1 EE, and BG2 complete (non-ee). Don't know if this is a problem.

They have been installed separately, and I do not have a windows partition (would highly prefer not to make one).

My main source for instructions on how to install BGT on the mac have revolved around this page http://www.weidu.org/Mac.html.

On this page, it lists two solutions. I will paste both and describe my problems with each.

" Copying Option.

    Copy weidu-mac over Setup-Foo.exe (where Foo is something like Solaufein or Tactics or whatever is appropriate for the mod you are installing).
    Run Setup-Foo.exe (you may have to type ./Setup-Foo.exe to do so) "

If I try this option, the weidu terminal window tells me that I am not installing in a valid game directory. I have tried opening the files in the directories contents/resources/ and contents/resources/drive-c/GOG games/Baldur's Gate 2.

" Hand-Installation Option.

    Run weidu-mac Setup-Foo.tp2 --tlkout dialog.tlk "

I am afraid I do not know exactly what this means. I am not very familiar with the correct commands to type in the standard mac terminal or the weidu terminal. If it means that I should run a mac weidu file in the above directories and then try to run setup-bgt.tp2 within the weidu terminal window, I get the result

sh: -c: line 0: unexpected EOF while looking for matching `''
sh: -c: line 1: syntax error: unexpected end of file
logout

This is when I type 'weidu setup-bgt.tp2' in the weidu terminal. If I try to identify the precise address of the file, e.g. /Applications/Baldur's Gate 2/Baldur's Gate 2.app/Contents/Resources/drive_c/GOG Games/Baldur's Gate 2, the terminal says there is no such address - it seems to have a problem with locating a file within a .app file - the 'wrong address' feedback cuts off the address at /Applications/Baldur's Gate 2/Baldur's Gate 2.app.

Sorry for a complicated question on what must be an awkward subject, but I have tried my hardest to try to solve the problem.
 



#2 hook71

hook71
  • Member
  • 276 posts

Posted 17 January 2015 - 11:19 AM

BGT is not compatible with the EE versions of BG. You'll have to get the original version of BG1 to make it work with BGT.







Also tagged with one or more of these keywords: mac