Jump to content


BWS Questions/Problems


  • Please log in to reply
4 replies to this topic

#1 Gygax

  • Member
  • 12 posts

Posted 27 January 2015 - 11:23 AM

Is there a reason the BWS literally  FORCES me to download every SINGLE mod i need when i have them already and have pointed it to the folder they are in? beside it being an inconvienece its also an irritating waste of time...also why isit asking for stratagems v28 but downloading stratagems V30?


It seems really redundant that it wants to download mods it already knows are there...


I had 3 install issues with the old Weidu installer every time i use BWS something goes wrong with it missing areas,damaged creature's broken installs language changes from english to german/french



any info on why this keeps happening would likely reduce my  irritation and perhaps provide information for others having these issues..

Edited by Gygax, 27 January 2015 - 11:37 AM.

#2 dabus

  • Member
  • 1982 posts

Posted 27 January 2015 - 11:52 AM

BWS skips the download when the files are there. At least it worked for me testing just some minutes ok.
You can also look into the log why it got the file.
bg2eetp[]= BG2EE_TP_Alpha0000003.rar = 11585812
<= BG2EE_TP_Alpha0000003.rar = 11585812
BG2EE_TP_Alpha0000003.rar has been downloaded before.
WeiDU[]= weidu.exe = 972288
<= WeiDU.exe = 972288
WeiDU.exe has been downloaded before.
First line is the expected outcome.
Second line is the local file that's found with that name.

The expected name and size are always fetched by wget before the download. If wget does not work for you, that may be another reason why it's not working for you. If the byte-size or the files name differ, you'll also be forced to reload.

If things are missing, it will look like this:
WeiDU[]= weidu.exe = 972288
<= NA
Fetching WeiDU.exe
You can also see if the size differed.

If you know that those files are ok, you can just skip the download-process. The things like searching for missing "downloads" will still be done and you can force to use the present files.

Stratagems... because that's the name that was in the config-file while someone made an update and put the file on the server with the same download-url. Happens every few weeks. If guys would (want to) help out, these differences could be minimized.

Dunno what you mean with old installer... If you mean that the BWS produces errors... Yup, may happen. If you got logs/debug-files/changelog weidu than that can be handled, too.

Edited by dabus, 27 January 2015 - 11:53 AM.

THINK! - It's not illegal.

#3 Gygax

  • Member
  • 12 posts

Posted 27 January 2015 - 12:31 PM

i cancelled the installation moved my files from external storage and that fixed the problem of re downloading but i pointed the installer AT the external location and did not read for some reason...maybe something on my system that was interfering or BWS does not like external paths


i used to use a weidu installer had to manually unpack everything but that diapered somewhere i cant recall what it was called but was very similar to BWS just had walls of white text on standard black background once install was started 

Edited by Gygax, 27 January 2015 - 12:37 PM.

#4 dabus

  • Member
  • 1982 posts

Posted 27 January 2015 - 12:58 PM

That's the BiG World Installpack.
The BWS is similar because I wrote it so that it should be more comfortable to use than the BiG World Installpack while doing the install with the same tools in the background.
The installpack does not download files, it ships with a batch that could do the unpacking (does not advertise it though).
The BWS can do both and you've got the option to either use the installpack to install or customize your stuff on component level, which will result in the BWS also handling the install.

By the way; Since every person has other preferences, I also added an option to export the url-list, so you could use other tools to fetch those files.

Edited by dabus, 27 January 2015 - 01:01 PM.

THINK! - It's not illegal.

#5 Gygax

  • Member
  • 12 posts

Posted 27 January 2015 - 03:40 PM

It is a nicer to look at that's for sure  perhaps i was creating the problems? i have been having just odd that i have only ever had 1 install with it that worked perfectly (HDD death ended that run) maybe it's something i was doing and not noticed (forced installed the wrong mod perhaps)


Thanks for the feedback :) 

Also tagged with one or more of these keywords: BWS