Jump to content


Photo

Help with BWS setup


  • Please log in to reply
6 replies to this topic

#1 ccain96

ccain96
  • Member
  • 3 posts

Posted 11 June 2015 - 10:45 AM

This is my first post, :clap:  , but I've been a fan of this site for years.  I'm an experienced BG player, and using mods, but I am not a scripter or programmer.  Long story short, I have all the mods that I want to use, I have the latest BWS files located in my BG2 install location  (no it's not UAC protected), but I can not get the BWS to run successfully.

 

I usually like to go with the "tactics" version of installation, but I go in and manually choose which mods I want/don't want, however it never seems to keep my selections, because as soon as I start the installation, it's downloading all the mods I've already got in the downloads section.  It always says I'm missing mods, even though I confirm everytime the mods are there.

 

I will provide details as needed, but I am looking for just some basic steps to make sure at the beginning of the installation, and what I'm trying to do is feasible.

 

Steps I've done:

1.  Complete install with full options of BG1/BG2, all patched... with main/dialog.tlk/chitin key and others copied to another location for the "rollback" scenario

2.  All mods that I want in my game located in the "BIG world downloads" section  (however the program never seems to see the rar's in there...

 

If anyone could help with a  1,2,3 step procedures at first, then I'm hoping I can fix this myself.



#2 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5042 posts

Posted 11 June 2015 - 10:57 AM

When you say the latest, is the latest the bws_20150302.exe in these pages, or the very latest zip archive file in the Banches tab ? Cause for it to work properly actually, it needs to be the later one, not the mentioned 3 months old version. What Operation System do you have, cause if it's a Windows 8.1, all the freaking folders are image reflection protected except the C:\Users\<username>/ -folders, cause the images are stored in an invisible subfolders of there.
Also you don't have the horrible Comodo Virus Protection program, right ?


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#3 ccain96

ccain96
  • Member
  • 3 posts

Posted 11 June 2015 - 11:01 AM

I actually just read your section for going to the branch tab and using the more up to date BWS program, so I will try that here shortly.  I'm using Win7Pro... and I use Norton 360, but I always turn it off and unplug from the internet when I have all my mods in order.  I'm still perplexed why the BWS install doesn't recognize the rar files as I made sure I had the latet and greatest... and even when it goes out and supposedly downloads it...  it comes back telling me that I'm missing "critical mods"...  "sigh"..    I'll try the newest BWS and make sure my mods are in the right place.. and fire this thing back up



#4 ccain96

ccain96
  • Member
  • 3 posts

Posted 11 June 2015 - 11:17 AM

Also, off the top of my head... when I launch the big world setup, and I choose "tactical", and I go in and select/uncheck the mods I want and don't want....  it doesn't seem to stick.  When I get to the part of it downloading mods I need, it downloads mod I had left unchecked because I knew certain mods would be trouble.  My question is this:  What is the point of clicking on the "choose mods and components" option under Community defined mods compliation, if it doesn't keep what I select/don't select?



#5 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5042 posts

Posted 11 June 2015 - 11:32 AM

Are you still using the old version ?
Cause the mods it remembers have been updated and the file sizes have been changed... also you have to start the BiG World Setup.vbs with Admins privileges or it could not do some of the things right. Someone else might have to give more up to date info. Cause I haven't actually touched the install for a while.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#6 dabus

dabus
  • Member
  • 1982 posts

Posted 11 June 2015 - 12:17 PM

BWS.vbs starts the AutoIt3-script in an elevated state, so starting as Admin should not be an issue (I see that "do you allow this program to make changes on this computer?" every time I double-click it.).
Concept is to load what you selected (including dependencies you selected to solve by adding them).
You can see the selection in the BiG World Setup\config\user.ini underneath the [Save]-section.
Actions are logged in different logs, so you could try to look at BiG World Download Debug.txt. You can see the checks there...

JA#BGT_Tweak[]= JA_BGT_Tweak-1.71.zip = 9766894
<= JA_BGT_Tweak-1.71.zip = 9766894

This would be mod = filename = Size
Found name = Found size

BWInstallpack[]= BiG World Installpack v11.1.7z = 976974
<= NA

NA means to available, so this will be loaded.

If your PC does not work with wget (the download tool), the sizes will always be "unclear"/wrong and the BWS will try to catch them.

You could export the URLs you selected with the BWS and feed another tool with that data.
You could skip the download and just check missing files / enforce the loading of the files you got.

If those fail, you could try do download with some help of Kerzenburgs linklist and try to use the BiG World Projects batch-files.
THINK! - It's not illegal.

#7 Evani

Evani
  • Member
  • 29 posts

Posted 30 June 2015 - 01:00 PM

Hello,


I'm in a fairly similar situation as well, except that AutoIt freezes/ crashes during the mod selection screen, selection export screen, conflict resolution, or 'the mod isn't installed in any of the versions' screen so I can never finish selecting or saving my mod selections. I've done every recommendation I've found in the forums so far except that my installation for windows 8.1 isn't in the C Drive (It's too small for a mod heavy install). Is that the issue?

I've gotten to the actual installation process once but the installer froze over and encountered a fatal error reading the debug file. I have no idea how to replicate that though.