Jump to content


Works with The GoG-version?


6 replies to this topic

#1 -UrszaTheGeek-

-UrszaTheGeek-
  • Guest

Posted 08 July 2016 - 02:18 AM

Sorry if I am asking a really stupid question - but I am lacking experience with mods; now since I always liked Tieflings and Haer'Dalis was - next to Minsk - my favorite companion in BGII I simply want to download and play your mod.

Now I don't find my "original" hard-copies of BGII and Throne of Baal anymore, so I downloaded the game on GoG. (It's called "Baldur's Gate II - Enhanced Edition"; there is another edition out there as well). Now... while I think your mod should work... I wanted to ask whether it works with the GoG-version as well?

 

I really hope so, since I don't want to have another playthrough where I am stuck either with one out of three women where NONE of those is my taste, or with Anomen... nothing against Anomen... but hey... nobody beats a Tiefling-Bard!

 

Many Greetings from

UrszaTheGeek.



#2 Mike1072

Mike1072
  • Member
  • 526 posts

Posted 08 July 2016 - 02:33 AM

Both the original games and the Enhanced Editions can be purchased on gog.  The content of the gog versions of the original games should be identical to the content of the disc versions, and the content of the gog versions of the Enhanced Edition games should be identical to the content of the Beamdog and Steam versions of the Enhanced Editions.  Due to some packaging differences, users of the Steam and gog Enhanced Edition games may need to use the modmerge tool before they can mod their games.

 

The latest version of the Haer'Dalis Romance mod claims to be compatible with BGII:EE, so you should be okay.



#3 -Guest-

-Guest-
  • Guest

Posted 08 July 2016 - 03:20 AM

Thank you for your quick response!

I tried to install it without the modmerge-tool first - I got a notification where I was asked whether the program was installed correctly, and I could choose between 2 options: "Yes, it was installed correctly" (not the right phrasing I guess) and "Re-install in compatibilty (?) mode" (sorry, I am not a native speaker and thus run my Windumb 8 on my mothertongue, so I have to translate the stuff back into english... I hope you get what those notifications mean). I chose the 2nd option (the re-installation), and then it seemed to work... I got the line "Installation successful" at the end ... so... I hope it works.

 

Sorry for another stupid question :crying: ... is there a way to check whether the mod will run before you meet Haer'Dalis and get into the Sphere? (I guess that's when the story would start basically, right?)



#4 Mike1072

Mike1072
  • Member
  • 526 posts

Posted 08 July 2016 - 01:05 PM

You should be able to open WeiDU.log in your game directory using a text editor to see a list of all components you have successfully installed.

 

Modmerge would only be necessary if you were unable to install mods.



#5 -Guest-

-Guest-
  • Guest

Posted 08 July 2016 - 04:18 PM

I followed your instructions concerning the WeiDU.log. It says:

 

// Log of Currently Installed WeiDU Mods
// The top of the file is the 'oldest' mod
// ~TP2_File~ #language_number #component_number // [Subcomponent Name -> ] Component Name [ : Version]
// Recently Uninstalled: ~HAERDALISROMANCE/HAERDALISROMANCE.TP2~ #0 #0 // Haer'Dalis Romance (SoA & ToB): v2
~HAERDALISROMANCE/HAERDALISROMANCE.TP2~ #0 #0 // Haer'Dalis Romance (SoA & ToB): v2

 

 

If I am not mistaking all lines starting with // are "inactive"... and I guess the // Recently uninstalled [...] might hint at the fact that the addon wanted to be "re-installed" with compatibility-modification? 

The next line (starting with ~ ) hopefully means it's working?

 

Sorry again for bothering you... I am only Geeky when it comes to everything useless (and Biology), so until PCs turn into biological cylons (or centurions being able to talk ^^) I have to ask people with a better understanding for software, hoping that things get stuck in my head so I don't need to ask again :/



#6 Mike1072

Mike1072
  • Member
  • 526 posts

Posted 08 July 2016 - 07:32 PM

No worries.  Looks like it's definitely installed.



#7 -Caszidy-

-Caszidy-
  • Guest

Posted 17 July 2016 - 10:29 PM

Hello, I don´t want to start extra topic, so I ask here  :ermm: Can I install Unfinished Business component Murder of Acton Balthis (that quest for Haer Dalis), or is this already in some form implemented in Haer Dalis romance? Thanx ;-)





Reply to this topic