Jump to content


Photo

Isaya's patched version


  • Please log in to reply
18 replies to this topic

#1 agb1

agb1
  • Member
  • 1623 posts

Posted 20 November 2016 - 07:30 PM

Isaya posted a patched version of this mod here:  http://www.shsforums...ility/?p=567986

 

Noting it here for consideration in future releases and because I had a hard time finding his post and it might be of interest to others.

 
Despite the version number in Isaya's post saying v2.2, it was published after v3.1.  Possibly Isaya used that number for his file because v3.1 still says 2.2 in the VERSION string in the tp2 file.

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#2 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 13 August 2017 - 02:51 AM

Gone


Edited by Roxanne, 14 August 2017 - 06:49 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#3 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 06:26 AM

Wait, why is it only for BG2EE and EET? Why wasn't it made the way to make sure it works on different platforms?



#4 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 06:34 AM

Wait, why is it only for BG2EE and EET? Why wasn't it made the way to make sure it works on different platforms?

There are existing versions for the rest, there is no need to change them.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#5 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 06:39 AM

But why have 2 different packages and confuse players. I am in touch with Kaeloree, but it should be updated properly, to make one package work on different versions rather tahn make different versions for different games. Like it was done with most mods, my mod series etc. If it's made that way, I may be able to arrange proper upade in the download manager.



#6 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 06:49 AM

But why have 2 different packages and confuse players. I am in touch with Kaeloree, but it should be updated properly, to make one package work on different versions rather tahn make different versions for different games. Like it was done with most mods, my mod series etc. If it's made that way, I may be able to arrange proper upade in the download manager.

It was K4thos suggestion to make the EET version known to other users as well because it might solve some problems with UTF8 code for them as well. If you say this is the wrong place here, then it will be removed. We thought it would improve the situation compared to what it was before, but obviously this is not the case.


Edited by Roxanne, 14 August 2017 - 06:49 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#7 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 06:56 AM

I mean that utf-8 conversion may be done upon installation and that's how most mods handle this. Now people who are not aware how EE works may install wrong version of it, because there are 2 of them and they will find out there may be problems when it's already too late and they would need to reinstall game or risk and reinstall many mods and hope that nothing will go wrong during the reinstallations. I suggested it should be updated as other mods that work on both old game and EE and instead you deleted links... I kinda don't understand it.



#8 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 07:00 AM

Updating the mods was done after this statement was published:

 

I did indeed contact the mod author. His response was as follows:

 

"Hi!

I'm really sorry, but I don't maintain my mods anymore! I'm more than happy for other people to update them, but I don't have the time or inclination to keep things going unfortunately.

 

Sorry!

 

Liam"

There are no such conditions or other strings attached to it.

If there has been a misunderstanding about scope and backwards compatibility, then all converted mods need to be removed and the former status needs to be re-established until somebody is found to do the updates under the revised conditions.

 

 

The full discussion of the issue is here http://gibberlings3....opic=28887&hl=.


Edited by Roxanne, 14 August 2017 - 07:04 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#9 Cahir

Cahir
  • Member
  • 105 posts

Posted 14 August 2017 - 07:08 AM

Lava, I think Roxanne doesn't play vanilla BG2 anymore (only EET as I understand) and is simply don't interested in providing backward compatibility taken into consideration that all Liam's mods are in perfectly stable condition for vanilla users.

#10 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 07:13 AM

Lava, I think Roxanne doesn't play vanilla BG2 anymore (only EET as I understand) and is simply don't interested in providing backward compatibility taken into consideration that all Liam's mods are in perfectly stable condition for vanilla users.

Exactly.

The users of the old game have stable mod versions. There is no further development of any of these mods for the old games. There is no need for updated versions.

We branch off an EET compatible version and keep that alive and maybe even do furtehr development over time. A new generation of games and players can enjoy the old mods this way. Otherwise it will never happen, since nobody can do all the testing for the old games to ensure nothing is broken there. And users of the old games have no advantage at all from the new versions, so why hinder progress by useless requirements?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#11 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 07:20 AM

Ugh, but there are EE users who may donwload vanilla version and still encounter problems, because OFFICIAL download is outdated. I asked politely because I am in youch wil Kaeloree and I may ask him to opload the official download if the update is made properly so people could download the mod from SHS downloader and enjoy the game no matter what game they use. That's why I asked - to make it safe for all users.



#12 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 07:30 AM

Ugh, but there are EE users who may donwload vanilla version and still encounter problems, because OFFICIAL download is outdated. I asked politely because I am in youch wil Kaeloree and I may ask him to opload the official download if the update is made properly so people could download the mod from SHS downloader and enjoy the game no matter what game they use. That's why I asked - to make it safe for all users.

What you describe is the existing situation.

I tried to improve it by pointing to an EE/EET capable version.

You prefer status quo until somebody is found to maintain the mods for old AND new games. Until that day, it seems we have to revert to the previous state then.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#13 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 07:35 AM

What? I just said that it can be done. I would even help checking if it intalls fine on the old version. I also said that if such a version is prepared, I may ask Liam to upload the file so it was all clear for all mod-users and so people who visit only the download menager and do not search through forum threads could safely download a safe version. Instead you are acting as if I wanted no new versions at all. Yeah, 'cause that's exactly why I am doing my best to make my mods work on every possible platform. PLUS I also asked to find out what you actually changed, as no one updated changelog.


Edited by Lava Del'Vortel, 14 August 2017 - 07:37 AM.


#14 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 07:50 AM

The approach to leave the *old game* versions as they are, i.e.in their last *official* version and status and start a new branch for the EE/EET games is not new.

I have done this successfully for the Chloe NPC mod already, even involving active participation from the original modder who helped with her abandoned ideas.

Similar things have been done for DSotSC or TDD. There is also development ongoing for other long abandoned mods.

It is simple fact, that nothing has been done on these mods for years and maybe never will if we introduce unneccesary restrictions.

It is much cleaner approach to say e.g. versions up to 2.2 of the mod are for old game, vesrions 3.0 and beyond are for new game. It is much clearer and safer than to maintain two versions within one mod package using GAME_IS etc and trying to preserve such a vehicle over the next decade. But if someone likes to do it, why not?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#15 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 07:59 AM

I just told you that I can ask Liam upload new version if it will be uploaded properly, with the mod working on all versions of the game! I offered help in checking if it's working on vanilla version. And no, you are wrong. Right now, someone who is using EE or EET may go directly to the download menager and download the official, outdated version, use Polishi translation and it will break his game. Then he/she will check the forums and realize the wrong version was installed. Making updated official version is much safer for everyone.



#16 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 14 August 2017 - 08:39 AM

What you describe is not correct

And no, you are wrong. Right now, someone who is using EE or EET may go directly to the download menager and download the official, outdated version, use Polishi translation and it will break his game. Then he/she will check the forums and realize the wrong version was installed.

...and will find out that there is no other version and that the mod is not available for his/her game. This is where we are today unless we change it. Or keep waiting for it to somehow change...

 

You are looking at that from the perspective of a mod like Yoshimo friendship which is one or two scripts and a dialogue file. I have done this for a mod like Region of Terror where a *one mod serves all* comes out as a 550MB package, just to find that with any install you just need 260MB of that because thousands of area graphic files and animations are for the other game and never used in your install. This is a source of errors and not maintainable in the long run.

 

Anyway, you made your (and Kaeloree's?) point clear. So be it.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#17 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 08:45 AM

There are no area files here, so there is the whole area thing is inadequate. The point is to make a file that will work with every game; a package that anyone can use without wonderis if that's the one he/she should use. And making that is simple.

And I am speaking for myself. I only contacted Kaeloree to ask if it's possible to upload new version to the right section.



#18 Cahir

Cahir
  • Member
  • 105 posts

Posted 14 August 2017 - 12:35 PM

Lava problem here is who will spend the time to update all Liam's mods the way it will be compatible with both vanilla and EE/EET. Roxanne offered to make them compatible with EE/EET but since she considers vanilla engine obsolete she has no interest to spend the time for coding and testing updated mods on vanilla BG2. Everyone would like to have these mods to be compatible with all versions but to this day nobody (except Roxanne) offered to carry the torch. I don't mind having two versions, why not put both of them on SHS?

#19 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 2255 posts

Posted 14 August 2017 - 12:39 PM

Because not every person always knows what version should be used on what platform, Cahir. And I will spend my time on those updates. I actually already prepared new versions of all released IEP mods, now I'm just making sure they're going to work fine on all game versions - vanilla, EE and EET.