Jump to content


ToB is required to install Error

Error Throne of Bhaal Darian

  • Please log in to reply
5 replies to this topic

#1 -AnnDarkwater-

-AnnDarkwater-
  • Guest

Posted 11 December 2016 - 05:52 AM

Just as in a title... I get ToB is required to install error ( Yes, I do have it. I have EE) Now, I tried to edit  tp2 file by adding slashes. Helped  (sort of) but now error with override folder is appearing. I'm at my wits end here. Did anyone expirience this error before?

 



#2 agb1

agb1
  • Member
  • 1623 posts

Posted 11 December 2016 - 06:43 AM

Nephele has not been made compatible with EE yet. You are attempting a conversion. What is the exact error?

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#3 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4810 posts

Posted 11 December 2016 - 06:56 AM

Nephele has not been made compatible with EE yet. You are attempting a conversion. What is the exact error?
v2.3 now with BGII:EE compatibility!
Says otherwise... but the EET might be teh issue... so:
N...What is the exact error?
It's likely due to this, it's not the usual ToB error, but still it's the same thing, not updated .tp2 file to the very last generation of weidu.exe standard:
// --------------------------------------------
// Nephele NPC Mod v2.2
// --------------------------------------------
// Component setup
BEGIN @1
  REQUIRE_PREDICATE GAME_IS ~bg2ee bgt tob~ @2

// Adds custom IsValidForPartyDialogue state used throughout nephele
APPEND ~STATE.IDS~ // adds custom IsValidForPartyDialogue state
  ~0x80101FEF CD_STATE_NOTVALID~
  UNLESS ~CD_STATE_NOTVALID~
Of course a little more complications might arise from the EET's install as the game no longer is classified by weidu as BG2EE, but EET. But the fix is this:
The fixed code could look like this:
// --------------------------------------------
// Nephele NPC Mod v2.4
// --------------------------------------------
// Component setup
BEGIN @1
REQUIRE_PREDICATE GAME_IS ~bg2ee bgt tob eet~ @2

// Adds custom IsValidForPartyDialogue state used throughout nephele
APPEND ~STATE.IDS~ // adds custom IsValidForPartyDialogue state
  ~0x80101FEF CD_STATE_NOTVALID~
  UNLESS ~CD_STATE_NOTVALID~
And should it be said, the mod doesn't work in the BG1EE/SoD game.
 
And then there's also these:
ACTION_IF GAME_IS BG2EE THEN BEGIN

  INCLUDE ~nephele/lib/cd_ee_kit_appends.tph~
  LAUNCH_ACTION_FUNCTION ee_kit_appends STR_VAR class = "CLERIC" kitname = "lkneph" END

END

// Copying images and creatures
ACTION_IF GAME_IS ~bg2ee~ BEGIN
  COPY ~nephele/images/ee~ ~override~
END ELSE BEGIN
  COPY ~nephele/images/bg2~ ~override~
END

...

//Symbol

ACTION_IF GAME_IS ~bg2ee~ BEGIN
COPY ~nephele/bams/ee~ ~override~
END ELSE BEGIN
COPY ~nephele/bams/bg2~ ~override~
END
That need to have this fix:
ACTION_IF GAME_IS ~BG2EE eet~ THEN BEGIN

  INCLUDE ~nephele/lib/cd_ee_kit_appends.tph~
  LAUNCH_ACTION_FUNCTION ee_kit_appends STR_VAR class = "CLERIC" kitname = "lkneph" END

END

// Copying images and creatures
ACTION_IF GAME_IS ~bg2ee eet~ BEGIN
  COPY ~nephele/images/ee~ ~override~
END ELSE BEGIN
  COPY ~nephele/images/bg2~ ~override~
END
...

//Symbol

ACTION_IF GAME_IS ~bg2ee eet~ BEGIN
COPY ~nephele/bams/ee~ ~override~
END ELSE BEGIN
COPY ~nephele/bams/bg2~ ~override~
END

Edited by The Imp, 11 December 2016 - 07:08 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#4 agb1

agb1
  • Member
  • 1623 posts

Posted 11 December 2016 - 07:36 AM

For EET compatibility in particular, more is needed.  Transition code between campaigns must be added.  I have a local copy with most of these changes implemented, but still a bit left to do.


BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#5 agb1

agb1
  • Member
  • 1623 posts

Posted 11 December 2016 - 07:53 AM

Actually, it looks like my patches were pretty much finished.  I've uploaded them into the BiG World Fixpack now, and enabled Nephele in the EET selection for BWS.


Edited by agb1, 11 December 2016 - 07:54 AM.

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#6 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4810 posts

Posted 11 December 2016 - 08:04 AM

That was fast.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.






Also tagged with one or more of these keywords: Error, Throne of Bhaal, Darian