Jump to content


Photo

BGT Imoen level bug


2 replies to this topic

#1 WanderingScholar

WanderingScholar
  • Member
  • 7 posts

Posted 04 August 2017 - 07:49 AM

I couldn't find any past forum posts about this but in my latest install Imoen starts as a Level 24 Mage/7 Thief "finimoen.cre" when she joins in Baldur's Gate. I can post my WeiDU but the only change from my last install that would touch npc levels is "TOB style npcs" from tweaks. Any thoughts?



#2 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4276 posts

Posted 04 August 2017 - 01:47 PM

"finimoen.cre" when she joins in Baldur's Gate. ... Any thoughts?

Well, the original BG1's imoen's .cre name was imoen2.cre ... in the ancient times when I was reading posts, so one of the mods most likely edited the npclevel.2da file and botched the whole process.
Make a new .txt file into the game folder, open it with Notepad and then copy this text/code into it:

mkdir change-log
WeiDU.exe --log nul --change-log npclevel.2da >change-log/change-log.txt --out change-log
pause

And use the "save as" functrion in Notepad, and save it as "run.bat" .. or anything you like as long as it ends with .bat, as that allows you run the cmd.exe and with the above commands.

Then copy the setup-bgt.exe and rename it as weidu.exe

And run the run.bat, it will make the change-log folder into your game folder, then package that as a .zip via right clicking the folder. And then upload that .zip archive to this forum in the "More Reply Options" when you have logged into the forum.

 

That should tell us the things I need to find what mod is the culprit, if my hunch is correct.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#3 WanderingScholar

WanderingScholar
  • Member
  • 7 posts

Posted 04 August 2017 - 04:47 PM

Thanks for getting back, I went ahead and just did another install with BWS while I was away since I get impatient with these things  :doh: . As I suspected "ToB-Style NPCs" was causing the problem since it was the only thing I removed along with some other graphics mod giving me trouble. Strange that this exists given how long that component has been out. 





Reply to this topic