Jump to content


Photo

NTotSC for EET (and BGT and BG:EE) - Bugthread


  • Please log in to reply
95 replies to this topic

#81 jastey

jastey
  • Staff
  • 2564 posts

Posted 03 March 2020 - 11:28 AM

Thank you very much, Sergio! I wanted to read it throroughly soon.



#82 sturmvogel

sturmvogel
  • Member
  • 22 posts

Posted 11 July 2020 - 07:51 AM

I have done a few of the minor quests already and really enjoyed the new Firewine Bridge dungeon, although I was fortunate that I'd waited to gain a fair number of levels before venturing into it.

 

But I've killed the banshee and started the Release the Phantoms quest. In my first battle with the Dark One, I killed him and I cannot talk to the Phantom. Do I need to wait some more or is this a bug in my game?



#83 jastey

jastey
  • Staff
  • 2564 posts

Posted 14 July 2020 - 06:15 AM

But I've killed the banshee and started the Release the Phantoms quest. In my first battle with the Dark One, I killed him and I cannot talk to the Phantom. Do I need to wait some more or is this a bug in my game?


This is DSotSC, not NTotSC. I'm not familiar enough with DSotSC to answer that question without research.



#84 jastey

jastey
  • Staff
  • 2564 posts

Posted 29 July 2020 - 08:40 AM

NTotSC updates to v4.1.0!

 

Version 4.1.0 comes with corrected installer for the Will O'Hara Soundset component: it is now dependent on the Will O'Hara NPC component as it should be. Thank you to Roberciiik for providing the fix!



#85 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 29 July 2020 - 09:22 AM

Question: When your description says... yada yada yada Northern Tales of the Sword Coast (BGT, BG:EE, EET) yada yada yada... when I make an EET install, should I install the mod into the BG1EE, or after EET's install into the BG2EE ? And probably before the EET_End... or ? I ask to just ask for clarity. It's not like I will install this just yet. Maybe in say 15 years. :P


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#86 jastey

jastey
  • Staff
  • 2564 posts

Posted 29 July 2020 - 10:43 AM

If the mod says it has comatibility with EET you install it onto the EET game. If the readme does not explicitely state that the mod should be installed after EET_End.exe you always install mods before EET_End.exe.

For NTotSC this means: onto EET, before EET_End.



#87 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 29 July 2020 - 08:29 PM

For NTotSC this means: onto EET, before EET_End.


Good, that was what was to be expected ... because:

 

 

If the readme does not explicitely state that

One might want to lower their expectations a little about such things. It's not like all of them can be correct about things all of the time. See the reference in the current readme, that says the version to be 3.2 ... and the istall -word. Yes, it's a side project, so wouldn't worry about such... but the expectation of reading the readme, is a little too steep, when the maker doesn't.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#88 jastey

jastey
  • Staff
  • 2564 posts

Posted 29 July 2020 - 10:31 PM

If it gives and older version number then that's not the current readme, obviously. It's just the newest that is available online, which needs to be updated separately from the mod package. If you'd took the time to actually look into the mod package then you'd notice that "the maker read the readme".

 

And, you know - linking to the DSotSC readme in the NTotSC thread and accusing me of not reading readmes when dealing with the mods... haha, Jarno.

 

EDIT: online readmes are updated.


Edited by jastey, 29 July 2020 - 10:35 PM.


#89 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 29 July 2020 - 11:48 PM

And, you know - linking to the DSotSC readme in the NTotSC thread...

Sorry, the forum linked to the file... so it's not NTotSC forum. Which is why...

Mhh, maybe the forum could be DSotSC & NTotSC for BGT-weidu & EE's or what ever, rather than just one of those.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#90 jastey

jastey
  • Staff
  • 2564 posts

Posted 30 July 2020 - 12:17 AM

Sorry, the forum linked to the file... so it's not NTotSC forum. Which is why...


Which is in a thread that, you know, states "Dark Side of the Sword Coast" in the post itself. The whole thread is called "DSotSC readme". Which makes it kind of obvious that this is not the NTotSC readme that is linked to.

 

NTotSC was dependent on DSotSC once. That is why it was put into the DSotSC forum. After the update it is no longer dependent and could be treated as an independent quest mod, but unfortunately SHS had no active admin any longer who could make a new mod forum for it. The missing admin also is the reason why the forum name cannot be changed.



#91 jastey

jastey
  • Staff
  • 2564 posts

Posted 13 December 2020 - 08:55 AM

NTotSC updates to v4.2.0!

 

4.2.0 - provided by Roberciiik
-Proof reading of Polish version.



#92 Hatro

Hatro
  • Member
  • 2 posts

Posted 29 June 2021 - 04:02 AM

Hello, 

My OS is Linux, BGee is from Steam. I can't install NToTSC. I've tried all possible language versions.

Now I will try to paste debug file. (First time in my life I'm trying to post spoiler, I have no idea how it works.)

Spoiler



#93 jastey

jastey
  • Staff
  • 2564 posts

Posted 29 June 2021 - 09:54 AM

@Hatro I cannot reorduce this eror. I installed the current 4.2.0 Polish version on Steam BG:SoD without problems.

Make sure you have the admin rights needed to install mods, Windows can be overly protective. Best you copy the Baldur's Gate EE folder somewhere outside of the C:Programs and mod this copy - this will also protect your install from game autoupdates.

Also, if you use SoD from Steam (or GOG) make sure to install first the DLC Merger or you'll encounter problems with invalid Texts ingame.



#94 Hatro

Hatro
  • Member
  • 2 posts

Posted 29 June 2021 - 10:10 AM

@jastey Thank you for a quick reply. This time Windows isn't a problem, because my OS is Linux, more precisely - Linux Mint.

In my WEiDu log i see that setup.tra caused errors. Perhaps it's something about encoding. 



#95 jastey

jastey
  • Staff
  • 2564 posts

Posted 29 June 2021 - 10:22 AM

Oh, Linux. - me no idea, sorry. :(



#96 bay94c

bay94c
  • Member
  • 3 posts

Posted 03 January 2022 - 12:17 AM

As there's a posting forum for bugs, I've got a non-ee install that's giving me some trouble.  Here's the error I get:
 
ERROR: BIFF [.\DATA\AREA030A.BIF] cannot be loaded: Unix.Unix_error(20, "stat", ".\\DATA\\AREA030A.BIF")
 
ERROR locating resource for 'COPY'
Resource [AM0310.wav] not found in KEY file:
        [./chitin.key]
Stopping installation because of error.
Stopping installation because of error.
 
ERROR Installing [Northern Tales of the Sword Coast (NTotSC) for BGT-Weidu, BG:EE, and EET], rolling back to previous state
 
 
I've looked in the data directory and the area030a.bif is there, but I definitely cannot find the am0310.wav file.  I'll include the debug file here
Attached File  SETUP-NTOTSC.DEBUG   69.53K   34 downloads - although I should add that most of the setup npcs classes and items it shows have NOT been installed
yet.  I'm actually doing it manually because I find I have trouble getting big world picture or big world setup to work properly these days.
 
I've been folowing the Big World Project readme guide 19.2 for the install order.

Edited by bay94c, 05 January 2022 - 08:56 AM.