Jump to content


Photo

Shadows over Souber v1.14


  • Please log in to reply
28 replies to this topic

#1 weigo

weigo
  • Modder
  • 116 posts

Posted 22 March 2018 - 11:59 AM

I have updated SoS to be compatible with BG2EE, BGT, BG2 and EET.

 

https://github.com/w...SoS-EE/releases


Edited by weigo, 22 March 2018 - 12:30 PM.

Modification:

BP-BGT-Worldmap-v6.6 (Download)


#2 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 22 March 2018 - 12:33 PM

To make the updates in BWS

 

- Shadows Over Soubar AR4360 needs Area Patcher >>>>Is that still the case?

-The former component "Remorhaz walking speed adjustment" is now part of the single main component and will only automatically install on english version of the classic game, not EE/EET, correct?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#3 weigo

weigo
  • Modder
  • 116 posts

Posted 22 March 2018 - 09:49 PM

To make the updates in BWS

 

- Shadows Over Soubar AR4360 needs Area Patcher >>>>Is that still the case?

-The former component "Remorhaz walking speed adjustment" is now part of the single main component and will only automatically install on english version of the classic game, not EE/EET, correct?

1) What is the problem with AR4360? I don't know.

2) The former component "Remorhaz walking speed adjustment" will only install for BG2, TOB and BGT installations.

REQUIRE_PREDICATE (!GAME_IS ~bg2ee eet~) ~Not for EET and BG2EE~

Modification:

BP-BGT-Worldmap-v6.6 (Download)


#4 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 22 March 2018 - 10:04 PM

To make the updates in BWS

 

- Shadows Over Soubar AR4360 needs Area Patcher >>>>Is that still the case?

-The former component "Remorhaz walking speed adjustment" is now part of the single main component and will only automatically install on english version of the classic game, not EE/EET, correct?

1) What is the problem with AR4360? I don't know.

2) The former component "Remorhaz walking speed adjustment" will only install for BG2, TOB and BGT installations.

REQUIRE_PREDICATE (!GAME_IS ~bg2ee eet~) ~Not for EET and BG2EE~

This is the code in area patcher

 

////////////            Shadows over Soubar - AR4360 Near Areas ////////////
////////////                                                    ////////////
////////////////////////////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////////////////////////////

BEGIN ~Restore Shadows over Soubar - AR4360 Near Areas~ DESIGNATED 4001 GROUP ~Shadows over Soubar~
REQUIRE_COMPONENT ~setup-area_patcher.tp2~ 0 ~You must install the core component first.~
REQUIRE_PREDICATE (MOD_IS_INSTALLED ~setup-sos.tp2~ 0) ~This component is needed only if you have installed Shadows over Soubar.~

//(REQUIRE_PREDICATE FILE_EXISTS_IN_GAME ~AR4230.ARE~)

COPY_EXISTING ~AR4360.are~ ~override~

    WRITE_ASCII 0x0018 ~%NBaldursGate_RinniesHouse_L2%~ #8
    WRITE_ASCII 0x0024 ~%NBaldursGate_RinniesHouse_L2%~ #8
    WRITE_ASCII 0x0030 ~%NBaldursGate_RinniesHouse_L2%~ #8
    WRITE_ASCII 0x003c ~%NBaldursGate_RinniesHouse_L2%~ #8

BUT_ONLY_IF_IT_CHANGES

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#5 weigo

weigo
  • Modder
  • 116 posts

Posted 22 March 2018 - 11:29 PM

Ok, I didn't know this area patcher. I will patch this area.

Thanks for the infos. :)


Modification:

BP-BGT-Worldmap-v6.6 (Download)


#6 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 22 March 2018 - 11:43 PM

Ok, I didn't know this area patcher. I will patch this area.

Thanks for the infos. :)

It is a tool that is now integrated in BWFixpack, so people using BWS for their install will have this applied automatically. In case you have the things corrected in the mod, the patch can be deleted from Fixpack.

 

Also, I did not check if all the other SoS patches in Fixpack are meanwhile incorporated/invalid with the new version?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#7 weigo

weigo
  • Modder
  • 116 posts

Posted 23 March 2018 - 08:04 AM

All BW Fixpack patches are now integrated in SoS-EE 1.14.

Thanks Roxanne for the infos.


Modification:

BP-BGT-Worldmap-v6.6 (Download)


#8 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 19 April 2018 - 09:30 AM

I have made the following discovery

http://gibberlings3....topic=29339&hl=

 

It is related to a problem somebody else recently reported and now I ran into it myself. I fixed it very easily with Near Infinity.

I have no clue what causes it.

Maybe somebody answers my G3 questions and it can be solved in the mod.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#9 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 19 April 2018 - 10:55 AM

I have made the following discovery

http://gibberlings3....topic=29339&hl=

 

It is related to a problem somebody else recently reported and now I ran into it myself. I fixed it very easily with Near Infinity.

I have no clue what causes it.

Maybe somebody answers my G3 questions and it can be solved in the mod.

Thanks to Ikki, the source of the error is identified. I sent you a Pull Request with the correction.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#10 jbwheels

jbwheels
  • Member
  • 14 posts

Posted 21 April 2018 - 09:35 AM

I'm running into the following error during installation:

ERROR: error loading [SoS/Worldmap/eet/sos_links.tbl]
ERROR: [SOS/Worldmap/eet/eet-links.tbl] -> [SOS/Worldmap/eet] Patching Failed (COPY) (Unix.Unix_error(20, "stat", "SoS/Worldmap/eet/sos_links.tbl"))
 

I'm using the Big World setup with a bunch of mods, but I've tested it without SoS & I get a working installation. I don't know that I could do as well with a manual installation. I really want to get SoS running. What should I do?

 

Thanks!

 

PS This is my first time playing BGEE in years, so my memory of the mods & installation process is pretty foggy.


Edited by jbwheels, 21 April 2018 - 09:40 AM.


#11 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 21 April 2018 - 09:42 AM

I'm running into the following error during installation:

ERROR: error loading [SoS/Worldmap/eet/sos_links.tbl]
ERROR: [SOS/Worldmap/eet/eet-links.tbl] -> [SOS/Worldmap/eet] Patching Failed (COPY) (Unix.Unix_error(20, "stat", "SoS/Worldmap/eet/sos_links.tbl"))
 

I'm using the Big World setup with a bunch of mods, but I've tested it without SoS & I get a working installation. I don't know that I could do as well with a manual installation. I really want to get SoS running. What should I do?

 

Thanks!

 

PS This is my first time playing BGEE in years, so my memory of the mods & installation process is pretty foggy.

What is the location of your BG2EE game directory? Is this UAC protected?

Did you check that the file is there SOS/Worldmap/eet/eet-links.tbl ? Maybe your download was incomplete?


Edited by Roxanne, 21 April 2018 - 09:48 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#12 -HalfCelestial-

-HalfCelestial-
  • Guest

Posted 21 April 2018 - 10:00 AM

Hopefully the author will fix it soon, I'm running into the same problem since two or three days ago. It didn't happen in my previous installation, a few weeks ago.



#13 jbwheels

jbwheels
  • Member
  • 14 posts

Posted 21 April 2018 - 10:07 AM

I'm running into the following error during installation:

ERROR: error loading [SoS/Worldmap/eet/sos_links.tbl]
ERROR: [SOS/Worldmap/eet/eet-links.tbl] -> [SOS/Worldmap/eet] Patching Failed (COPY) (Unix.Unix_error(20, "stat", "SoS/Worldmap/eet/sos_links.tbl"))
 

I'm using the Big World setup with a bunch of mods, but I've tested it without SoS & I get a working installation. I don't know that I could do as well with a manual installation. I really want to get SoS running. What should I do?

 

Thanks!

 

PS This is my first time playing BGEE in years, so my memory of the mods & installation process is pretty foggy.

What is the location of your BG2EE game directory? Is this UAC protected?

Did you check that the file is there SOS/Worldmap/eet/eet-links.tbl ? Maybe your download was incomplete?

D:\Games\steamapps\common\Baldur's Gate II Enhanced Edition

I just checked the zip & the file is there...



#14 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 21 April 2018 - 10:17 AM

D:\Games\steamapps\common\Baldur's Gate II Enhanced Edition

I just checked the zip & the file is there...

 

Steamapps causes all types of errors, write errors like yours included. I would move a game to be modded to a neutral directory to eliminate this source for errors.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#15 jbwheels

jbwheels
  • Member
  • 14 posts

Posted 21 April 2018 - 10:38 AM

D:\Games\steamapps\common\Baldur's Gate II Enhanced Edition

I just checked the zip & the file is there...

 

Steamapps causes all types of errors, write errors like yours included. I would move a game to be modded to a neutral directory to eliminate this source for errors.

The directory is outside Program Files so it should be ok. Everything works without SoS... and HalfCelestial is having the same problem... There has to be a bug in the installation code somewhere.



#16 -HalfCelestial-

-HalfCelestial-
  • Guest

Posted 21 April 2018 - 10:55 AM

I also have the games installed in a neutral directory (C:\GoG Games), so the problem must be somewhere else.



#17 -HalfCelestial-

-HalfCelestial-
  • Guest

Posted 21 April 2018 - 11:37 AM

All right, I tried to install them again. This time I selected nothing except SoS in the mod selection (and the mandatory ones, of course), and it worked. The installation was a success without any errors. So not sure what's up, I guess I'll try again with my full selection and see what happens.

 

But perhaps I should wait for an update nevertheless? Is this problem you (Roxanne) mention with the mod hard to fix/too problematic? I have NearInfinity, but I'm no expert with it, perhaps you could give me an indication as to what I can do to fix it?



#18 Roxanne

Roxanne

    Modder

  • Member
  • 3564 posts

Posted 21 April 2018 - 12:14 PM

All right, I tried to install them again. This time I selected nothing except SoS in the mod selection (and the mandatory ones, of course), and it worked. The installation was a success without any errors. So not sure what's up, I guess I'll try again with my full selection and see what happens.

 

But perhaps I should wait for an update nevertheless? Is this problem you (Roxanne) mention with the mod hard to fix/too problematic? I have NearInfinity, but I'm no expert with it, perhaps you could give me an indication as to what I can do to fix it?

If you refer to that BGEE.lua issue I detected some days ago, that is easy to fix, just remove one symbol from a file and save.

 

You can already do this prior installation with a simple text editor.

In your BG2EE directory, - after the mod has been extracted but before you start installation - go to this file

SOS/lib/ cheat_var.tph

Open it with any text editor. Scroll down to the very end and in the second to last line

{"AR4370", "SOS Lyrar's Hold""},  remove the second " after the word Hold, so the entry looks like all the others above. Save and done.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*

 


#19 -HalfCelestial-

-HalfCelestial-
  • Guest

Posted 21 April 2018 - 01:59 PM

Easy enough, thank you for your help.



#20 -HalfCelestial-

-HalfCelestial-
  • Guest

Posted 21 April 2018 - 04:33 PM

Well, this again. I'll try downloading it manually just in case something is corrupted or something.

NOT INSTALLED DUE TO ERRORS Shadows Over Soubar

C:\GOG Games\Baldur's Gate II - Enhanced Edition>
ERROR: error loading [SoS/Worldmap/eet/sos_links.tbl]
ERROR: [SOS/Worldmap/eet/eet-links.tbl] -> [SOS/Worldmap/eet] Patching Failed (COPY) (Unix.Unix_error(20, "stat", "SoS/Worldmap/eet/sos_links.tbl"))
ERROR: Unix.Unix_error(20, "stat", "SoS/Worldmap/eet/sos_links.tbl")
Shadows Over Soubar (Shadows over Soubar) was not installed due to errors.