Jump to content


Photo

Compatibility Issue DoF x EET


  • Please log in to reply
2 replies to this topic

#1 Raduziel

Raduziel
  • Member
  • 25 posts

Posted 12 July 2018 - 02:42 PM

Hi, guys.

 

I'm quite active on Beamdog forums, but I don't usually come here.

 

I need help.

 

I have a mod called Deities of Faerun. For some reason, since the 2.5 update, a player can't install the mod. I've run through my code over and over and I can't see anything wrong.

 

I can't reproduce the issue, the player says that it happens only when installing in EET. I'm using 2.5 and it runs fine. The issue happens even over a "clean" EET install (nothing but EET and DoF).

 

I'm suspecting that it is something to do with the MulticlassKits function (qdmulti), but I'm not sure.


All kits components fail when installing. The .DEBUG and Weidu.log are both attached. Here's the text of the error:
 

[DeitiesOfFaerun\Lib\Multiclass/QD_MC_AP.eff] loaded, 272 bytes
Copied [DeitiesOfFaerun\Lib\Multiclass/QD_MC_AP.eff] to [override/RASHARF#.eff]
Copying and patching 1 file ...
[override/QD_MCP01.spl] loaded, 154 bytes
ERROR: cannot convert kit_code or %kit_code% to an integer
ERROR: [override/QD_MCP01.spl] -> [override] Patching Failed (COPY) (Not_found)
Stopping installation because of error.
Stopping installation because of error.
ERROR: [RASharCM.2da] -> [override] Patching Failed (COPY) (Not_found)
Stopping installation because of error.
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Install kit: Nightcloak of Shar], rolling back to previous state
Unable to Unlink [DeitiesOfFaerun/Backup/5/OTHER.5]: Unix.Unix_error(1, "unlink", "DeitiesOfFaerun/Backup/5/OTHER.5")
[DeitiesOfFaerun/Backup/5/UNSETSTR.5] SET_STRING uninstall info not found

RASharCM.2da is located in the right folder and this error happens with all multiclass components (RAxxxxCM, RAxxxxCT, RAxxxxFC, RAxxxxRC).

 

Here's what I've tried already:

1- Reinstall the mod.

2- Reinstall the mod over a clean install.

3- Provide a new version of the mod and ask for repeat test 2.

 

4- Change the commando INCLUDE ~DeitiesOfFaerun/Lib/Multiclass/qd_multiclass.tpa~  from the ALWAYS block on the .tp2 to every .tpa.

5- Change INCLUDE to REINCLUDE

6- Grab the files of the QDMulti and using those instead of those provided by DoF

 

7- Triple-check if the files are located where they're supposed to be and if there are any typos on the code. Nothing I could see (and even if there were that would prevent any install, not only EET installs).

 

8- Check all the checks for EET. Apparently they are all perfect.

 

Removing the MC entries on the tp2 allows the mod to be installed normally. So I'm pretty sure that it is an interaction between QDMulti and EET.

Can anyone help? An insight maybe?

 

Thanks!
 

Attached Files


Edited by Raduziel, 12 July 2018 - 06:11 PM.


#2 Raduziel

Raduziel
  • Member
  • 25 posts

Posted 13 July 2018 - 05:12 AM

From DoF's thread on Beamdog's forum, a solution proposed by the user Radamanth77:

- ERROR: [override/QD_MCP01.spl] -> [override] Patching Failed (COPY) (Not_found)

Ok, i think i found this issue and wanted to share my infos about.
First of all thanks to Raduziel for the awesome work on an awesome mod.

The problem comes out after an installation of EET on a 2.5 patched game. If you check the KITLIST in your override directory, you would notice that the GRIZZLY_BEAR kit got an extra 0x00004027 column.
Extra becouse the previous one is 0x00004027 aswell.
Just delete the last "extra" column and restart the installation of the mod. Everything will go fine then.
I think the problem is in the patch itself BTW.

Hope to help, I m testing loads of EET installations around this mod and I will share any finding.

#3 Raduziel

Raduziel
  • Member
  • 25 posts

Posted 13 July 2018 - 12:52 PM

Kjeron fixed this issue.

 

Attached Files