Jump to content


Photo

BWPv18 released


  • Please log in to reply
110 replies to this topic

#1 Leonardo Watson

Leonardo Watson
  • Member
  • 465 posts

Posted 27 July 2018 - 09:43 AM

What was planned as a minor update turned out to become a major release. Mainly Vlad’s Compilation is included and the install order is changed. As always the most recent mods' version is included and some new mods are added.
The functionality of the Installpack is significantly improved, new features are added but not yet the planned download function. The Trimpack is now part of the Installpack.
 



#2 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 28 July 2018 - 09:06 AM

Great news!

 

Congrats, Leonardo!

 

This is on time: I was just preparing to install MegaMod using 17.0.4 :-)

 

P.S. No Textpack v18? Is it unnecessary or v17.0.1 would fit?


Edited by EvilMax, 28 July 2018 - 09:41 AM.


#3 Leonardo Watson

Leonardo Watson
  • Member
  • 465 posts

Posted 28 July 2018 - 01:16 PM

The Textpack v17.0.1 ist still up to date.



#4 ChitownWillie

ChitownWillie
  • Member
  • 4 posts

Posted 29 July 2018 - 10:38 AM

Hello,

 

Trying out v18, and it seems to have choked at "~SETUP-LOLFIXER.TP2~ #0 #15 // Store Stuff - MAJESTIC Store Fixer: 19022016":

 

validate line 613 ...
 next file
        1 file(s) moved.
validate line 614 ...
The syntax of the command is incorrect.
Not enough storage is available to process this command.
C:\BWP\BGII - SoA>

 

FYI - Plenty of HD space available.



#5 Leonardo Watson

Leonardo Watson
  • Member
  • 465 posts

Posted 29 July 2018 - 12:21 PM

I never had this issue. I did a Google search and found this anwer:

 

"This is a very uncommon error within Windows and should normally never occur, however there are some cases where this error seems to popup. The main reason is that the IRPStackSize is set to a low value, changing this should solve the error in most cases."

 

https://windowsinstr...s-this-command/

I don't know whether this helps. There are a few websites that offer help for this problem.



#6 Greenhorn

Greenhorn
  • Member
  • 555 posts

Posted 29 July 2018 - 01:13 PM

Congratulations on new update Leonardo !  :cheers:  Although I noticed that some mods got updates which made some information on history section of  BWPv18 install guide obsolete. Rjali for example hit v.9 in the meantime. But nevertheless...  :Bow:  Credit where it is due.  :new_thumbs:



#7 Leonardo Watson

Leonardo Watson
  • Member
  • 465 posts

Posted 29 July 2018 - 11:11 PM

@ ChitownWillie

 

Your installation is nearly complete. Let's see how o finish it.
The "validate" message comes from that part where the IDS files will be corrected. The only mod that really still needs to be installed is Generalized Biffing. So the easiest way is to skip the BWP installation and install Generalized Biffing manually. However, this way you will miss some processes that may not be really important. The clearest way to finish the installation is this:
Open the BiG World Installpack\install\individual.bat respectively the BiG World Installpack\install\process.bat and delete all lines between 1. CORRECTIONS AND IMPROVEMENTS and Call .\%BWIPI%\close2.bat at the end of the file and save it. Start the install.bat again and it will continue where the installation was aborted. If the error hapens again then open the BiG World Installpack\install\close2.bat and write rem at the beginning of the line Call ".\%BWIPS%\trim_IDS.bat" and Call ".\%BWIPS%\trim_IDS.bat" and save the file. Start the install.bat again. This way the installation will be finished as intended.

 

 

@ Greenhorn

Thank you for the hint



#8 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 30 July 2018 - 02:11 AM

More questions :-)
I've found slight differences in manual and individual.bat. It is not a problem for minor components, but there are some significant questions though. Please, correct me if I'm wrong.
 
1. EET_Tweaks alters experience in third order. If I understood article re XP in Appendix correctly, it is supposed that Ding0’s Experience fixer (xpmod) lowers XP relatively and then BP Balancer alters once more, but with strict assignment (so no more problems). EET_Tweaks will do simiar thing as xpmod, but after Balancer if xpmod not installed, right?
2. Re KLlatu tweaks.
 

findstr /I /M "FULLPLATE.TP2~.*#.*#1./" %ELOG%>nul
if errorlevel 1 (
    Call %EINSTI% klatu "2140 2150"
)

 
As far as I understand, this code can enable spelcasting and thieving in combat if Full Plate and Packing steel isn't installed, right? Maybe its installation fact should be mentioned in manual inaddition to incompatibility with Fullplate?
3. Klatu installs store tweaks that affec prices: discard reputation and increase charisma. I think it is good for some cases (for example, Blackguard kit that should keep his reputation as lower as possible), but it should be mentioned as installed by default (components 2170 and 2180)
4. d0tweaks and ebg2 can install the same component - Additional racial enemies. No check in individual.bat for this. I don't know if mods themselves check this, but if not check should be added to installation.
5. Is Gavin fixpack still required? Current leaving script is following (v21 and later, don't know in which previous verions it is the same):

// b!getting_rid_of_gavin.baf

IF
    Exists("B!Gavin")
    Global("B!GavinExistsInBG2","AR0602",0)
THEN
    RESPONSE #100
        ActionOverride("B!Gavin",LeaveParty())
        ActionOverride("B!Gavin",DestroySelf())
        SetGlobal("B!GavBhaal","GLOBAL",0)
        SetGlobal("B!GavinExistsInBG2","AR0602",1)
        Continue()
END

I'm in doubt that following fix is still needed for AR0602:

REPLACE_TEXTUALLY ~ActionOverride("B!Gavin",DestroySelf())~ ~ActionOverride("B!Gavin",LeaveParty()) ActionOverride("B!Gavin",DestroySelf())~

Possibly it is harmful: don't know how engine will react to double destruction. But I'm not sure. Maybe it is Ok, because simply ignored...
6. DrizztSaga v3 isn't compatible with TheOneDrizzt. Does BWP v18 contain solution to install RoT and Drizzt Saga together? Or I should stick with one mod?
 
Minor updates and some very tiny glitches (aren't worth fixing, but if you'll update some time...) :
1. Your installpack is adopted to ClubOfPain 1.5 (i saw specific fixes for this version) I think, it colud be possible to simply update version in manual from 1.3 to 1.5?
2. NToSC is v2.3.0 now. I see no fixes in Fixpack, so it won't harm to allow latest one?
3. Indira is v12beta3
4. Baldur's Gate Romantic Encounters is v2.6 with some fixes
5. Munchmod stated 3.3. install log from 2.7
6. Is Blood Of The Martyr needed if it is consumed by comp. #3 of Sorcerer’s Place Item Collection ?
7. Didn't  got Ajantis for BG2 v14: on G3 we have only v16 and v17. Will try the latest... Do you know anything about its problems?
8. Adrian NPC is v4.3 Mayby it is Ok to use it, because the only change is that crossmod is traified
9. Foundling is v4.1 now with some bugfixes
10. Didn't find Sheena v1.7. Will try with Sheena v2.5
11. Nathaniel v4.4 has more fixes, including from Fixpack and Lollorian. Maybe it is worth updating from 4.3 ?
12. Typo in 20.23 - .tp2 file contains ToSC in its name, not BGT
 
That is it so far. Hope, this is not only my questions, but a little help to BWP manual and install too. :-)

P.S. I had a chance to overview v18 and this is really major update. Nice work!


Edited by EvilMax, 30 July 2018 - 02:17 AM.


#9 new(Mike)

new(Mike)
  • Member
  • 87 posts

Posted 04 August 2018 - 10:05 PM

thank Leonardo for youer hard work,you are so great.

 

Now ROT v3.1 is releasled, https://github.com/weigo87/RoTerror-EE

 

v 3.1 EE - 2018, March
 
- compatibility with EE/EET and SOA/TOB/BGT
 
 
So I want to know if I can install ROT v3.1 by BWP 18.


#10 Leonardo Watson

Leonardo Watson
  • Member
  • 465 posts

Posted 05 August 2018 - 09:59 PM

@EvilMax
Your comment is welcome.

1. The conditions for the EET_Tweaks component are not clear enough defined. Neither the XP nor the Blancer components should be installed.
2 + 3. I made a note for the next release.
4. Good catch!
5. Will be deleted
6. TheOneDrizzt needs to be updated


@new(Mike)
I really don't know. There are much changes to the mod so I have to test it before. The Installpack won't recognice the mod because the setup is renamed. Certainly not you may use the Fixpack patches.



#11 jastey

jastey
  • Staff
  • 1251 posts

Posted 06 August 2018 - 02:37 AM

@EvilMax:

 

5. Is Gavin fixpack still required?

No. All fixpack fixes are integrated into the current Gavin mods.

 

 

7. Didn't  got Ajantis for BG2 v14: on G3 we have only v16 and v17. Will try the latest... Do you know anything about its problems?

The only known problems with Ajantis v17 are:

1. some PIDs for the engaged romance can give a "No Valid Links or Replies" error if they are clicked before the "Are you still my love" first romance dialogue

2. crossmod to "Skie - Cost of One Soul": Ajantis' reactions to the dagger will trigger before the PC knows about the actualy costs to retore it.

Other than that, v17 fixes some issues that are still in v14 and also provides improvements in terms of gameplay (PID is cycling back to the menue so you don't have to re-initiate dialogue to ask Ajantis all serious dialogue questions, groups ends in the area in Windspear hills the quest was started instead of the entrance point every time etcpp.)



#12 jastey

jastey
  • Staff
  • 1251 posts

Posted 06 August 2018 - 02:47 AM

2. NToSC is v2.3.0 now. I see no fixes in Fixpack, so it won't harm to allow latest one?

There are changes from 2.2.2 to 2.3.0 from mod package's POV:

 

-there is a new component "Fighting Ebcounters" with content that was included into the main package before (needs to be considered in installer tool)

-NTotSC.tp2 is now called setup-ntotsc.tp2.



#13 Samriel

Samriel
  • Member
  • 271 posts

Posted 07 August 2018 - 10:03 AM

Hi, I followed BWP instructions to install the mod Rukrakia but for some reason the mod never seems to work.

 

I did go with Big World Fixpack 18, BiG World Textpack v17.0.1 ENGLISH and the mod itself unpacking all of them into the install BG2 folder and installing them staring with BWF, the BWT and then the mod itself.

 

By the way, when trying to give it a try with older versions of Big World Textpack like v15 it first tells me to "press any key to continue" but afterwards a second black window pops up(completely empty) and while the message "processing fixes" appears in the first one the process does not seem to progress at all. I waited like half an hour and nothing. I did not experienced said problem with V18.

 

I'm using Windows 10.



#14 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 08 August 2018 - 03:04 AM

Hi, I followed BWP instructions to install the mod Rukrakia but for some reason the mod never seems to work.

 

I did go with Big World Fixpack 18, BiG World Textpack v17.0.1 ENGLISH and the mod itself unpacking all of them into the install BG2 folder and installing them staring with BWF, the BWT and then the mod itself.

 

By the way, when trying to give it a try with older versions of Big World Textpack like v15 it first tells me to "press any key to continue" but afterwards a second black window pops up(completely empty) and while the message "processing fixes" appears in the first one the process does not seem to progress at all. I waited like half an hour and nothing. I did not experienced said problem with V18.

 

I'm using Windows 10.

Do you have Rukrakia mod as a part of BWP install (Fixpack running check question )? Did you wait long enough? Fixes process is quite slow even on good CPUs. On i7 4930k process you described took several minutes without any visible progress. I was close to interrupt BWP install, but accidentially fixes were completed and I saw the progress :-) Well, you also can see CPU load in task manager during that process. Please, try to run it again and wait enough time. Be patient :-)

 

jastey, Leonardo Watson, thank you for your replies :-)

 

More findings:

-  I had to remove Foundling mod from BWP install. It contains qd_multiclass function by the Aquadrizzt similar to the Might and Guile and thus conflicts with some Stratagems v30 components during kits patching process.

- Rjali v9 (didn't find v8.5) setup failed

Copying and patching 1 file ...
[./override/ANOMEN.bcs] loaded, 144633 bytes
override/ANOMEN.bcs copied to Rjali/Backup/3/override.ANOMEN.bcs, 144633 bytes
Copied [ANOMEN.bcs] to [override/ANOMEN.bcs]
Copying and patching 1 file ...

ERROR locating resource for 'COPY'
Resource [DORN.bcs] not found in KEY file:
	[./chitin.key]
Stopping installation because of error.
Stopping installation because of error.

ERROR Installing [Rjali Romance Mod (BG2EE:SoA & TOB NPC) created by nullset], rolling back to previous state
Unable to Unlink [Rjali/Backup/3/OTHER.3]: Unix.Unix_error(1, "unlink", "Rjali/Backup/3/OTHER.3")
Will uninstall 1056 files for [RJALI/SETUP-RJALI.TP2] component 3.

Edited by EvilMax, 08 August 2018 - 06:29 AM.


#15 new(Mike)

new(Mike)
  • Member
  • 87 posts

Posted 08 August 2018 - 08:56 PM

when I install with BWP 18, when I see
Welcome to the Installpack!
═══════════════════════════


You can use this universal tool for multiple tasks.
What do you want to do?

[1] Prepare a megamod installation (backup and unzip)?
or
[2] Install the megamod?
or
[3] Use the additional tools (change-log, list components, traify, clean-up)
or
[4] Quit?



after I choose 2, it tell me "You must first prepare a megamod installation before you can install it." and cannot go on.

if i choose 1, it tell me "There is no folder "BiG World Downloads" in the same directory.
This folder stores all your downloaded mods. All packages out of this
folder will be extracted into your BGII folder automatically.
Maybe you have installed "BiG World Downloads" at another place." and cannot go on.


I want to install mods by BWP and I don't want to prepare a megamod installation.

how can I do make the installation continue,thank you very much

Edited by new(Mike), 08 August 2018 - 09:11 PM.


#16 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 08 August 2018 - 10:59 PM

BWP is the Megamod installer :-) So, you are about to install the Megamod and you cannot install Big World without installing Megamod because Big World == Megamod :-) Really.

 

Actually, Megamod is a term denoting your custom Baldur's Gate world gathered from your favorite mods by yourself. BWP makes them installed without conflicts where possible.

 

Short answer to your question: you must prepare your installation like in Big World manual described. First you are intended to download all mods you want to install into the BiG World Downloads directory. Installer will try to unpack them, backup your original BG2 directory and run install. No problems if you already unpacked them and put into another dir. Actually I did so and then copied over to the BG2 directory where I run Dig world install batch file .

 

IIRC, after "Maybe you have installed "BiG World Downloads" at another place." and cannot go on." installer asked you path to dir with mods. Write full path to folder where all your unpacked mods located and continue. More details are in Big World PDF.



#17 jastey

jastey
  • Staff
  • 1251 posts

Posted 09 August 2018 - 12:55 AM

Concerning Ajantis BGII v17 I forgot to mention that the mod structure changed as well:

The mod has three components now, the second only being for EE, but the third one adding crossmod content and therefore should be installed as late as possible (i.e. after other NPC and quest mods)!



#18 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 09 August 2018 - 01:42 AM

More findings.

 

1. Oversight and Refinements are both changing HLAs. But Refinements makes textual changes and messes with HLAs if Oversight installed before. For example, Oversight overwrites monk's HLA table LUMO0.2DA, but Refinements tries to patch it. When Refinements tries to replace vanilla HLAs after Oversight installation it cannot find them. Result: we have two HLA trees: one from Oversight, second - from Refinements.

 

Possible solutions:

- install only one HLA changing component: from Oversight or from Refinements

- install Oversight HLA changing components aftrer Refinements allowing Oversight overwrite changes made by other mods.

- modify Refinements installer to detect Oversight and remove its entries (not good but I sticked with that)

 

2. (This is not an issue but matter of taste). Might & Guile changes to Kensai nerf its dual- and multiclass usability. It may not be liked by every player, especially lovers of Kensage and similar builds ;)

And although this mod gives very nice Quickstride solution for classes with movement rate bonuses allowed to be turned on/off, it significantly nerfs monks limiting movement rate bonust to fixed +4 instead of level-scaled one. I'm going to rewrite its Quickstride effect for monks to make it corresponding to the Sword&Fist description and scale every 3 levels. 

 

@jastey, Nice comment! I missed crossmod content not knowing that. Fortunately, simple replacement of Ajantis for BG2 to v17 breaks nothing: BWP installs only component #0. So the only problem is missed crossmod content that could be easily fixed even by manual installation :) And this is not a problem, because I'm going to rebuild BWP according to new findings you see above. :)


Edited by EvilMax, 09 August 2018 - 10:28 AM.


#19 new(Mike)

new(Mike)
  • Member
  • 87 posts

Posted 09 August 2018 - 02:00 AM

BWP is the Megamod installer :-) So, you are about to install the Megamod and you cannot install Big World without installing Megamod because Big World == Megamod :-) Really.
 
Actually, Megamod is a term denoting your custom Baldur's Gate world gathered from your favorite mods by yourself. BWP makes them installed without conflicts where possible.
 
Short answer to your question: you must prepare your installation like in Big World manual described. First you are intended to download all mods you want to install into the BiG World Downloads directory. Installer will try to unpack them, backup your original BG2 directory and run install. No problems if you already unpacked them and put into another dir. Actually I did so and then copied over to the BG2 directory where I run Dig world install batch file .
 
IIRC, after "Maybe you have installed "BiG World Downloads" at another place." and cannot go on." installer asked you path to dir with mods. Write full path to folder where all your unpacked mods located and continue. More details are in Big World PDF.

I have downloaded mods i want to install and packed them into a single file.
when i install ,i can unpacked them in the BGII - SoA folder easily.
it is difficult for me to repack these mods and change back to their original name

if I do not want to put mods into a separate folder BiG World Downloads, i do not do [1] Prepare a megamod installation (backup and unzip)
I just begin with [2] Install the megamod,if it is possible.

thank you very much

#20 EvilMax

EvilMax
  • Member
  • 87 posts

Posted 09 August 2018 - 03:31 AM

No, installer will ask you to prepare anyway and you must agree. But you simply give him path to the folder where you unpacked mods - it will just check them and you hanve no necessity to repack them. To save your time you can disagree to backup original game.