Jump to content


Photo

General discussion

twelff hundo

  • Please log in to reply
524 replies to this topic

#521 jastey

jastey
  • Staff
  • 1330 posts

Posted 07 January 2019 - 10:26 PM

The actual problem is a missing OS tag in the arestorationp.tp2. This:

 

LANGUAGE ~Deutsch (by Dachrisma)~
         ~german~
         ~arestorationp/language/english/game.tra~
         ~arestorationp/language/english/setup.tra~
         ~arestorationp/language/german/game.tra~
         ~arestorationp/language/german/setup.tra~
LANGUAGE ~Portugues brasileiro (by Felipe)~
         ~ptbr~
         ~arestorationp/language/english/game.tra~
         ~arestorationp/language/english/setup.tra~
         ~arestorationp/language/ptbr/game.tra~
         ~arestorationp/language/ptbr/setup.tra~

 

 

 

should be this:

 

LANGUAGE ~Deutsch (by Dachrisma)~
         ~german~
         ~arestorationp/language/english/game.tra~
         ~arestorationp/language/english/setup.tra~
         ~arestorationp/language/german/game.tra~
         ~arestorationp/language/german/setup-%WEIDU_OS%.tra~
LANGUAGE ~Portugues brasileiro (by Felipe)~
         ~ptbr~
         ~arestorationp/language/english/game.tra~
         ~arestorationp/language/english/setup.tra~
         ~arestorationp/language/ptbr/game.tra~
         ~arestorationp/language/ptbr/setup-%WEIDU_OS%.tra~

 

There are two ways to fix the German version for your install:

 

1. Quick hack: Before installing, go into arestorationp/language/german, and rename the file "setup-win32.tra" to "setup.tra". Then the install of the german Version should work.

 

2. Before installing, open the file arestorationp.tp2 with an editor (e.g. notepad) and change the line

~arestorationp/language/german/setup.tra~

to:

~arestorationp/language/german/setup-%WEIDU_OS%.tra~

Save the file (as tp2 file) and install the mod.

 

Almateria:

I think the "-%WEIDU_OS%" is missing for all language versions in the line "~arestorationp/language/english/setup.tra~", as well.



#522 Marlow42

Marlow42
  • Member
  • 3 posts

Posted 07 January 2019 - 11:36 PM

There are two ways to fix the German version for your install:

 

1. Quick hack: Before installing, go into arestorationp/language/german, and rename the file "setup-win32.tra" to "setup.tra". Then the install of the german Version should work.

 

2. Before installing, open the file arestorationp.tp2 with an editor (e.g. notepad) and change the line

~arestorationp/language/german/setup.tra~

to:

~arestorationp/language/german/setup-%WEIDU_OS%.tra~

Save the file (as tp2 file) and install the mod.

 

Almateria:

I think the "-%WEIDU_OS%" is missing for all language versions in the line "~arestorationp/language/english/setup.tra~", as well.

 

Many thanks jastey for your try!!

But both ways NOT solved the problem!

 

 

Regards, Marlow



#523 Almateria

Almateria

    most garbage person

  • Modder
  • 929 posts

Posted 07 January 2019 - 11:49 PM

Well, uh, that's awkward. I'll look into it!

 

(Meanwhile, congrats on being the first person to try non-english translations in five years!)



#524 jastey

jastey
  • Staff
  • 1330 posts

Posted 07 January 2019 - 11:59 PM

But both ways NOT solved the problem!

They did for me.

 

EDIT: You need to do either 1 or 2, not both.


Edited by jastey, 08 January 2019 - 12:00 AM.


#525 Marlow42

Marlow42
  • Member
  • 3 posts

Posted 08 January 2019 - 12:05 AM

But both ways NOT solved the problem!

They did for me.

 

EDIT: You need to do either 1 or 2, not both.

That was it!!!!!!!

 

MANY thanks Jastey!!!!!!!

 

Marlow