Jump to content


Photo

(Late to the party?) Undecided between BGT and EET.


  • Please log in to reply
16 replies to this topic

#1 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 31 December 2018 - 06:26 PM

Hello all.

 

Lately I've been thinking about starting a new playthrough, and I can't decide between the good old BGT or delving into EET. Inspired by the superb playthrough performed a few years ago by Usurper, my intent is to play a full Tactical installation, as I want content, content and more content - I'm not a purist by any means.

 

As far as I've seen, the current BWS for BGT hasn't been updated in a while, and I'm pretty sure I'll run into a quite a few problems down the line with such a gargantuan installation, but it supports every old, obscure and forgotten mod. EE GST seems quite a bit more streamlined and supports a sizeable number of mods too, but I don't really want to be missing out on interesting content that's not included.

 

I know there's no right answer, but I'd like to hear your opinions: what would you choose between a fully-fledged BWS Tactical installation (for old time's sake..), or a supposedly more limited content-wise EET/GST setup?

 

Thanks a lot!


Edited by DivideBy0, 31 December 2018 - 06:33 PM.


#2 Sergio

Sergio
  • Member
  • 712 posts

Posted 02 January 2019 - 02:31 AM

It depends.

Do you want to spend time learning how to use BWP and getting a great and stable install for BGT,

or

do you wish just to install it and get an almost perfect experience?

 

If it is the second case, go for EET. Otherwise, learn BWP and enjoy it.

The BWS for EE made by Roxanne is also far from perfect. I had a few issues (for example, summons having very long names - actually dialogues), so your choice. But apart from these little imperfection I guess the playthrough was fine - even if I interrupted it pretty early so I can't judge the endgame.


Edited by Sergio, 02 January 2019 - 02:31 AM.


#3 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4654 posts

Posted 02 January 2019 - 03:13 AM

It depends.
The BWS for EE made by Roxanne is also far from perfect. I had a few issues (for example, summons having very long names - actually dialogues), so your choice. But apart from these little imperfection I guess the playthrough was fine - even if I interrupted it pretty early so I can't judge the endgame.

It does yes.

That bug is a particular incombatibility between EE games and a mod that uses a particular non EE -game creature(s). And it's already fixed... at least on the side of the mod. Well, as far as I am conserned. There's Item Rev Rev, and Spell Rev Rev.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#4 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 02 January 2019 - 03:14 PM

Do you want to spend time learning how to use BWP and getting a great and stable install for BGT, or do you wish just to install it and get an almost perfect experience?

 
Hi Sergio, thank you for your reply.

I am already familiar with BWP, as I've performed several setups in the past years (albeit I have to admit I never went further than the first few chapters of BG1, shame on me).
 
My biggest fear is that a stable Tactical BWP install isn't really achievable, and I'd rather not have to restart a game from scratch as creeping issues start to pile up and become unmanageable.. Correct me if I'm wrong, but once you perform  generalized biffing, apart from the drastical load time decrease, you lose the ability to selectively modify or disable single mods.

 

A "great and stable" BGT install however would really be what I'd hope to achieve.


Edited by DivideBy0, 02 January 2019 - 03:19 PM.


#5 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4654 posts

Posted 02 January 2019 - 04:16 PM

Correct me if I'm wrong, but once you perform  generalized biffing, ..
This is not true. Generalized Biffing allows total uninstall of other stuff, the only condition is that you have the BWP Fixpack that removes the Biffing from other mods ... End_Biffing didn't. Nor did the other mods ... but as that's removed from them, today you can remove nearly anything and do drastic reinstalls ... but still, that's never good for your dialog.tlk.
So consider yourself corrected.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#6 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 02 January 2019 - 04:50 PM

So consider yourself corrected.

 

That's why I asked in the first place, thanks for your clarification.


Edited by DivideBy0, 02 January 2019 - 04:50 PM.


#7 Jourin

Jourin
  • Member
  • 25 posts

Donator

Posted 04 January 2019 - 09:29 AM

I prefer BGT with BWP.  Most of the problems reported with and by 18.1 have been with the newer versions.  VC 2.0 was not working along with ROT 3.0.  Needed to use older versions for both.  The same for DSotSC where version 3.0 is reported as breaking BGT while 2.17 worked.  Also the newer Sandra doesn't work with BGT so you need to use version v 1.11 which is very hard to find.  I planned on doing a BWP install on the day after Thanksgiving per tradition, but discovered my external hard drive with all the mods and clean install copies can't be read.  Leonardo's website changed so his library of links to mods is also no longer complete.  So I decided to do a EET installation.  Definitely easier because you can easily get copies of the mods that work with EET, but as I play through with my (6 year old) son I constantly feel that stuff is missing.  He noticed so I told him this is the beginners version and after we complete this (which will take several months) we will do the advanced version (BWP).  Hopefully Leonardo works out a new 18.2 version soon - I know he just worked with Vlad to release a VC 2.1 that hopefully works with BGT.  My son is also inspiring me to learn how to mod since he has asked me to fix some things and since Dad can fix (almost) anything I said I would try to have it complete when we start the advanced BWP game.  So who knows, maybe in a few months I will release a small mod.


Edited by Jourin, 04 January 2019 - 09:31 AM.


#8 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 04 January 2019 - 11:28 PM

So, the current BWS version tries to install mod versions incompatible with BGT, and I'll have to force the installation of older versions? I can find my way through the various .ini, but that doesn't sound fun at all..



#9 ALIEN

ALIEN
  • Member
  • 852 posts

Posted 06 January 2019 - 04:45 AM

I can find my way through the various .ini, but that doesn't sound fun at all..

You are basically hacking BWS so beware: every time when BWS starts it preform auto-updates and it will remove you editing. Not that simply changing "mod download link" will magically makes BWS aware about older version. It's not and there is a very high chance that things will break. so don't do it.



#10 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 06 January 2019 - 08:00 AM

You are basically hacking BWS so beware: every time when BWS starts it preform auto-updates and it will remove you editing. Not that simply changing "mod download link" will magically makes BWS aware about older version. It's not and there is a very high chance that things will break. so don't do it.

 

I'm aware that BWS can be started with the no auto update .vbs, however what seems illogical to me is that in the specific .ini files for BGT there are links for incompatible versions of the mods. Given that BGT is managed differently from BGEE, IWD and such, why couldn't the old and working mod versions links be left there?



#11 ALIEN

ALIEN
  • Member
  • 852 posts

Posted 07 January 2019 - 07:08 AM

Short version: because differences between component numbers between old nad new mod versions.



#12 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 08 January 2019 - 02:12 AM

Thanks for the explaination Alien. Anyway, I've decided to try a BGT Tactical installation, and it seems that the following mods aren't available anywhere anymore (I've scavenged a few missing ones on archive.org):

 

Almateria's Quest 2: The Mod itself (AlmaQuest2v3_WIN.zip)  
Alora NPC: The Mod itself (AloraNPC-master.zip)
Crusader Pack: The Mod itself (CrusaderPack4.3.rar)
Ding0's Tweak Pack: The Mod itself (d0tweak-v24.zip)
Dungeon Crawl: The Mod itself (DungeonCrawl-master.zip)
Legion of Hell: The Mod itself (LOHMod.zip)
Oversight: The Mod itself (Oversight.zip)
The Sellswords: The Mod itself (Sellswords-master.zip)
Tiax NPC: The Mod itself (Tiax-master.zip)
Xulaye NPC: The Mod itself (xulaye v1.2.1.zip)

 

Anyone able and willing to provide them?
 



#13 Greenhorn

Greenhorn
  • Member
  • 578 posts

Posted 08 January 2019 - 02:42 AM

Thanks for the explaination Alien. Anyway, I've decided to try a BGT Tactical installation, and it seems that the following mods aren't available anywhere anymore (I've scavenged a few missing ones on archive.org):

 

Almateria's Quest 2: The Mod itself (AlmaQuest2v3_WIN.zip)  
Alora NPC: The Mod itself (AloraNPC-master.zip)
Crusader Pack: The Mod itself (CrusaderPack4.3.rar)
Ding0's Tweak Pack: The Mod itself (d0tweak-v24.zip)
Dungeon Crawl: The Mod itself (DungeonCrawl-master.zip)
Legion of Hell: The Mod itself (LOHMod.zip)
Oversight: The Mod itself (Oversight.zip)
The Sellswords: The Mod itself (Sellswords-master.zip)
Tiax NPC: The Mod itself (Tiax-master.zip)
Xulaye NPC: The Mod itself (xulaye v1.2.1.zip)

 

Anyone able and willing to provide them?
 

Almateria's Quest 2: The Mod itself (AlmaQuest2v3_WIN.zip) - I have it on my hard drive but I'll not share it without author's permission

Alora NPC - http://www.baldursga...wnfile&id=195 

mod is marked as AloraEE but it's description says : 

 

Chosen of Mystra's Alora NPC Mod for BG2:SoA, BG2:EE and EET

Not so sure about BG:SoA part but you can certainly check it yourself

 

Crusader Pack- http://www.mediafire...erPack4.3.rar 

Probably can dig couple of more if someone else doesn't step in... 


Edited by Greenhorn, 08 January 2019 - 02:43 AM.


#14 Greenhorn

Greenhorn
  • Member
  • 578 posts

Posted 08 January 2019 - 04:49 AM

Thanks for the explaination Alien. Anyway, I've decided to try a BGT Tactical installation, and it seems that the following mods aren't available anywhere anymore (I've scavenged a few missing ones on archive.org):

 

Almateria's Quest 2: The Mod itself (AlmaQuest2v3_WIN.zip)  
Alora NPC: The Mod itself (AloraNPC-master.zip)
Crusader Pack: The Mod itself (CrusaderPack4.3.rar)
Ding0's Tweak Pack: The Mod itself (d0tweak-v24.zip)
Dungeon Crawl: The Mod itself (DungeonCrawl-master.zip)
Legion of Hell: The Mod itself (LOHMod.zip)
Oversight: The Mod itself (Oversight.zip)
The Sellswords: The Mod itself (Sellswords-master.zip)
Tiax NPC: The Mod itself (Tiax-master.zip)
Xulaye NPC: The Mod itself (xulaye v1.2.1.zip)

 

Anyone able and willing to provide them?
 

Legion of Hell - http://www.mediafire...nzla/LOHMod.zip

Ding0's Tweak Pack - https://github.com/A...0Tweak/releases

Dungeon Crawl - 

http://www.pocketpla...=168&Itemid=117



#15 Greenhorn

Greenhorn
  • Member
  • 578 posts

Posted 08 January 2019 - 06:08 AM

Oversight - https://www.gibberli.../870-oversight/

Xulaye NPC - available here on SHS, current version is 2.0, there are probably older versions too on it's download page

The Sellswords - available on the same site as Dungeon Crawl

Tiax - same as above, only it is under One day NPCs section



#16 DivideBy0

DivideBy0
  • Member
  • 44 posts

Posted 08 January 2019 - 07:59 AM

Greenhorn, thank you very much for the links provided. I already had downloaded a few of those mods, but as there's a size mismatch between what BWS is expecting I thought that those mods versions were different than the ones I needed.

 

Maybe it's just a matter of a different compression format. Thanks again.


Edited by DivideBy0, 08 January 2019 - 08:00 AM.


#17 Greenhorn

Greenhorn
  • Member
  • 578 posts

Posted 08 January 2019 - 08:24 AM

 I already had downloaded a few of those mods, but as there's a size mismatch between what BWS is expecting I thought that those mods versions were different than the ones I needed.

And that is where the problem lay with BWS, especially for it's outdated BGT version ( probably it still expect, older, outdated mod versions) . It is solvable I think, with some manual tinkering but unfortunately I forgot majority of it I'm afraid. 

Good luck with your installation and you are welcome.