Jump to content


Photo

Just came back and very confused about Big World Project


  • Please log in to reply
19 replies to this topic

#1 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 08 July 2019 - 07:41 PM

Hi folks,

Just came back after some time away and things sure have changed. I remember some years ago playing BG mega-mods with hundreds of mods installed courtesy of the Big World Setup program (I think I used version 7 the first time, version 14 the second time). It had a number of useful features, including:

* a curated recommendation list so you could pick the stuff that was right for what you wanted

* it would download all those mods for you into one giant folder and then install them.

 

I'm looking around and noticing that while BWP has continued on to version 18, BWS is obsolete, and possibly straight-up gone. Haven't been able to piece together why though. What happened here? Is there a new program that serves this purpose? Should I try to use an old BWS and just live with it? Manually download all the mods myself (hundreds of them)? It seems like it's 'out of date' but I saved off a directory with BWS 14.3 and all the mods it downloaded about 4 years ago. Maybe with the exact mod set it would work fine?

 

Also, I haven't really decided if I should be shooting for EE or original edition. How are the current megamod offerings for EE? I made myself a list of the mods I really enjoyed from back in 2009. My top mods are:
The Longer Road 10/10

Ascension 10/10

Fade 9/10

Tashia 9/10

Beyond the Law 9/10

Northern Tales of the Sword Coast 9/10
Dark Side of the Sword Coast 9/10

BG1 Mini Quests & Encounters 9/10
BG1 Unfinished Business 9/10
Assassinations 9/10
Planar Sphere Mod 9/10
Every Mod and Dog 9/10
BG2 - Quest Pack 9/10
BG2 - Unfinished Business 9/10
Fading Promises 9/10
Improved Asylum 9/10
Adalon's Blood 9/10
Tortured Souls 9/10

Any explanation/history less on would be super helpful around now.

Cheers,

Vandervecken


Edited by Vandervecken, 08 July 2019 - 07:50 PM.


#2 Niewiem

Niewiem
  • Member
  • 31 posts

Posted 08 July 2019 - 11:02 PM

The answer is easy

Keeping it up to date was a loooooooooooooooooooooooooooot of work and there is no one who can spare  that much time.

Alien is working on new install tool but it is in beta
https://forums.beamd...ity-public-beta



#3 jastey

jastey
  • Staff
  • 1873 posts

Posted 09 July 2019 - 01:04 AM

What Niewiem said. All maintainers of BWS burnt out, so ALIEN is currently making an automated installer that doesn't need the work that lead to people burning out - means on the other hand that it will be less comfortable for players. But the main reason it is less comfortable currently is because it is in beta, still. It's still the best way to go if you want to have help in installing in an automated form. And: anything you notice and report to ALIEN he will work on instantly.

 

To your mod list: you get a good idea of what is available for the EE if you look at the Modlist for BG:EE, Modlist for BGII:EE, and also the EET Compatibility List (in general, mods compatible with EET are also for BG(II):EE).



#4 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 07:37 AM

What was involved in the BWS work - was it the job of maintaining mod compatibility, or updating all the download locations and versions? What's the fundamental difference between BWS and what ALIEN is working on?

 

And thanks for the links, I'm looking at the EET compatibility list and it recommends using BWS to install. Is there an automated install utility for EET or is it the same issue?


Edited by Vandervecken, 09 July 2019 - 07:46 AM.


#5 Greenhorn

Greenhorn
  • Member
  • 616 posts

Posted 09 July 2019 - 08:04 AM

 It's still the best way to go if you want to have help in installing in an automated form. 

Unless you have 32-bit junk of computer which cannot be upgraded.  :P



#6 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 08:19 AM

I'm looking at the EET compatibility list, and noticing something. As an example, Tashia has an EET-compatible version (or at least claims to) here:
https://github.com/RoxanneSHS/TashiaEE

but it's not on the list. Should I take claims of EET-compatibility at face value?

And if I use ALIEN's thing for installing EET, how would I handle such a conflict?



#7 jastey

jastey
  • Staff
  • 1873 posts

Posted 09 July 2019 - 08:52 AM

The EET list lists official versions. Roxanne's versions are unauthorized, and some contain changes Roxanne saw fit.

 

For Project Infinity you'll need to define install order yourself, but there are ways to do that. If in question, ask. Maybe a more crowded place like BeamDog's will lead to more replies overall, though.

 

For BWS: there was the download link (which changed for some forums with each version), the file size, the version number, the mods needed descriptions, all mods with the components where added to the install order lists by hand, one list for every game (clasic and EE). Before you could make the changes you had to look at the mod to see how much it changed and whether it affects compatibility, etc. Adding the changes was not all, you also needed to test the new build, for every game, etc. There are several mod updates per week, so basically you had to do that every day.



#8 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 10:18 AM

Defining an install order for yourself seems absolutely fraught with risk of errors. Is there any guidance for how to make good choices? And if you make bad choices will you end up with failures to install (good), or failures during the game (bad)?

I get how BWS was a whole lot of work, but it seems like without it, it's almost impossible to do a megamod for anyone but the most experienced die-hards, willing to potentially fight through lots of bugs and restarts.



#9 jastey

jastey
  • Staff
  • 1873 posts

Posted 09 July 2019 - 10:28 AM

Do you still have a weidu.log from a mega mod you would like to redo? The great advantage of the IE community is that you don't have to be the experienced one, but can post and ask in the forums for help.

 

And yes, there will be always bugs in the game. Even with maintained mods and modders trying to keep them bugfree, there is always one more bug that will only show when you play the mod - in a way the modder never even realized was there.

 

EDIT: Don't forget that PI is in beta. ALIEN is working on install list and compatibility, it's just a bit of a bad time in-between.


Edited by jastey, 09 July 2019 - 10:29 AM.


#10 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 11:19 AM

I do have a WEIDU log but it's from years ago. I guess I can put together a list of mods and ask for help with ordering.



#11 jastey

jastey
  • Staff
  • 1873 posts

Posted 09 July 2019 - 11:21 AM

If you follow the link above there are ways to make an install order list for PI with weidu.logs. I do not have experience with this, though.



#12 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 11:56 AM

Hmm, I guess I just don't trust a weidu.log from so long ago. And I'm less concerned about the construction of such a list than I am about making poor choices. Anyway, thank you for your help so far.



#13 Shuv-Oohl

Shuv-Oohl
  • Member
  • 96 posts

Posted 09 July 2019 - 12:28 PM

Defining an install order for yourself seems absolutely fraught with risk of errors. Is there any guidance for how to make good choices? (...)

 

Of course. Leonardo's BWP which is mainly the pdf to clarify questions, the fixpack and the editable install.bat.

For those 20 mods You are interested in I don't see any problems in using BWP.

Just download the mod versions that are stated in the most recent pdf.



#14 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 12:36 PM

Oh, for that list I was wondering about EE/EET compatibility. I think the BWP was mostly dealing with Classic, right?



#15 Shuv-Oohl

Shuv-Oohl
  • Member
  • 96 posts

Posted 09 July 2019 - 12:44 PM

Correct. I'm sorry.

#16 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4812 posts

Posted 09 July 2019 - 04:09 PM

I think the BWP was mostly dealing with Classic, right?

Actually; NO !

It was dealing with the Classic version ONLY !


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#17 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 09 July 2019 - 04:24 PM

Gotcha. Ok, I've done some more research. I've narrowed down the list of mods I used last time to the mods that I rated 8/10 or higher personally. I'd say about 90% of them are in EET at least unofficially. This is good news, as I've decided I want to try EET for the next playthrough.

 

I have a few more questions:

1) what's happening with Lure of the Sirine's Call? I think @jastey was working on this one.

2) What kind of mods would you say are important but that I might have forgotten? For example, the Worldmap mod, not something you think about as content but turns out it's necessary, basic stuff. I'll put my list below.

3) What are some great mods you would recommend I try? I last played a full game through 10 years ago, so I'm sure there's a lot of content since then. Hit me with your reccs!

4) How should I handle things like XP reduction? The more content you add the more you might end up overleveled.BWS used to have recommendations for this, not sure what to do now.

 

Here is my list so far. The three mods I think I will miss most are Beyond The Law, Tortured Souls and Improved Asylum:

Rating    EET-Compatible    Name
        NPC Mods
8    Yes    Amber - Romance + Abduction & item quests
9    Yes    Fade - Romance & Quests
9    Unofficial    Tashia - Romance & Quest
8    EE not EET    Neh'taniel - paladin
9    No    Beyond the Law (needs a lot of investment)
8    Yes    Angelo - esp with Imoen
8    Maybe EE    Solaufein (by Weimar)
        
        BG 1 Mods
9    Yes    Northern Tales of the Sword Coast
9    Yes    Dark Side of the Sword Coast
9    Yes    BG1 Mini Quests & Encounters
8    Yes    Grey Clan Episode 1 - In Candlelight
    Unclear    Lure of the Sirine's Call
9    Yes    BG1 Unfinished Business

        BG2 Mods
8    Unofficial    Expanded Thief Stronghold
9    Yes    Assassinations
8    Yes    The Darkest Day
8    Unofficial    Reign of Terror
9    Unofficial    Expanded Mage Stronghold (was Planar Sphere Mod)
8    Yes    Check the Bodies
    Yes    Worldmap
9    Yes    Every Mod and Dog
9    Yes    BG2 Quest Pack
9    Yes    BG2 Unfinished Business
9    Yes    Rogue Rebalancing
9    Yes    Fading Promises
8    Yes    Tower of Deception
9    No    Improved Asylum
9    Yes    Adalon's Blood
9    No    Tortured Souls
8    No    Domains of Dread
8    No    Dark Ritual
        
        ToB Mods
10    Unofficial    The Longer Road
10    Yes    Ascension
 


Edited by Vandervecken, 09 July 2019 - 07:06 PM.


#18 jastey

jastey
  • Staff
  • 1873 posts

Posted 09 July 2019 - 11:35 PM

Lure of Sirine's Call is all officiall EE and EET ready. There was some hickup with the second, optional component "extended lighthouse area" which lead to crashes at night first for EE, now that's fixed it's still in BGT, maybe just let this component drop although for EE it should be fixed.

 

If you like quests in the style of bgqe, then Ascalon's Questpack could be a good choice. Also, there are really good quests in the BG1 Romantic Encounters mod as listed here (if you do not want the hot panty type of components).



#19 Vandervecken

Vandervecken
  • Member
  • 176 posts

Posted 10 July 2019 - 06:02 AM

Thank you! Also I found that EET_Tweaks handles XP reduction.

 

Also, what ended up happening with Weimar's Solaufein?



#20 jastey

jastey
  • Staff
  • 1873 posts

Posted 10 July 2019 - 08:47 AM

If it's on a list then it's compatible, but noone ever really took it on.