Jump to content


Photo

BGT v1.21: Issues, Solutions and Suggestions


  • Please log in to reply
165 replies to this topic

#161 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 03 January 2022 - 11:51 AM

It was Widescreen 3.07.  I guess the question is why did it work before, since I added nothing new to the folder, and deleted nothing either.  The only thing I can think of is I did not play the game using it, but that seems hard to believe.


This is impossible. Since running a setup-modname.exe creates a setup-modname.debug -file ... and likely the file that you had, is called "widescreen-v3.07.zip" or more likely "widescreen-v3.07.exe", which is self extracting archive file that you extract into the games folder... which adds the setup-widescreen.exe and a folder called "widescreen"...


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#162 chuft

chuft
  • Member
  • 40 posts

Posted 03 January 2022 - 12:13 PM

This made me curious enough to take out my old computer and look at the BG2 folder that I had copied to my new one.  It does have Widescreen 3.07 and the exe and the setup and debug files, with no errors.  So it did work fine on my last computer but not on this one.

 

I can only assume it had something to do with going from Windows 7 to Windows 10.  The folder contents are identical.



#163 skellytz

skellytz
  • Staff
  • 319 posts

Posted 03 January 2022 - 02:10 PM

Yes, that's the problem. Widescreen 3.07 is from 2016 with an outdated WeiDU version. Back in 2019 you installed all the mods with different and more recent WeiDU exes that you apparently didn't keep in the game folder. If you had kept a more recent version, the installer would have scanned the game folder for other installers and auto-updated itself to the most recent version found. Now you tried to reinstall everything using the outdated WeiDU installer that Widescreen was packaged with and that's why mods requiring newer WeiDU versions failed to install. This is exactly the first advice you got here: update your WeiDU. Come on, chuft, pull yourself together ;)

 

Edit: By "reinstall everything" I mean that you tried to reinstall only Widescreen, which in your mod install chain means WeiDU had to go through the other mods as well.


Edited by skellytz, 03 January 2022 - 02:52 PM.


#164 chuft

chuft
  • Member
  • 40 posts

Posted 03 January 2022 - 02:49 PM

Since I deleted nothing from the folder, indeed I hadn't even looked at it since building this computer and copying stuff over, your comment made me go look at the old computer with its folder that I copied.  And all the exe's are still there, but they are not here.  I can only assume my antivirus (which is different on the new computer) removed them for some reason since I can't imagine a reason to manually do so.

 

WeiDU is rather mysterious to me but I guess you are saying the widescreen one would have noticed there was a newer version and used that if it was available, and it was not available this time, because it had been somehow removed. 



#165 chuft

chuft
  • Member
  • 40 posts

Posted 03 January 2022 - 02:54 PM

I see no quarantined files so they must have been intercepted during the copying process two years ago.  I probably just clicked through it since I figured I could always extract them again if needed.  That's the only way I can think of that the setup exe's would be missing from a folder I copied and forgot about in Nov 2019.

 

In case someone is reading this later, my old antivirus was Webroot and new one is Kaspersky.


Edited by chuft, 03 January 2022 - 02:55 PM.


#166 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 04 January 2022 - 03:48 AM

The folder contents are identical.


This is so untrue, the fact is the setup-modname.exe's are/were missing, so the folder contents are totally different. Which is what lead into the problem you had and so on. I am aware that you now know this. But you, and others will want to remember that.


Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.