Jump to content


Photo

Bug Report: Game crashes when Bub Snikt is spawned.

BGT DSotSC Bub Bub Snikt

  • Please log in to reply
5 replies to this topic

#1 Roberciiik

Roberciiik
  • Member
  • 6 posts

Posted 29 November 2019 - 10:09 AM

Hi,

 

I just installed fresh BGT v1.20 with DSotSC (current master version from Gitjas github). And I found that the game crashes after travelling to south area of Beregost. I thought that it is a "Beregost bug" but I could go for example to the temple. So I analyzed that on this area should be NPC Bub Snikt, so I tried to run command "CLUAConsole:CreateCreature("DSBUB")" in temple location and game also crashed!

 

I've checked that master version from repository differs significantly from 2.17 availabe here at forum (removed sounds, directory layout reorganized, etc). Did I miss something during installation? Is it bug, or github version is not compatible with BGT?

 

I haven't installed modding tools, so if you need some extra debug files from other tools, let me know so I would try to run them.

 

Thanks for help.

Robert 



#2 jastey

jastey
  • Staff
  • 2002 posts

Posted 29 November 2019 - 10:40 AM

Hi, the DSotSC from my GitHub (Gitjas) is the most current one v3, we are preparing it for official move to the SHS GitHub and will then also update the download here at SHS.

Do you have any other mods installed? Please post the content of your weidu.log here.

I know that the current DSotSC works in BGT except for (so far) minor bugs, it's the first time I hear about Bub Snikt crashing the game. What level is your PC on? Because Snikt spawns with different cre-files depending on the PC's level. Does "DSBUB2", "DSBUB4", or "DSBUB6" also crash your game?



#3 Roberciiik

Roberciiik
  • Member
  • 6 posts

Posted 29 November 2019 - 11:24 AM

I found this issue when I played with TDD, BGT, DSotSC, NTotSC and BG1NPC mods in Polish (language). When I found that it is a problem with Bub, I tried to spawn DSBUB2 and DSBUB6 (with the same result). Later I reinstalled game just to BGT (PL) and DSotSC (master from github and without translations (ENG)). 

 

First time I played my team with main player (W/M/C lvl 1/1/1), Imoen (lvl2) and Will O'Hara (lvl2). But in my second approach with clean installation, I've just imported character from list and I moved outside Candlekeep with Gorion, then moved to location (CLUAConsole:MoveToArea("AR9700")), then I could not find Bub in the expected position (near to cave) so I tried to spawn him with crashing result.

 

Note that the version 2.17 works good as I played it before upgrade.

 

Here is my Weidu.log:

// Log of Currently Installed WeiDU Mods
// The top of the file is the 'oldest' mod
// ~TP2_File~ #language_number #component_number // [Subcomponent Name -> ] Component Name [ : Version]
~BG2FIXPACK/SETUP-BG2FIXPACK.TP2~ #1 #0 // BG2 Fixpack - Podstawowe poprawki: v9.01
~BGT/BGT.TP2~ #7 #0 // Baldur's Gate Trilogy - Rdzen: 1.20 (20 Feb 19)
~DSOTSC/DSOTSC.TP2~ #0 #0 // Dark Side of the Sword Coast (DSotSC): v3.0 beta
~DSOTSC/DSOTSC.TP2~ #0 #1 // DSotSC Wizard spells: v3.0 beta
~DSOTSC/DSOTSC.TP2~ #0 #2 // DSotSC Priest spells: v3.0 beta
~DSOTSC/DSOTSC.TP2~ #0 #4 // Distribute DSotSC items also in vanilla content: v3.0 beta

Edited by Roberciiik, 29 November 2019 - 02:10 PM.


#4 Roberciiik

Roberciiik
  • Member
  • 6 posts

Posted 30 November 2019 - 08:02 AM

I checked that spawning of Conchobhair (DSCONCH) also breaks the game. The rest of NPCs can be created correctly.



#5 Roberciiik

Roberciiik
  • Member
  • 6 posts

Posted Yesterday, 07:11 AM

I gave up and finally end with DSotSC in 2.17 version.

 

I checked various installation options and all of them cause the game is not responding after spawning DSBUB or DSCONCHO creatures.

I've tried the following installations (in polish if not specified):

- BG2 Fix pack v9 + BGT 1.20 + DSotSC v3.0

- BG2 Fix pack v9 + TDD + BGT 1.20 + DSotSC v3.0 + NTotSC v3.1.1 + BG1NPCProject

- BG2 Fix pack v9 + BGT 1.20 + DSotSC v3.0 (with all optional components)

- BG2 Fix pack v9 + BGT 1.20 + DSotSC v3.0 (ENG)

- BG2 Fix pack v9 + BGT 1.18 + DSotSC v3.0

- BG2 Fix pack v13 + BGT 1.20 + DSotSC v3.0

- BG2 Fix pack v9 (ENG) + BGT 1.20 (ENG) + DSotSC v3.0 (ENG)

- BG2 Fix pack v9 + BGT 1.20 + DSotSC v3.0 (with replaced dsbub and dsconcho CRE files from 2.17)

 

I'm not a modder, so I don't know exacly how to verify correctness of NPCs files. It does not look like installation problem, more like corrupted NPC data. I opened CRE files with Infinity Explorer but there was no full information about NPC, missing data like portraits or sounds which could be incorrect. Can someone check it in this BGT setup or provide some debug tools that I could verify this by myself? I'm ready to help find out what causes this bug, and want to enjoy pretty updated DSotSC version.

 

Thanks



#6 jastey

jastey
  • Staff
  • 2002 posts

Posted Yesterday, 08:42 AM

Thank you for your thorough tests. (And sorry for the frustration.)

I can confirm BGT 1.20 crashes for Bub* and Conch* cres. Reason was for Bub invalid cre colors, for Conch* it was an invalid color of his armor.

Attached are corrected files for which no more crashes occur in my game. Put the attached cres into dsotsc/base/cre and the itm file into dsotsc/base/itm - replacing the current files in the mod package, and install the mod.

Attached Files







Also tagged with one or more of these keywords: BGT, DSotSC, Bub, Bub Snikt