Jump to content


Stuck on Final DOTSC quest (missing nephew), trollslayer died

  • Please log in to reply
No replies to this topic

#1 Dieuw

  • Member
  • 1 posts

Posted 28 March 2020 - 02:05 AM

Hey everyone,


I'm playing through this mod the first time and ran into an issue near the end. After going through a  lot of caves, I run into the TrollSlayer dwarf NPC which according the the walkthrough is supposed to join me. However, it was impossible for me to keep him alive. I'm not sure what exactly caused this, but running into the room, there are about +/- 50 duergar with about another 50 or so ready to spawn immediately afterwards. Every time I tried the fight, trollslayer died within the first 30 or so seconds due to how powerful the enemy is (might be SCS, i dont know). I kept getting hit with seemingly endless desecrates, invisibility pot spamming rogues, cleric buffed fighters etc. Trollslayer had no chance every single time. I couldn't get him into the party either since the fight simply doesn't end before he died.


Side notes, on the bright side, definitely an epic fight. Trying it legitimately, it ran my entire party out of healing and all spells through all 4 casters, after which I still died to numbers. After about 4 or so reloads, I used the wand of cloudkill I got from curse of bone hill combined with luring the duergar into a chokepoint and webbing them in cloudkills. That, eventually, worked. Arter spending 2 or so hours on the fight I perhaps stupidly saved upon completing it, overtwriting the save from before the fight started. 


I tried ressing trollslayer but he stayed dead. I read the walkthrough and read that he is supposed to give me info on where to go next along with updating the search. I tried going back to ortho the smith, and to my surprise, he finished the quest. 


However, in the journal there are many mentions of information I never received. I never encountered the drow leader, which is supposedly something that happens after recruitting Trollslayer. I also never visited her room or, for that matter, a seperate drow encamptment somewhere near nashkell. The name jarlaxle or the Braeghan darthe never dropped either. 


I am assuming that trollslayer dying locked me out of the referenced content. Is this true? If so, is there any way to fix this? Like a console command to spawn him, or a map teleport command to teleport me into the referenced drow compound near nashkel so I could still confront the Drow leader? I can still reload to before talking to ortho, so perhaps spawning a new trollslayer would work, if I knew the console command for it...


Kind regards


Edited by Dieuw, 28 March 2020 - 02:07 AM.