Jump to content


Photo

Compatibility with The Stone of Askaver


  • Please log in to reply
10 replies to this topic

#1 Thanatos-Zero

Thanatos-Zero
  • Member
  • 22 posts

Posted 01 October 2020 - 01:14 PM

Red Carnelian, the author of The Stone of Askavar claims that DSotSC overwrite it's mod files.
If you do not mind, can you please verify this?
Maybe Red Carnelian's claims are based on his own version of DSotSC?
- http://www.baldursga...hp?topic=8300.0
- http://www.baldursga...php?topic=449.0

Edited by Thanatos-Zero, 01 October 2020 - 01:17 PM.

"That was me as well!" Or if you prefer moon speak... "SORE MO WATASHI DA!"
ElyonYedaDomar_650x240_zps695695ae.gif


#2 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 5143 posts

Posted 01 October 2020 - 01:56 PM

This might be a case of bad prefix selection if that happens, but the blame likely goes to Red Carnelian, as we comply to the general measures that mods like this go under, while there is no entry by Red Carnelian.

Or the fact that no such thing was made.

PS, you are pointing to a DSotSC thread from 2005, updated last 2012, while this version is from 2017 to 2020, so... it's definitely not the same, and Stones of Askavar still seems to be a mod that overwrites both vanilla & mod files without any regard of actually patching files, so any mod composition that is made needs to take that into account and move the whole mod into patching format ... say, if memory serves, things like the dead BWP & BWS once did.

 

PS, the version you refer to is the (non-Enhanced Edition) BG1 version, while this is specifically the BG1EE, EET and BGT -only versions of the DSotSC. That same forum has also the old Tutu-only version of the mod. But those are likely very hard to combine to this, so jastey hasn't invested time in trying to do that. As it likely be a waste of that resource.


Edited by The Imp, 01 October 2020 - 02:06 PM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#3 jastey

jastey
  • Administrator
  • 3117 posts

Posted 01 October 2020 - 09:21 PM

The SHS version for BGT/EET changed almost all files to use a "ds" prefix which the BG:EE version does not. I don't know the Stone of the Askavar mod, but I'd say with regard to the BGT/EET DSotSC version here at SHS, this statement about incompatibilitiy of files needs to be varified again as it likely is no longer the case.



#4 Endarire

Endarire
  • Member
  • 160 posts

Posted 01 October 2020 - 10:06 PM

The newest SHS versions of Stone of Askavar and Dark Side of the Sword Coast are almost certainly compatible on EET.



#5 Thanatos-Zero

Thanatos-Zero
  • Member
  • 22 posts

Posted 02 October 2020 - 06:54 AM

@The Imp Thank you. Actually this guide pointed out the incompatibility first, about which I asked on the Infinity Engine Discord server.
And then I was pointed here by the user ALien, which also was so friendly to give me the above mentioned links.

@jastey I see! Thank you.


@Endarire Is that so? Thanks, I am going to check this out.


Edited by Thanatos-Zero, 02 October 2020 - 06:56 AM.

"That was me as well!" Or if you prefer moon speak... "SORE MO WATASHI DA!"
ElyonYedaDomar_650x240_zps695695ae.gif


#6 jastey

jastey
  • Administrator
  • 3117 posts

Posted 02 October 2020 - 07:39 AM

The newest SHS versions of Stone of Askavar and Dark Side of the Sword Coast are almost certainly compatible on EET.


Stone of Askavar is not an SHS mod?



#7 Endarire

Endarire
  • Member
  • 160 posts

Posted 02 October 2020 - 09:28 AM

I somehow recalled SoA being on SHS.  Regardless, the latest non-Roxanne versions of SoA and DSotSC should be compatible on EET.  This is my current speculation based on the assumption that many years of patching and compatibility fixes have made these compatible.



#8 Mordekaie

Mordekaie
  • Member
  • 23 posts

Posted 14 October 2022 - 09:02 AM

Just for confirmation :

 

Do SoA v2.2 and DSotSC for EET v4.1 are compatible ?

 

Is it still relevant to install SoA after DSotSC ?

 

If the answer is yes, is there any issue to expect as SoA is installed in BGEE, while DSotSC for EET is installed after EET_core ?



#9 Red Carnelian

Red Carnelian
  • Member
  • 30 posts

Posted 18 October 2022 - 02:37 AM

They should be compatible and not effect each other. Stone of Askavar doesn't use any DS files.



#10 Mordekaie

Mordekaie
  • Member
  • 23 posts

Posted 18 October 2022 - 04:56 AM

Thanks.

 

The Stone of Askavar readme recommands to install Dark Side of the Sword Coast before SoA. So I guess this recommandation is outdated ?



#11 Endarire

Endarire
  • Member
  • 160 posts

Posted 18 October 2022 - 06:59 AM

That's correct.  Dark Side of the Sword Coast & Northern Tales of the Sword Coast are each EET compatible and should be installed post-EET Start.