Jump to content


Photo

BG1 areas in IWD2 weather flag issue


  • Please log in to reply
4 replies to this topic

#1 Proteusz

Proteusz
  • Member
  • 3 posts

Posted 10 October 2020 - 02:09 PM

Hi, I am currently toying with moving some content between BG1 and IWD2. I converted v1.0 are to v9.1 and was able to run areas smoothly with the exception of weather. It seems that setting up weather flag in .are file crashes the BG1 area while loading in IWD2. Mastarea.2da is setup properly and I have no idea where the error might come from. Any ideas?


Edited by Proteusz, 10 October 2020 - 02:13 PM.


#2 Gwendolyne

Gwendolyne
  • Staff
  • 903 posts

Posted 11 October 2020 - 06:03 AM

iirc, I may be wrong because It was so many years ago, IWD2 maps don't work with the regular BG weather flag. You should have a look at the IESDP IWD2 are structure documentation and modify it.


Edited by Gwendolyne, 11 October 2020 - 06:03 AM.

CARPE DIEM ....
 

In progress : Menace sur le Royaume de Diamant Éternel there.

#3 Proteusz

Proteusz
  • Member
  • 3 posts

Posted 11 October 2020 - 10:08 AM

Thanks Gwendolyne for the tip, the thing is I converted BG1 are to IWD are structure (v9.1), so the flags are at the same offsets as in regular IWD2 areas. All other flags seem to work fine (eg. day/night), except weather. So far I wasn't able to find the reason why.



#4 Proteusz

Proteusz
  • Member
  • 3 posts

Posted 15 October 2020 - 09:12 AM

I think I've found the reason - I haven't copied tis files properly. Apparently overlay files (like waves, pools, lava) come in pairs, one of which is connected with rain. Now everything seems to work fine :) I can continue with my little project.



#5 Endarire

Endarire
  • Member
  • 59 posts

Posted 15 October 2020 - 09:59 AM

@Proteusz
Your project seems like it would interest K4thos for IWD-in-EET.  I recommend leaving a forum post there about what you've done, what you're doing, and including links to your code.