Jump to content


Photo

How to deal with the DDraw problems of PST and other IE games


  • Please log in to reply
82 replies to this topic

#41 Sam Lake

Sam Lake
  • Member
  • 2 posts

Posted 18 June 2010 - 03:43 PM

Thanks Sam. ATI probably did this by accident, but it's good to know that these drivers may help.


No doubt, there's no way it was their intention to fix graphic glitches in an 11-year old game, though I'm thankful for it nonetheless. I just hope it'll work for others as it did for me.

And I forgot to mention in my previous post - thanks a lot for you widescreen UI, ghostdog. It's a joy to play PS:T with it.

Edited by Sam Lake, 18 June 2010 - 03:45 PM.

"You wanna swap wives? You can have mine as soon as I get one." - Myron, Fallout 2

#42 nug

nug
  • Member
  • 4 posts

Posted 09 August 2010 - 08:12 AM

Hi, i'm sorry for my english.

I found a post here.

This is a way to emulate DDraw through Microsoft Application Compatibility Toolkit. You can download it here.

Below is the post i found:

[I downloaded Application Compatibility Toolkit"

After installing the program, open "Compatibility Administrator" (should be under the new start menu shortcut "Microsoft Application Compatibility Toolkit 5.0")

I then pressed "New" and then right clicked on the newly created database and choose "Create New" and "Application Fix"

Name it whatever you want, and then locate the program file: "torment.exe" wherever it is on your HD. Click Next and choose one of the operating system compatibility modes if you wish; I chose "none." On the next page scroll down to "ForceDirectDrawEmulation" and check it. Click finish.

Now go up to "torment.exe" on the top right and right click to "Run Program"]

#43 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 09 August 2010 - 08:26 AM

Hi, i'm sorry for my english.

Your English good enough, the same solution is also in here... the link that takes to the Dazzle's post.

Deactivated account. The user today is known as The Imp.


#44 nug

nug
  • Member
  • 4 posts

Posted 09 August 2010 - 08:45 AM

The cursor problem remains, but it doesn't appear on playing screen, only in option screen, main menu, character screen, etc.

nv_ddraw_fix doesn't help. i'm using gtx 260 videocard, it seems that it works only with 8xxx series.

Edited by nug, 09 August 2010 - 09:08 AM.


#45 Freddy

Freddy
  • Member
  • 23 posts

Posted 11 August 2010 - 05:51 PM

I found using virtualbox with a windows xp guest fixed most of the problems I was getting which were: overall lag, especially for spells and green artifacts when casting spells. I have a radeon 5xxx card though.

I used the graphics drivers that came with virtualbox guest additions and not ati or nvidia drivers which both seem to suck very badly with planescape.

The only problem i'm getting is with screen scrolling. The scrolling arrow randomly vanishes on my normal machine so I can't scroll (opening inventory fixes it) and on virtualbox I find I can only scroll up and left, not right or down.

Edited by Freddy, 11 August 2010 - 06:03 PM.


#46 nug

nug
  • Member
  • 4 posts

Posted 12 August 2010 - 11:30 AM

Maybe I should try using Windos XP mode (Microsoft Virtual PC).

This doesn't seem to work. Torment doesn't even start, it shows an error message.

Edited by nug, 12 August 2010 - 11:58 AM.


#47 Freddy

Freddy
  • Member
  • 23 posts

Posted 12 August 2010 - 12:26 PM

Windows XP mode didn't work for me either. It gives a "no valid video modes supported" error. XP mode is very limited compared to other virtual machines like virtualbox.

#48 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 12 August 2010 - 01:29 PM

Um, since you used a virtual machine you should have used win98 and not winXP, since win98 is the system Torment was made for.

Edited by ghostdog, 12 August 2010 - 01:29 PM.


#49 nug

nug
  • Member
  • 4 posts

Posted 13 August 2010 - 09:14 AM

Um, since you used a virtual machine you should have used win98 and not winXP, since win98 is the system Torment was made for.

I'll keep it in mind *jokingly*

Well, actually, I fought there is no win98 for Windows 7, so I tried using winXP, but it seems I've been mistaken (just found win98 for win7).

Edited by nug, 13 August 2010 - 09:21 AM.


#50 Freddy

Freddy
  • Member
  • 23 posts

Posted 13 August 2010 - 10:59 AM

Um, since you used a virtual machine you should have used win98 and not winXP, since win98 is the system Torment was made for.


Well, I get the impression the cause of most of the problems people have with planescape is graphics driver related. So as long as the virtual machine's graphics drivers don't have the same problems modern graphics drivers have with the game, using XP over 98 shouldn't cause any problems.

#51 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 13 August 2010 - 03:39 PM


Um, since you used a virtual machine you should have used win98 and not winXP, since win98 is the system Torment was made for.

I'll keep it in mind *jokingly*

Well, actually, I fought there is no win98 for Windows 7, so I tried using winXP, but it seems I've been mistaken (just found win98 for win7).

I was actually talking about setting up a stand alone virtual machine program and not the one win7 has. (I think win7's VM only does partial emulation, but I could be wrong). Anyway, as Freddy said, problems mainly come from the DDraw graphical emulation and not from the operating system.

#52 -Erik-

-Erik-
  • Guest

Posted 10 September 2010 - 05:14 AM

Hi, i'm sorry for my english.

I found a post here.

This is a way to emulate DDraw through Microsoft Application Compatibility Toolkit. You can download it here.

Below is the post i found:

[I downloaded Application Compatibility Toolkit"

After installing the program, open "Compatibility Administrator" (should be under the new start menu shortcut "Microsoft Application Compatibility Toolkit 5.0")

I then pressed "New" and then right clicked on the newly created database and choose "Create New" and "Application Fix"

Name it whatever you want, and then locate the program file: "torment.exe" wherever it is on your HD. Click Next and choose one of the operating system compatibility modes if you wish; I chose "none." On the next page scroll down to "ForceDirectDrawEmulation" and check it. Click finish.

Now go up to "torment.exe" on the top right and right click to "Run Program"]

This is awesome, now I don't have to manually disable hardware accelleration anymore. Thanks! However you can make it even easier.

After doing what you said, click on the floppy disc to save the database if you haven't already. Then right click on it and click on 'install'. Now when you start Torment.exe it will automatically apply the fix, without having to boot it through the compatibility administrator. :)

#53 -Humanophage-

-Humanophage-
  • Guest

Posted 24 October 2010 - 11:30 AM

I believe I've found a way to fully fix the cursor issue while running full screen. One has to use the D3DWindower solution, and then use a programme called ShiftWindow to force full screen. The procedure is like this:
1. Open D3DWindower and ShiftWindow.
2. Run P:T using D3DWindower.
3. In ShiftWindow, choose to run P:T in a window.
4. In ShiftWindow, choose to run P:T full screen.

If one switches to full screen straight away, there will be graphical artefacts. This doesn't take long at all, and it fixes all the troubles.

#54 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 24 October 2010 - 02:07 PM

nug, Erik and Humanophage thank you for the info. I've added it in the first post ;)

#55 WDeranged

WDeranged
  • Member
  • 21 posts

Posted 28 November 2010 - 10:10 PM

I've just got myself a Radeon 5970 and was pretty blown away to find that PST works without any of the graphical issues that plagued me with my Geforce, the only issue I'm getting is slowdown when lots of NPC's are on screen, has anyone found a workaround for this?

I'm on Windows 7 by the way, I tried the compatibility toolkit but performance is almost identical <_<

#56 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 29 November 2010 - 11:12 AM

I've just got myself a Radeon 5970 and was pretty blown away to find that PST works without any of the graphical issues that plagued me with my Geforce, the only issue I'm getting is slowdown when lots of NPC's are on screen, has anyone found a workaround for this?

I'm on Windows 7 by the way, I tried the compatibility toolkit but performance is almost identical <_<

The d3dwindower will probably fix your problems.

#57 English learner

English learner
  • Member
  • 7 posts

Posted 29 November 2010 - 09:25 PM

It seems D3Dwindower does not work on 64 win7.

#58 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 29 November 2010 - 09:43 PM

It seems D3Dwindower does not work on 64 win7.

Where did you install the game to ? And was all the Windows Security on your control, or was it 'just what it is'...

Deactivated account. The user today is known as The Imp.


#59 English learner

English learner
  • Member
  • 7 posts

Posted 29 November 2010 - 10:00 PM

I installed the game to "D:\Planescape - Torment". When I force Torment to run in window mode by using D3D and the DLL, it still runs in full screen. Have you ever tested D3D on X64?

#60 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 30 November 2010 - 02:03 AM

I installed the game to "D:\Planescape - Torment". When I force Torment to run in window mode by using D3D and the DLL, it still runs in full screen. Have you ever tested D3D on X64?

You probably haven't disabled the User Account Control & Program Compatibility Assistant. The help for that on the answer #2.

Deactivated account. The user today is known as The Imp.