Jump to content


Photo

BWP v15


  • Please log in to reply
257 replies to this topic

#1 Leonardo Watson

Leonardo Watson
  • Member
  • 496 posts

Posted 23 March 2015 - 05:59 AM

BWP v15 is released now. I have re-arranged the biggest part of the tweaks due to technical reasons. Although most of the common player won't notice any difference in the gameplay it was one of the most complicated piece of work that I ever did.

---

In the previous versions there were some problems that should be solved now. One of them was with the Aurora mod:
Aurora should go before SCS, however, doing so leads to another problem.
Aurora's main component and some others like RR add their own scripts to a lot of creatures. So, when it comes to SCS, some creatures have all 5 script slots filled and SCS skips that creature. I got nearly 80 times the message "Failed to insert script". Now, this problem is drastically reduced to 9 times now.
Also I got messages like "Couldn't add CLERIC_STALKER to spell.ids as no slots remain" with the IWDification mod. This is solved now.

---

In the past I always made an installation with nearly most of the mods. Then I noticed that leaving out an mod can also lead to errors as if to add an mod in the wrong order. Some mods expect IDS entries that are made by other mods. If the mods isn't there, the entry is missing in the IDS and the installation of the mod fails. For example, TDD is the only mod that adds SIMULACRUM to the SPECIFIC.IDS, however, a few other mods expect it there.

---

I have added  the Scales of Balance mod. There are some problems now when I install it in the suggested order before Stratagems:

Component 250 7: Weapon Proficiency Overhaul adds sob/wizard/clabma01.2da which includes GA_D5_CANT
The d5_cantr.spl however is copied only with component Component 600 28: Wizard Class Changes
So if one installs component 600 28: Wizard Class Changes without component 250 7: Weapon Proficiency Overhaul this lead to the

 

 

ERROR: Failure("resource [D5_CANT.spl] not found for 'COPY'")

 

with the stratagems component 6000 Smarter general AI.

When I try to install the stratagems component 8141 Slightly Improved Drow or 8170 [Enhanced Sendai's Enclave I get the error message:

 

ERROR: [dagmag01.CRE] -> [override/dagmag01.CRE] Patching Failed (COPY) (Failure("Unknown function: %RESREF_D5_GSEQ3_KIT_EFFECTS_REMOVE%"))
Stopping installation because of error.
Failed to patch dagmag01.CRE; error message was Failure("Unknown function: %RESREF_D5_GSEQ3_KIT_EFFECTS_REMOVE%")


I didn’t manage to install most of the NPC changing components 800 and higher except for 815, 821, 835, 860, 872, 890


With component 310 9: Kensai Weapon Focus I got the error:

 

ERROR: [d5_KLSWO.2da] -> [override] Patching Failed (COPY) (Failure("Unknown macro: remove_blank_lines"))


Oddly enough I was able to install this component with SoB v2.4. I Didn't want to delay the new release of BWPv15 any longer so I didn't investigate why this happens.

---

I did't manage to install Imoen's Romance Mod v2.4 because it overwrites content of other mods. For example:
In the AR1203.bcs I have code blocks from FR_ROV, Fade, TsukiBG2 and Azure. Imoen's Romance replaces them all with its own code block. I don't know why this happens because the responsible code from Imoen's Romance is:
 

 

ACTION_IF FILE_EXISTS ~Override/ar1203.bcs~
    THEN BEGIN
        EXTEND_BOTTOM ~Override/ar1203.bcs~ ~imoenRomance/scripts/SOA/Quests/ar1203.baf~
END
ELSE BEGIN
        COMPILE ~imoenRomance/scripts/SOA/Quests/ar1203.baf~
END

 


Unfortunately I haven't enough skills to investigate this further.

---

I also tried to install the new Divine Remix v8. Sadly the component 1000 is a sure road to failure and will ruin your whole installation. Without this component you will miss the core of the mod.

---

Many mods are modifying and overwriting STATS.IDS, ACTION.IDS, SPELL.IDS and a few other IDS files again and again. This appears to be a source for countless fails and the main problem in the megamod to be solved. Therefore I will start a new topic about this.

---

Occasionally I got error messages like this:

 

ERROR: COPY ~Setup-RevisedBattles.exe~ ~WeiDU.exe~ FAILED: cannot open target 

 

although the file is existing. I am pretty sure this is caused by an activated virus scanner.

The same is with the message:

 

ERROR: problem saving [override/DRIZZT.dlg]: Sys_error("override/DRIZZT.dlg: Invalid argument")


---

The functionality of the Installpack is much improved now.

I want to further improve the install order and have a long to-do list. Above all I am unsure about the right order of IR with IPPv4. IR is going to be changed very much. Is it needed to split it any longer? I need your suggestions about this.

---

I did my very best for a bug-free installation. However, the BWP is far to complex to test all configurations. So I need your comments for further improvements. Please post here your experiences and suggestions. Probably I won't answer shortly. It may take some time until I am back at the forum again. Sooner or later I will read your posts carefully.



#2 Almateria

Almateria

    most garbage person

  • Modder
  • 947 posts

Posted 23 March 2015 - 11:01 AM

Again:

1. the language table omitted the italian and chinese languages for ARP.

2. Is there any good reason as to why ARP is considered a "mini-mod"? Because I sure as heck don't think it's mini, especially when compared to the rest of mods in that category.



#3 -kerkes-

-kerkes-
  • Guest

Posted 23 March 2015 - 11:21 AM

BWP v15 is released now. I have re-arranged the biggest part of the tweaks due to technical reasons. Although most of the common player won't notice any difference in the gameplay it was one of the most complicated piece of work that I ever did.

Mr. Leonardo Watson, my hat is off to you. :Bow:

While I'm not a BWP player, the ammount of work you put into making this work deserves my utter respect. Keep up the good work. 

As for 1pp and IR, probably the best bet would be to wait for IRv4 (it really shouldn't be long - the only thing it lacks now is a Readme, mayhap some minor bugfixes). Fwiw, I install these components of 1pp before IR/SR:

Spoiler

 

.....and then IR/SR - that way, game looks darn stunning, with no errors, CTDs and similar.



#4 jastey

jastey
  • Staff
  • 2420 posts

Posted 23 March 2015 - 12:09 PM

Great thing! Thank you for considering so many new (and beta) versions.

 

But, please remove the Gavin BG1 German translation from the textpack. The v9beta has an own revised (part) German version.



#5 new(Mike)

new(Mike)
  • Member
  • 103 posts

Posted 24 March 2015 - 05:15 AM

where i can find Ascalons Questpack v2.00b_1502057,  i can only find v1.01



#6 prozh

prozh
  • Member
  • 7 posts

Posted 24 March 2015 - 05:26 AM

where i can find Ascalons Questpack v2.00b_1502057,  i can only find v1.01

https://github.com/w...ee/2.00b_150205



#7 new(Mike)

new(Mike)
  • Member
  • 103 posts

Posted 24 March 2015 - 04:32 PM

thank you very much

 

@prozh



#8 Saint-Stanislas

Saint-Stanislas
  • Member
  • 14 posts

Posted 31 March 2015 - 05:00 PM

Hi there , Already posted in the pined thread of bwp and just saw this thread. Dabus helped me to figure out that there is a missing ")" in process.bat at the strings about BG1RE. It cause a syntax error and close the batch file. The workaround for me was to add the ")" and then rename process.bat to individual.bat, mostly because I couldn't figure out how to avoid the checksum on process.bat !

#9 new(Mike)

new(Mike)
  • Member
  • 103 posts

Posted 04 April 2015 - 05:56 PM

is the mod of The Fields of the Dead installed in BWP15

the mod can be installed in BGT,i don't konw if it can be installed in BWP15

#10 jastey

jastey
  • Staff
  • 2420 posts

Posted 04 April 2015 - 10:05 PM

Sir Ajantis NPC for BGII is now officially v12 and available from the Downloads Page.



#11 Gaspare

Gaspare
  • Member
  • 129 posts

Posted 05 April 2015 - 05:25 AM

Is the trimpack needed in order to make a correct megamod install? I noticed it hasn't been updated like other files...

 

I'm using BWS to make the install, I guess that latest version present in the repo is compatible with BWP 15?

 

Last doubt I have, , do I have to keep the already existing individual.bat file after i rename my "process.bat" file to "individual.bat", once I fixed the original "process.bat" file by adding the missing bracket?


Edited by Gaspare, 05 April 2015 - 05:31 AM.


#12 Leonardo Watson

Leonardo Watson
  • Member
  • 496 posts

Posted 05 April 2015 - 07:58 AM

@ Almateria
I simply have no own category for ARP. The chapter "BP and following mods" is no better place for it. That wouldn't change the install order at all. But you are free to make your own suggestions.
Italian and Chinese languages are included now.

@ -kerkes-
Thanks for your suggestions. I will consider them with the next update.

@ Saint-Stanislas
Thanks for your hint. I have updated a fixed Install Pack.

@ new(Mike)
The Fields of the Dead is on my to-do-list.

@ Gaspare
Trimpack is needed for some files and it is still valid.



#13 Gaspare

Gaspare
  • Member
  • 129 posts

Posted 06 April 2015 - 01:03 AM

Ok. I'll just use BWS to get a modlist based on the type of install I choose (tactics in my case), then i'll download mods manually and use BWP 15 to install everything... I hope It works xD



#14 dreamer2007

dreamer2007
  • Member
  • 430 posts

Posted 06 April 2015 - 07:30 AM

Thank you very much the new version! :)



#15 tomkaz

tomkaz
  • Member
  • 992 posts

Donator

Posted 06 April 2015 - 05:07 PM

Hi Leonardo;

 

You put in lots of good work into v15.  I envy your knowledge of DOS.

 

I had problems with v14 and gave up on it.   But I used the install order from v14 with v13 and it worked great.  That game is dead because I selected a few mods that were unpleasant to play and one that kills me instantly before I can take a step.  I need to go to that area to do other things.  But so much for that.  My solution is to start a new game with v15.

 

The BWP Project pdf was very helpful.   The only problem I had was with the URL on page 19.  It is:  

 

http://iem.rp-addict.com/index.php

 

I have tried it several times, but I cannot make a connection.  I am using Google with Kaspersky active on Windows 7 Pro (64 bit).

 

I want to check it out for updates as some are difficult to find.  I do have many of the missing ones saved, but I am still looking for some to complete my game.  That is the reason I am trying to go to that site.

 

Any information would be helpful, especially if the problem is with my computer or with Time-Warner Internet.  If it is available at only certain times, it would be useful to publish that information.

 

Thanks again for the great effort.  With a bit of luck, I will be installing the game in two days.

 

Tom



#16 tomkaz

tomkaz
  • Member
  • 992 posts

Donator

Posted 09 April 2015 - 07:34 AM

Hi Leonardo:

 

I noticed there is a new version of BiG World Installpack.  Is there a place that documents the differences between v15 and v15.0.1?  Idid not find anything in the v15.0.1 files.

 

Tom



#17 tomkaz

tomkaz
  • Member
  • 992 posts

Donator

Posted 09 April 2015 - 02:50 PM

Hi Leonardo:
 
I am not happy right now.  The game is finished installing, but it is not the game I wanted.  I spent a few days editing individual.bat.   I did not wanted all the components listed in individual.bat.  I used REM to delete the lines with components I did not want and rewrote the lines with the choices I wanted. However, BiG World Installpack installed them all.  It appears that it ignored individual.bat completely.
 
I am still very confused by the choices you make to install the mods and components.  I would appreciate information on what the choices mean and which choices I should make to have BiG World Installpack follow individual.bat.
 
Thanks for any help you can give me.
 
I will be trying to install the game to my specifications in about an hour.  I will read the choices more carefully and see if I can make better choices with this next install.
 
As a side bit of information, the skipped mods listed were gMinionScripts (scripts), NTotSC (large quest; standard), NTotSC Patch (no comments), and MTS Crappack (various tweaks).  I do not understand this.  Especially since all the mods loaded correctly in previous mega-mod games.  Actually the game refused to install until I included MTS Crappack. 
 
Tom
 
Reading though the error logs I found the reason that NTotSC was not installed was because it must be installed after DSotSC.  In the WeiDU.log file, DSotSC was not installed.  But in individual.bat, DSotSC is there and before NTotSC.
 
Tom
 
I just realized there is no code for installing MTS Crappack in individual.bat nor in Big World Project v15 pdf.  It is in Big World Project v13 pdf.
 
Tom

Edited by tomkaz, 09 April 2015 - 03:38 PM.


#18 dabus

dabus
  • Member
  • 1982 posts

Posted 09 April 2015 - 04:04 PM

Simple: Look at the code...
findstr /I /M "individual" %SET%>nul
if %errorlevel%==0 (
	call ".\%BWIP%\individual.bat"
)
So individual is used if individual is in BWP Settings.txt. Search bat-files for that string and you find
%TXT% | findstr @503 | Call %C%
%TXT% | findstr @547 | Call %C%
:REPMODSE
set X=
set /P X=
if /I "%X%"=="1" echo PreSelection>> %SET% & goto :CKSUMCOM
if /I "%X%"=="2" echo process>> %SET% & goto :CKSUMPRO
if /I "%X%"=="3" echo individual>> %SET% & goto :CKSUMIND
if /I "%X%"=="4" echo allyouget>> %SET% & goto :CKSUMPRO
%TXT% | findstr @500 | Call %C%
goto :REPMODSE
Now look for 3 in string.txt. Text has a 503 in front of it.
@503
@503[1] Do you want to choose a preselection?
@503 or
@503[2] Do you want to filter the mods according to various parameters?
@503 or
@503[3] Do you want to use an installer changed by your own and skip the settings?
@503 WARNING: This option should only be used by very experienced and keen on
@503 experimenting players. You probably will run into problems and therefore
@503 you should be able to use NearInfinity!
@503 or
@503[4] Do you want to install all you can get? (not recommended)
Tada. So you likely selected another option and not 3.
Wasn't that hard if you keep 2 or 3 things in mind and know where to start/know what you want.
You just need a tool to search through the files. You can even use cmdline-tools like the batch.
Search all batch files in a folder for individual with this:
findstr /n /s /I "individual" "*.bat"

Edited by dabus, 09 April 2015 - 04:07 PM.

THINK! - It's not illegal.

#19 tomkaz

tomkaz
  • Member
  • 992 posts

Donator

Posted 10 April 2015 - 08:08 AM

Hi dabus:

 

My apologies.  I sent a reply yesterday thanking you for your help.  But like my mega-mod game, it got lost.

 

I did trace the installation sequence (with the information in your post) and now understand some more about how BWP installation works.

 

One thing I do not understand is why there are two installation files.  BWP uses individual.bat if you are modifying the mods or components you want in your game.  BWP uses compilation.bat if you are installing everything in you BGII - SoA game.  Since you cannot do both, why are there two?  Well I will just need to do some more tracing of the installation process.

 

I must admit Leonardo has some very neat programming in those files.  I learned Apple DOS with the help of What's Where in the Apple and Beagle Brothers' charts.  When I was forced to switch to Microsoft, Peter Norton's DOS 5 Guide was great.  But until a few years ago, I have been away from DOS programming.  The DOS of today is amazing.

 

Thanks again for you help,

 

Tom



#20 tomkaz

tomkaz
  • Member
  • 992 posts

Donator

Posted 10 April 2015 - 07:34 PM

I have a new mega-mod game installed and played it for about an hour.  Comparing it to my last mega-mod game, which had the same mods, it seems to have more bugs.  About 12 mods have been updated so they may not have been fully tested.

 

I did make some typos in editing the individual.bat file.  This caused some components to be loaded that I did not want and prevented one mod from being installed.  There are 183 mods installed.  It took 2 hours and 20 minutes to install.

 

Therefore, I have to say that Big World Project v15 is a success and working well.

 

Tom