Jump to content


Photo

Icewind Dale 2 help


  • Please log in to reply
3 replies to this topic

#1 Sammy

Sammy
  • Member
  • 2 posts

Posted 21 May 2019 - 04:49 AM

Hey,

I have no idea if this is the wrong part of the forum for this question (please move this thread there if so), but I upgraded to Windows 10 last year and just the last few days I decided to reinstall IWD2 to replay. The first problem I encountered was simply that the game would not start, I'd just get most of the screen go black and it would stay like that (and had to use task manager to close the exe). I went over to the IWD2 page on PCGamingWiki (https://pcgamingwiki...Icewind_Dale_II) to see what to do, and it said to delete the ddraw.dll file On Win 10 to solve the problem, which I did and it worked. Second problem I found was that I noticed when starting a new game, the fog of war was screwed up, like flickering at the edges. Anyone know how to solve this issue?



#2 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4792 posts

Posted 21 May 2019 - 06:33 PM

The second problem... you need to either disable or re-enable the sprite mirroring. To do this, if you use the C -drive, you have to first installing the game into the users own folder, here: C:\Users\<windows username>\Games\IWDII or the like, as that's the only folder that you are allowed to edit files in, without them being redacted to be else where that the old games have no reason to read them from. Specifically into C:\Users\<windows username>\AppData\Roaming\<game install folder> ... and yes, the AppData folder is set to be invisible, so to see it you just need to allow hidden files&folders to be viewable in the folder options. 

 

And then you go to the game folder and either edit the icewind2.ini with Notepad for example or start the configuration tool(Config.exe), in where that can be done.

 

Also if it's the flicker I had in the past, it's actually video cards anti-aliasing & resolution option based, so setting a different resolution in the Widescreen mod is an option. The other, is to remove the anti-aliasing completely, which depends on your videocard. While the last is to replace the fog of war texture with a better/less micro particles, but while that can be done, there has not been a mod release that would do that.

 

EDIT; Note that I had forgotten the number 2 from the file name, and couldn't give the exact .exe name, but now they are included.  :rolleyes: It wasn't like I had the game at hand at the time. 


Edited by The Imp, 23 May 2019 - 03:50 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.


#3 Sammy

Sammy
  • Member
  • 2 posts

Posted 22 May 2019 - 08:15 PM

I did all that, installed where you recommended, enabled sprite mirroring (and yes it didn't revert) and still got the same problem:

 

jLIxc6X.jpg



#4 The Imp

The Imp

    Not good, see EVIL is better. You'll LIVE.

  • Member
  • 4792 posts

Posted 23 May 2019 - 05:06 AM

OK, there's a very old but still good work workaround for this problem in here. It works... but it's not GREAT, as it will make a few of the screen flicker the ~curse words~. But it fixes the wrongly angled textures. And as a bonus, you didn't need to delete the ddraw.dll, as this replaces it... :P

And then sometimes you'll be searching for your invisible&blinking cursor. Ahh, we'll live with this. And if you got the game from GOG, the same fix is already included in the game's folder, you just need to run it.


Edited by The Imp, 23 May 2019 - 05:11 AM.

Yep, Jarno Mikkola. my Mega Mod FAQ. Use of the BWS, and how to use it(scroll down that post a bit). 
OK, desert dweller, welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand. Ouh, actually it was still snow then.. but anyways.