Jump to content


Photo

IE games and NVidia Series 8 video cards


341 replies to this topic

#221 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 19 November 2009 - 03:32 AM

So I thought I had done a pretty good job of following the directions in the tutorials and everything but when I try to load up the games with a boot disc it goes right back to the DC menu screen. There are files on the disc because I can go to the CD player and see about 40 tracks there. Anyone have any idea what could have gone wrong?

Boot disc?
DC menu screen?


OK, now to the real questions.
What game are you trying to start?
Have you installed the whole game?
Now, for example when you try to start the BG2 ToB game(or BGT or Tutu), you need to insert the BG2 ToB CD into a cd drive, quit the Front End programs it might load, and go to your game directory, make a quick icon from the BGMain.exe to the desctop, and start that.
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#222 -Confused-

-Confused-
  • Guest

Posted 21 November 2009 - 04:14 PM

Posted Image

Saw this screenshot in this topic and wondering why I cant get mine to look similiar when it comes to GUI.

Posted Image

As you can see it is much bigger here, I run 1280 res atm. And this is BGT108_Install is Tutu a better choice?

What do I need to do to get the GUI, to scale like on the upper of the screenshots?

Really helpful tho had the flicker issue and the GUI+Meny's left mouse trails and old images, but with the Vsync always off in RivaTuner that got solved quicky.

#223 Isaya

Isaya
  • Modder
  • 294 posts

Posted 22 November 2009 - 06:19 AM

Your screenshot shows a resolution of 640x480. It's set by the game, not by your video driver. Using the BGConfig program, in the game directory, you can unlock higher resolutions, 800x600 and 1024x768. The higher ones listed in the tool are not working properly, so avoid them at all cost.
If you wish to play with higher resolution, you need a mod/patch called Widescreen. Contrary to what its name implies, it works with any kind of screen and let you choose you the resolution that best fits your screen, whether it is 1280x1024, 1280x800 or any other.

There is no difference between BGT and Tutu regarding handling of screen resolution.

Edited by Isaya, 22 November 2009 - 06:20 AM.


#224 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 22 November 2009 - 06:32 AM

Your screenshot shows a resolution of 640x480.

Meaning he is most probably using BG1, not BGT or BG1Tutu/EasyTutu. Yeah, the Widescreen mod is the answer to th why the GUI looks as it does, and what comes to the size of the screen shot, it's obviously resized...
The Widescreen mod also works in BG1, so go install it if you like the higher rezz.

Edited by Jarno Mikkola, 22 November 2009 - 06:34 AM.

Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#225 -Charlo-

-Charlo-
  • Guest

Posted 29 November 2009 - 07:25 AM

Your screenshot shows a resolution of 640x480. It's set by the game, not by your video driver. Using the BGConfig program, in the game directory, you can unlock higher resolutions, 800x600 and 1024x768. The higher ones listed in the tool are not working properly, so avoid them at all cost.
If you wish to play with higher resolution, you need a mod/patch called Widescreen. Contrary to what its name implies, it works with any kind of screen and let you choose you the resolution that best fits your screen, whether it is 1280x1024, 1280x800 or any other.

There is no difference between BGT and Tutu regarding handling of screen resolution.


First of all thanks for responses, but a few minor corrections.

1. No it does not show a 640x480 screenshot
It shows how the game looks in 1280x960.
2. I did use BGT in that screenshot that was mine above, now I went EasyTutu instead. My question about Tutu vs BGT wasnt about resolution but rather which one might be better for various reasons.

As reference, this is how BG1 looks in 640x480.
Posted Image

I later figured out that the widescreen mod just like you said fixes the scaling of the GUI. So Im running that mod in 1280x960 and with a scaled GUI it looks much better than the unscaled one dont you agree :P
Posted Image

#226 -Arlin-

-Arlin-
  • Guest

Posted 13 December 2009 - 05:58 AM

Hello everyone! This is my first reply here!
I've still got a problem with Planescape Torment, I've got an nvidia geforce 8500GT 512MB, I've installed the nvidia fix and use "force direct draw" with windows compatibility administrator, now the spells are ok (my big problem) but there's the problem of the mouse trail. I tried to fix in the Torment.ini, or uninstalling the nvidiafix but nothing!

What can I do? Please help me ^_^'

#227 Greaph

Greaph
  • Member
  • 2 posts

Posted 15 December 2009 - 04:43 PM

For fixing BG1, IWD1 (without HoW), IWD2 and PST you can install this fixer utility (programmed by Eddy, WeiDUed by me):
If you use this fixer utility, don't forget to remove the application profile in the Compatibility Manager (if you're using it, remove the profile like this: start -> programs -> Microsoft Application Compatility Toolkit -> Compatibility Administrator -> Installed Database -> right click and remove on the item you created) or stop using the .vbs launcher.



I dl'd and extracted the file to the directory I installed the PST files to. Tried to run the "Setup_nvidia_Fix" executable within the game directory and received the following error: ERROR: Unable to find DIALOG.TLK in:
dialog.tlk

I am sure I have done something stupid wrong, but I followed the readme as I understood it. Any help please?

I am trying to run PST on an nVidia 8800 gt system. Ran fine until game crash in "The Tomb". Now upon subsequent loads, I get the following error: Assertion failed .... ChDimm.cpp at line number 787

PST- 4 disk, ISO's on hardrives, Patched to 1.1, then big fix update, no cracks, hacks, or mods.

TIA- Greaph

#228 -docmock1981-

-docmock1981-
  • Guest

Posted 21 December 2009 - 11:16 AM

I don't know if anyone is monitoring this forum anymore, but I installed the nvidia fix to use with Planescape Torment and the game runs fine until I attempt to cast certain spells (ie Magic Missile, Chromatic Orb) and then the game screen freezes momentarily, goes black, some parts of the screen return, and if I'm lucky, the game resumes several moments after the spell has been cast. I uninstalled the nvidia fix and went with the Microsoft compatibility fix and that works fine, but I get the mouse cursor artifact that is a few have mentioned. I've been going through the threads, but I don't see a solution. Considering the Compatibility fix is an older solution I wonder why the Nvidia fix is giving me such grief. I'm using Vista w/ an Nvidia Geforce 8600. I have all the typical patches installed for PST and, honestly, I can deal with artifact, but would prefer to play without it. If anyone has some insight into the matter or can direct me towards a link, I would be very grateful. Thanks to those of you who have spent so much time dealing with Vista/Nvidia in order to let us play some truly classic and amazing games.

docmock1981@gmail.com

#229 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 21 December 2009 - 11:28 AM

...

There is a half fix in here for your troubles, it's not perfect, but it should lessen the problem.
Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#230 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 22 December 2009 - 05:23 AM

I finally found a good way to avoid the problems newer cards have with DDraw (artifacts, choppy framerates, stuttering). The solution is to use the D3DWindower program. This utility can help you run older games in a window, using ddraw emulation, thus eliminating any ddraw issues. You can find it here. It's a partly translated version form Korean, but it's easy to figure out. In order to use it, push the "+" button, choose the game exe and then click on the settings button. Enter the resolution in which you have the game installed (height and width are misplaced). In the "DDL" box select the .ddl that was inside the archive, then go to the "Window Mode" tab and tick the "DDraw emulate" box. Finally press the "run program" button to run the game windowed.

This worked fine for PST, I've heard it also works good for the Fallout games and I'm sure it will also work for Baldur's Gate and Icewind Dale. The above settings worked for Planescape Torment, but other games may need somewhat different settings. If you want the window to fill the whole screen, just install the game at your fullscreen resolution and then run it with D3Dwindower.

Some antivirus may mark the exe as a trojan but I think that's because it somehow hacks d3d/ddraw to make any application run in a window. Anyway, I haven't encountered any problems, but use it at your own risk.

Maybe this should be mentioned in the first post, since it eliminates DDraw problems regardless (probably) of the graphic card.



EDIT: Another thing i forgot to mention is to check the "Cursor Clip" box in the "Direct input" tab. This keeps focus on the window , so the mouse won't appear outside. Especially useful for scrolling.

Edited by ghostdog, 23 December 2009 - 09:21 AM.


#231 -Gianluca-

-Gianluca-
  • Guest

Posted 22 December 2009 - 02:51 PM

I finally found a good way to avoid the problems newer cards have with DDraw (artifacts, choppy framerates, stuttering). The solution is to use the D3DWindower program. This utility can help you run older games in a window, using ddraw emulation, thus eliminating any ddraw issues. You can find it here. It's a partly translated version form Korean, but it's easy to figure out. In order to use it, push the "+" button, choose the game exe and then click on the settings button. Enter the resolution in which you have the game installed (height and width are misplaced). In the "DDL" box select the .ddl that was inside the archive, then go to the "Window Mode" tab and tick the "DDraw emulate" box. Finally press the "run program" button to run the game windowed.

This worked fine for PST, I've heard it also works good for the Fallout games and I'm sure it will also work for Baldur's Gate and Icewind Dale. The above settings worked for Planescape Torment, but other games may need somewhat different settings. If you want the window to fill the whole screen, just install the game at your fullscreen resolution and then run it with D3Dwindower.

Some antivirus may mark the exe as a trojan but I think that's because it somehow hacks d3d/ddraw to make any application run in a window. Anyway, I haven't encountered any problems, but use it at your own risk.

Maybe this should be mentioned in the first post, since it eliminates DDraw problems regardless (probably) of the graphic card.

Thanx for this program, it works! But I've got a little problem yet!
I Installed the game normally, in 640X480...when I run with this program I see always the topbar of the window! Is it normal? Can I remove it?

#232 ghostdog

ghostdog
  • Modder
  • 556 posts

Posted 23 December 2009 - 09:15 AM

I Installed the game normally, in 640X480...when I run with this program I see always the topbar of the window! Is it normal? Can I remove it?


Well it's in a window, so I don't think you can get rid of the topbar.
Another thing i forgot to mention is to check the "Cursor Clip" box in the "Direct input" tab. This keeps focus on the window , so the mouse won't appear outside. Especially useful for scrolling.

Edited by ghostdog, 23 December 2009 - 09:21 AM.


#233 -Concerned-

-Concerned-
  • Guest

Posted 23 December 2009 - 09:48 PM

Since Vista, I've been seeing graphic anomalies with the unexplored areas. Basically, jagged shadows:
Posted Image

I've applied the nvidia patch here and this worked for me to resolve the black box issue but the above issue persists.
Does this widescreen mod I'm reading about address this?

(...)

Color depth is 32 but, only software mirror BLT is enabled but the problem persists. enabling this in 16 but color mode works but then spell effects slow down the frame rate.

This exact problem, only I'm on a laptop with a 9300M GS and Vista 64-bit. Basically, the fog of war sprites aren't mirroring, nor the projectiles. Arrows/bolts/darts/daggers/axes travel either backwards or sideways when fired or thrown; obviously bullets look fine. The fog of war looks more or less exactly like JB's image. I've tried:
  • Updating drivers. No hot new fixes for an 11 year old game, sadly.
  • The nvidia fix. From what I gathered in this thread I should run the game with the fix installed in 32-bit color depth with all of the graphical options disabled. Changing to 16-bit and checking software transparent blt mirrors the sprites properly but causes nearly unplayable slowdown when spell or potion effects are present. Just imagining this during the final battle of the game (where webs, stinking clouds and exploding arrows are thrown hither and yon) makes me cringe.
  • Microsoft Combatibility Manager. After following the steps it did absolutely nothing to help the issue.
  • Dicking around with nvidia control panel application settings. None of them did anything because BG1 isn't a 3D game. Moving on.
  • Enabling Sprite Mirroring in baldur.ini (since the option isn't even available in-game). This had some pretty hilarious results, in that now the characters aren't mirrored properly on top of everything else. I switched it off.
  • D3DWindower. The Window Mode tab had some settings that looked promising, but any combination of them ended in the same result: Me looking at goofy fog of war and projectiles, but in a neat little 640x480 box in the middle of my desktop.
I have no intention of installing either BGT or Tutu, as I am well into Cloakwood at this point. I've been dealing with the 16-bit slowdown until now, but since the gameplay is only going to ramp up from here I figured I should try and address this. I'm playing The Original Saga (The 3 CD set) in case that counts for anything.

Merry Christmas everyone,

Concerned

#234 -Draketalon-

-Draketalon-
  • Guest

Posted 14 January 2010 - 12:19 PM

This nvidia fix worked for me but now i have an other problem. The game crashes when i open inventory, i have installed the patch that is supposed to fix this but when i use the nvidia fix thingy it crashes in inventory even though i have the patch installed. Any1 know what to do with this?

#235 -The Louis-

-The Louis-
  • Guest

Posted 01 February 2010 - 12:25 PM

I'm having some problems on Planescape Torment when i scroll the screen all the areas covered by fog of war starts flashing, i tried basicaly every combination of the solutions i found on this thread an every combination of configurations on that DDraw program posted by ghostdog...

The only solution i found was playing the game on fullscreen mode and with any resolution diferent from my monitor's native res (1680x1050), however LCD monitors make a really blury upscale when using resolutions lower than the native...

I think by removing the fog of war i would get rid of this problem but it would spoil the gameplay

Another funny thing is that i found only one person with a similar problem in this thread i wonder what i'm doing wrong

Any ideas how to solve this?


PS: sorry by my bad english :(

#236 -Brecht-

-Brecht-
  • Guest

Posted 03 February 2010 - 05:03 PM

Hi peepz,

Trying to run BG 1 + TOTSC again after years of silence ... found the graphic glitch ... searched the net ... landed here. Did the compatibility administrator thingie. Did Test Run ( after selecting ForceDirectDrawEmulation ) game worked as it did all those years ago ... saved the database ... running the game ... again getting graphic glitch ... what am i doing wrong?

#237 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 04 February 2010 - 12:12 AM

Trying to run BG 1 + TOTSC again after years of silence ... found the graphic glitch ... searched the net ... landed here. Did the compatibility administrator thingie. Did Test Run ( after selecting ForceDirectDrawEmulation ) game worked as it did all those years ago ... saved the database ... running the game ... again getting graphic glitch ... what am i doing wrong?

Did you install the database?

7. Tick the 'ForceDirectDrawEmulation' compatibility fix.
8. Click next and finish.
9. Save your database.
10. Right click the database and select install. This will install the database.
11. Close the compatibility administrator and start baldur's gate. It should work correctly in 32bit mode without any ingame rendering fixes. You don't need to run the compatibility administrator again.


I think by removing the fog of war i would get rid of this problem but it would spoil the gameplay

There is a mod that can do that... that works at least in BG2, so it might need to be remade for PST...
PS: the Fog of War is the total black area of the map, not the 'not currently in view' area.

Another funny thing is that i found only one person with a similar problem in this thread i wonder what i'm doing wrong

Well, I too have similar issue with the Icewind Dale 2, and the only way I could correct it was to use smaller screen size(1440x900?, or any other z*16 x z*10).

Edited by Jarno Mikkola, 04 February 2010 - 12:59 AM.

Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#238 -Brecht-

-Brecht-
  • Guest

Posted 04 February 2010 - 01:11 AM

Of course i installed it mate :P ... actually ... first installed BG alone ... did the database, worked fine ... then i installed TOTSC and again everything went black boxes ... uninstalled the whole thing ( BG + Totsc ) and re-installed. Did the database afer all the latest patches were installed.

The rest u know :P

#239 Jarno Mikkola

Jarno Mikkola

    The Imp in his pink raincoat.

  • Member
  • 10911 posts

Posted 04 February 2010 - 01:49 AM

Of course i installed it mate :P ... actually ... first installed BG alone ... did the database, worked fine ... then i installed TOTSC and again everything went black boxes ... uninstalled the whole thing ( BG + Totsc ) and re-installed. Did the database afer all the latest patches were installed.

<_< You need to make the database from the game(BG1+TotSC+patch 5512) with the Compatibility Administrator, and then install the database with the Compatibility Administrator by right clicking it(point 10)... so the next time you start the bgmain.exe, it runs the changes made by the CA.

Edited by Jarno Mikkola, 04 February 2010 - 01:51 AM.

Cerberus v1.05, MegaModKits v1.01L, iiSpellSystemAdjustments v7.1; mods by Jarno Mikkola the Imp. FAQ for the Megamods. The Frequently Answered Questions.
BWS - Standard = not imba items spells or cheats. Tactical = AI hardly stupid = stupid hard. Expert = broke.
In case the BG2 game crashes post the content of your baldur.err file. To get it to record stuff, open up the 'baldur.ini' in your game folder with Notepad, and under the [Program Options] section in the file, make a new line and type in 'Logging On=1' (without the '' quotes, unless the line is already there)... Save the file and exit. Now go back into the game and try to reproduce the crash. Then look in your game folder again for the Baldur.err file and open it with the Notepad to analyze its contents, or let us do it.
Posted Image

I am afraid of nothing.


#240 tanman

tanman
  • Member
  • 9 posts

Posted 06 February 2010 - 10:04 AM

Hi,
Just wanted to add my 2 cents.
Was having the usual nvidia 8800 issues when casting spells.
I used the D3D windower and all is OK, but it is annoying playing in a window (and you either do not scroll, or you clip the cursor to the window but in that case you cannot grab the window and try to center it better, and for instance I still had no scrolling on on side; you can reinstall with lower resolution so that you see 100% of the window inside your screen, but still...)

Well, I tried the torrent.ini tweak listed here ( http://www.bootstrik...ment_vista.html ):
Translucent Shadows=0
SoftSrcKeyBltFast=1
SoftBltFast=1
SoftSrcKeyBlt=1
SoftBlt=1
SoftMirrorBlt=1

and, well, all works fine, no more spell issues and happily playing fullscreen without fiddling with the HW acceleration.
Tested a little more and everything works great, this is the easiest fix I've found.

Edited by tanman, 06 February 2010 - 10:58 AM.




Reply to this topic