Jump to content


Photo

Edwin Romance v2.0.7


  • Please log in to reply
7 replies to this topic

#1 Wisp

Wisp
  • Modder
  • 1353 posts

Posted 24 January 2016 - 03:34 AM

Download.

SHS file uploads are still broken, so this update can be downloaded here

Changes:
  • Fall back on correctly encoded English when the non-English translation is incomplete.
  • Patch scripts in a different way for better mod compatibility.
  • Dekaras' weapons cannot be stolen.
  • Fix some potential cutscene problems.

Edited by Wisp, 01 May 2017 - 05:43 AM.


#2 -jezz-

-jezz-
  • Guest

Posted 02 February 2016 - 03:22 AM

  • Fix some potential cutscene problems.

Can you explain more in detail what you did here? I mean if this fixed something gamebreaking etc. I'm planning on romancing edwin and if this was important I'd reinstall with your new version (I have 2.0.6). But i'd rather not as my install is pretty big and I made effort on it.

 

Thanks



#3 -jezz-

-jezz-
  • Guest

Posted 03 February 2016 - 10:53 AM

Thanks Alien. I was more thinking if I could have more details I could maybe fix the "cutscene problems" myself in Near Infinity.



#4 Lollorian

Lollorian

    smiley addict

  • Member
  • 4150 posts

Posted 06 February 2016 - 09:53 AM

It is the addition of SetInterrupt(FALSE) (and SetInterrupt(TRUE) unless the script uses DestroySelf())

This should be something a reload can fix if it actually affected you :P


"I am the smiley addict, yellow and round, this is my grin :D when I'm usually around :P.
When there's trouble brewing, see me post, cuz it's usually a wall o' yellow and your eyes are toast!!!"

BWP GUIDE - BWP FIXES - impFAQ - NPC LIST - KIT LIST - AREA LIST

GitHub Links : BWP Fixpack | Lolfixer | BWP Trimpack | RezMod


#5 Wisp

Wisp
  • Modder
  • 1353 posts

Posted 10 February 2016 - 12:49 PM

Can you explain more in detail what you did here? I mean if this fixed something gamebreaking etc. I'm planning on romancing edwin and if this was important I'd reinstall with your new version (I have 2.0.6). But i'd rather not as my install is pretty big and I made effort on it.
Link. It's probably only an issue affecting lesser travelled roads in the mod (or they would have surfaced earlier and/or more frequently and would have been fixed or lead to a reputation).
This one "Patch scripts in a different way for better mod compatibility." is much more important.
Link.

#6 -jezz-

-jezz-
  • Guest

Posted 10 February 2016 - 03:25 PM

This one "Patch scripts in a different way for better mod compatibility." is much more important.
Link.

I installed both Rogue Rebalancing and Edwin Romance and yet I did not get any such warning. Does that mean my installation is not affected by this incompatibility somehow or should I be concerned?



#7 Wisp

Wisp
  • Modder
  • 1353 posts

Posted 10 February 2016 - 10:10 PM

It's only an issue if you install RR's CoC component. If there is no warning, there is no problem.



#8 Cahir

Cahir
  • Modder
  • 132 posts

Posted 06 August 2018 - 10:21 PM

Hi Wisp,

 

Any chance to make Edwin Romance natively compatible with EET?

 

I believe currently BWP Fixpack needs to be applied first, to be able to use ER on EET. Specifically this part of a code:

 

https://github.com/B...d Fixpack/edwin

 

Thanks in advance!