Jump to content


Photo

How to deal with the DDraw problems of PST and other IE games


82 replies to this topic

#1 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 08 December 2009 - 05:59 PM

EDIT: This thread is more or less obsolete since a nice ddraw fix has been provided by aqrit here : http://www.shsforums...8732-ddraw-fix/

If for any reason the above fix doesn't help you feel free to check the rest.











I finally found a good way to avoid the problems newer cards have with DDraw (artifacts, choppy framerates, stuttering). The solution is to use the D3DWindower program. This utility can help you run older games in a window, using ddraw emulation, thus eliminating any ddraw issues. You can find it here. It's a partly translated version form Korean, but it's easy to figure out. In order to use it, push the "+" button, choose the game exe and then click on the settings button. Enter the resolution in which you have the game installed (height and width are misplaced) , or simply leave them at zero and the window will open at your installed resolution. In the "DDL" box select the .ddl that was inside the archive, then go to the "Window Mode" tab and tick the "DDraw emulate" box. Finally press the "run program" button to run the game windowed and also check the "Cursor Clip" box in the "Direct input" tab. This keeps focus on the window , so the mouse won't appear outside. Especially useful for scrolling.

This worked fine for PST, I've heard it also works good for the Fallout games and I'm sure it will also work for Baldur's Gate and Icewind Dale. The above ddraw settings are for Planescape Torment, other games may need somewhat different settings. If you want the window to fill the whole screen, just install the game at your fullscreen resolution (if you can) and then run it with D3Dwindower.

Some antivirus may mark the exe as a trojan but I think that's because it somehow hacks d3d/ddraw to make any application run in a window. Anyway, I haven't encountered any problems, but use it at your own risk.


ATI Users : Installing the catalyst 10.6 drivers may help with your ddraw problems.

Other solutions may be found here


See this pic for a detailed description of the preferences that have worked for me :

Posted Image




- It seems that Humanophage has found a way to use d3dwindower in fullscreen. This is what he had to say:

I believe I've found a way to fully fix the cursor issue while running full screen. One has to use the D3DWindower solution, and then use a programme called ShiftWindow to force full screen. The procedure is like this:
1. Open D3DWindower and Shiftwindow.
2. Run P:T using D3DWindower.
3. In ShiftWindow, choose to run P:T in a window.
4. In ShiftWindow, choose to run P:T full screen.

If one switches to full screen straight away, there will be graphical artefacts. This doesn't take long at all, and it fixes all the troubles.





- nug and Erik also seem to have found another way to emulate ddraw :

nug:
I found a post here.
This is a way to emulate DDraw through Microsoft Application Compatibility Toolkit. You can download it here.
Below is the post i found:

[I downloaded Application Compatibility Toolkit"
After installing the program, open "Compatibility Administrator" (should be under the new start menu shortcut "Microsoft Application Compatibility Toolkit 5.0")
I then pressed "New" and then right clicked on the newly created database and choose "Create New" and "Application Fix"
Name it whatever you want, and then locate the program file: "torment.exe" wherever it is on your HD. Click Next and choose one of the operating system compatibility modes if you wish; I chose "none." On the next page scroll down to "ForceDirectDrawEmulation" and check it. Click finish.
Now go up to "torment.exe" on the top right and right click to "Run Program"]


Eric added:
After doing what you said, click on the floppy disc to save the database if you haven't already. Then right click on it and click on 'install'. Now when you start Torment.exe it will automatically apply the fix, without having to boot it through the compatibility administrator. :)









Old Solution :

IF you still want to play Planescape Torment fullscreen with DDraw emulation disabled and you have the cursor trail problem then this may help you :
(beware, this is only for PST)


It's known that Planescape Torment has stuttering problems with some newer graphic cards. This can be fixed by disabling Direct Draw acceleration*. Unfortunately this introduces a new glitch that makes the cursors leave an annoying trail behind at certain places.


This fix is a simple workaround for this glitch. I've simply edited the cursor files in order to make this glitch less apparent. I've replaced one of the cursors with a very small cross (so the trail left behind is barely noticeable) and I've made the bottom screen scrolling cursors transparent. It's not a real fix, but the glitch is now far less noticeable.


*You can disable DDraw by opening dxdiag (start->run->dxdiag) going to the display tab and press "disable" next to Direct Draw Acceleration. You can also do this by going to desktop->properties->settings->advanced->troubleshoot and reduce the hardware acceleration slider two notches before "none".


Here is the fix in weidu format :

Attached Files


Edited by ghostdog, 20 June 2011 - 08:52 AM.


#2 ThunderPeel2001

ThunderPeel2001
  • Member
  • 70 posts

Posted 03 January 2010 - 05:46 AM

This is interesting, I think I may have to try it out - the current fix I'm using (NVidiaFix) isn't really working properly at the moment.

#3 ThunderPeel2001

ThunderPeel2001
  • Member
  • 70 posts

Posted 03 January 2010 - 02:15 PM

This is interesting, I think I may have to try it out - the current fix I'm using (NVidiaFix) isn't really working properly at the moment.


This solution is WAY better than NvidiaFix -- looks like I need to update my guide again!

#4 Qwinn

Qwinn
  • Modder
  • 3085 posts

Posted 03 January 2010 - 02:17 PM

Which was an improvement, thunderpeel? The cursor trail workaround? Or the D3DWindower solution?

Qwinn

#5 Qwinn

Qwinn
  • Modder
  • 3085 posts

Posted 03 January 2010 - 02:29 PM

I just tried the D3DWindower option myself. I'm not far enough into the game to have any spells that used to cause me problems, though I'm confident it'll work. Game looks fine. I just don't like the fact that it's windowed, and unfortunately, unchecking "Use Windowed Mode", the game still runs windowed. Any ideas on how to get it to run full screen?

Qwinn

#6 -Topaze-

-Topaze-
  • Guest

Posted 03 January 2010 - 02:47 PM

Actually, NvidiaFix works fine for me in Planescape: Torment.
In Baldur's Gate, however, it doesn't. There's still some flickering at the bottom of the avatars, as well as other (very) minor glitches.

#7 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 03 January 2010 - 04:09 PM

I just tried the D3DWindower option myself. I'm not far enough into the game to have any spells that used to cause me problems, though I'm confident it'll work. Game looks fine. I just don't like the fact that it's windowed, and unfortunately, unchecking "Use Windowed Mode", the game still runs windowed. Any ideas on how to get it to run full screen?

Qwinn


I'm afraid it will always be in a window. Also, if you run it with your monitors native resolution, because of the title bar and the position of the window you'll miss some part from the bottom and right.

The workaround I've found for this, is to :

1. Create a custom resolution a few pixes smaller than the maximum monitor resolution. In my case since my monitor runs at 1680x1050, I've created a 1664x1028 resolution. I think both ATI's and NVIDIA's have the option to create a custom resolution with their control panels. If not, then some registry editing can do the trick.

2. Re-install the widesceen mod + my UI with said resolution. Since we're reducing the resolution, then there shouldn't be a problem with save games, but better make a secondary install just in case.

3. Open it with the d3dwindower. Also make sure to uncheck the "keep the taskbar on top" option from the taskbar properties, to keep it out of the way. (Or simply hide the taskbar)


Yeah it's not absolutely perfect, but it's a million times better than running it with all that stuttering, or the cursor trails.

#8 ThunderPeel2001

ThunderPeel2001
  • Member
  • 70 posts

Posted 05 January 2010 - 01:47 AM

I just tried the D3DWindower option myself. I'm not far enough into the game to have any spells that used to cause me problems, though I'm confident it'll work. Game looks fine. I just don't like the fact that it's windowed, and unfortunately, unchecking "Use Windowed Mode", the game still runs windowed. Any ideas on how to get it to run full screen?


Yeah, it just runs a lot more smoothly than before, and for the first time I actually saw spells being visualized (I was attacked by five or six cranium rats and was surprised to see all the fancy graphics -- I'm not sure they were ever working before on my 8800GTS!). I thought I was going to hate the Windowing, but it didn't bother me, thankfully... although I do think it would be preferable if we had the option to run fullscreen. I wonder if Eddie (the guy who wrote the NVidiaFix) would be of any use?

Yeah it's not absolutely perfect, but it's a million times better than running it with all that stuttering, or the cursor trails.


Definitely, it's the best it's looked so far for me. Here's hoping we can improve it just a bit, too.

Edited by ThunderPeel2001, 05 January 2010 - 01:48 AM.


#9 -TinTin-

-TinTin-
  • Guest

Posted 20 January 2010 - 03:25 PM

It's known that Planescape Torment has stuttering problems with some newer graphic cards. This can be fixed by disabling Direct Draw acceleration*. Unfortunately this introduces a new glitch that makes the cursors leave an annoying trail behind at certain places.


This fix is a simple workaround for this glitch. I've simply edited the cursor files in order to make this glitch less apparent. I've replaced one of the cursors with a very small cross (so the trail left behind is barely noticeable) and I've made the bottom screen scrolling cursors transparent. It's not a real fix, but the glitch is now far less noticeable.


*You can disable DDraw by opening dxdiag (start->run->dxdiag) going to the display tab and press "disable" next to Direct Draw Acceleration. You can also do this by going to desktop->properties->settings->advanced->troubleshoot and reduce the hardware acceleration slider two notches before "none".

The D3D utility didn't help me get rid of the stuttering in PS:T, but lowering the HW acceleration slider did, thanks! :)

Is there an easy way for this to be done automatically when Torment is started, and to be set back to normal afterwards?

And I love your UI. ;)

#10 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 20 January 2010 - 04:48 PM

Is there an easy way for this to be done automatically when Torment is started, and to be set back to normal afterwards?


None that I know of, unfortunately.

#11 nevill

nevill
  • Member
  • 87 posts

Posted 23 January 2010 - 04:15 AM

Is there a way to resize the window? 800*600 window looks tiny on my desktop and if I use resolutions higher than that, in-game sprites look too small in fullscreen (and besides, I don't want to start a new game). I would like to know if 800*600 window can be stretched to, say, 1280*1024, without looking extremely ugly.

Edited by nevill, 23 January 2010 - 04:17 AM.


#12 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 23 January 2010 - 04:26 AM

It can be stretched by changing the height/width values, but it doesn't look good. I don't know if there are any other options in the program to improve the stretching quality, fiddle with them and see what happens. (You know, could also change the desktop resolution to something smaller, while playing :))

#13 nevill

nevill
  • Member
  • 87 posts

Posted 23 January 2010 - 04:43 AM

You know, could also change the desktop resolution to something smaller, while playing

The easiest solution didn't occur to me. :( Thanks!

Now, if only we could position the window freely so that the menu on top of the window could be hidden and the window would fit the screen without additional tweaking...

Edited by nevill, 23 January 2010 - 04:43 AM.


#14 nevill

nevill
  • Member
  • 87 posts

Posted 23 January 2010 - 06:03 AM

Tried to reinstall the game with 800*580 resolution, but unfortunately for me you have disabled support for resolutions below 800*600. Is there a way I can make the mod install by changing some lines in tp2?

#15 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 23 January 2010 - 08:32 AM

Tried to reinstall the game with 800*580 resolution, but unfortunately for me you have disabled support for resolutions below 800*600. Is there a way I can make the mod install by changing some lines in tp2?


Go to the TPH folder, open WDM_check.tph and delete OR (4CDy < 599) and OR (2CDy < 599). This should do the trick.

I might actually remove those parts myself since the mandatory thing is only for the x-resolution to be >=800.

Edited by ghostdog, 23 January 2010 - 02:11 PM.


#16 nevill

nevill
  • Member
  • 87 posts

Posted 23 January 2010 - 01:27 PM

Thanks, will try that.

#17 -Patrick-

-Patrick-
  • Guest

Posted 23 March 2010 - 09:22 PM

Just wanna point one thing out here...

Followed the steps and I really like the game in windowed. Running in XP and using a 17" CRT old-school monitor set to a native 800x600 resolution, with torment running in the original 640x480, windowed.

It really makes the game look good. Since my monitor is set to 800x600 it makes the game window LARGER, resulting in a windowed mode that is only a tad smaller than the monitor... Also, since the game runs in 16-bit, the smaller windowed mode makes the colors blend much better and they don't appear to be as "jagged". In addition, it makes the entire game look cleaner, as the 640x480 resolution obviously looks streched if you are playing on a large monitor.

While the widescreen mod is GREAT and makes the game look far better, the aforementioned is how I perfer to play the game. This is my first play-through of the game and I want it to be close to the original... (great game so far, JUST GREAT!! cannot believe how good) It feels closer to the original intention and I feel like im back in '99. So thank you for this discovery!!

Now, the goods far outweigh the bads, but there is a SMALL problem I have encountered and I'm not sure if anyone else has this happening.

My computer is a freshly installed XP, so I doubt there is too much junk on it... but when I am running torment in windowed mode, the game sometimes crashes. Specifically, when I try to load a quick-save using the f9 key (fix-pack mod). The game does everything else fine... saving works normally, but, at least once a day, when I try to quick load the game simply crashes - but that save game is fine. It's just a matter of restarting the game and then trying to load the game again. It's really not a big issue, it jsut wastes about 5 seconds of my time restarting the game... it happened ONE other time when I brought up the dialogue window to review some text... I pressed the button and it crashed. Restarted, worked fine.

Just thought I'd throw it out there!!

#18 ghostdog

ghostdog
  • Modder
  • 554 posts

Posted 24 March 2010 - 03:53 AM

It has been mentioned by qwinn that using the quicksave too often can sometimes cause crashes.

Edited by ghostdog, 24 March 2010 - 03:53 AM.


#19 Qwinn

Qwinn
  • Modder
  • 3085 posts

Posted 24 March 2010 - 01:18 PM

Scient mentioned that he thought the crash occurs when you quickload with the mouse hovering over something besides general artwork, like a character portrait or GUI button or something like that. Hope that helps, and let us know if you get good results with that information.

Hopefully that problem can be resolved for the next release.

Qwinn

#20 rtr86

rtr86
  • Member
  • 46 posts

Posted 30 March 2010 - 10:27 AM

Interesting,,,

I always thought the graphical issues on older games only affected people with Nvidia cards.

I'm on a 4870 ATI and just tried this tweak/app to see what it's all about and I noticed a big difference! I always thought the jumpy animations were part of the game I've been playing for so long. I'm using a desktop res of 1440 x 900 and have installed PST @ 1280 x 800 (with ghostdog of course) and set the app the same. Everything 'feels right'. I'm impressed. Going to check it out on a few other titles now.

Edited by rtr86, 30 March 2010 - 10:56 AM.




Reply to this topic