Jump to content


Photo

Need help at Temple Ruins


  • Please log in to reply
13 replies to this topic

#1 GreenFire

GreenFire
  • Member
  • 3 posts

Posted 09 February 2010 - 02:37 PM

Hi,

I seem to have run into a problem with the Umar Hills quest. When I head over to the temple ruins map the game starts to slow down and within seconds it freezes completely. After a few seconds things start to move again, but then everything stops again for much longer, say several minutes. Then the game freeze for good. Also for some reason, no matter how I try to go to the map I always end up on AR1404 insted of AR1400, which btw seems empty. Now I've tried to look at the scripts that are firing, but apart from the ones tied to shadows (BPSHADW and DW#2INV9) going off like crazy I could't find anything wrong. (btw, is it normal that shadows start fighting shadow fiends?) So, I'd be grateful if someone with a better understanding of these things than me could give me a hand. I've attached my weidu.log and the area file+script to my post. Please let me know if I should post anything else.

Thanks,
Green

Attached Files



#2 Miloch

Miloch

    Barbarian

  • Modder
  • 6528 posts

Posted 09 February 2010 - 03:22 PM

I doubt Aurora v4 is causing this particular issue, but you'll want to uninstall that and install v5 when you get a chance. This sounds like a scripting thing, so maybe the script debuggerer (wherever that is - around here somewhere) might help.

Edit: oh, and decompile your ar1404.bcs with NearInfinity or DLTCEP and post the contents of that instead (use spoiler tags if it's big or attach it). And do a 'weidu --change-log ar1404.bcs' - see the pinned megamod FAQ for more instructions.

Edited by Miloch, 09 February 2010 - 03:25 PM.

Infinity Engine Contributions
Aurora * BG1 NPC * BG1 Fixpack * Haiass * Infinity Animations * Level 1 NPCs * P5Tweaks
PnP Free Action * Thrown Hammers * Unique Containers * BG:EE * BGII:EE * IWD:EE
================================================================
Player & Modder Resources
BAM Batcher * Creature Lister * Creature Checker * Creature Fixer * Tutu/BGT Area Map & List * Tutu Mod List
================================================================
"Infinity turns out to be the opposite of what people say it is. It is not 'that which has nothing beyond itself' that is infinite, but 'that which always has something beyond itself'." -Aristotle


#3 GreenFire

GreenFire
  • Member
  • 3 posts

Posted 09 February 2010 - 06:55 PM

Edit: oh, and decompile your ar1404.bcs with NearInfinity or DLTCEP and post the contents of that instead (use spoiler tags if it's big or attach it). And do a 'weidu --change-log ar1404.bcs' - see the pinned megamod FAQ for more instructions.


Ok, I had a change log made for the ar1404.bsc but it said that it wasn't affected by any mods. Made one for the .are file as well with the following results:

Spoiler


As for the content of the bsc file:

Spoiler


Hope you find something in it.
Thanks,
Green

#4 Miloch

Miloch

    Barbarian

  • Modder
  • 6528 posts

Posted 09 February 2010 - 07:55 PM

Ok, I had a change log made for the ar1404.bsc but it said that it wasn't affected by any mods.

Should be .bcs - obviously it's affected by mods since we can tell from the content.

Those last 3 blocks will cause loops and probably therefore lag, since they check globals without setting them or otherwise avoiding loops. Also, I don't know how often I tell people Continue() is stupid, don't use it unless absolutely necessary, but they keep using it, thinking it's somehow going to cure poor scripting.

IF
Global("CbInformedAboutRoots","GLOBAL",1)
Contains("CB901CMS","ClubMossCont") // Club Moss
Global("CbClubMossInfoClicked","GLOBAL",2)
THEN
RESPONSE #100
ContainerEnable("ClubMossCont",FALSE)
TriggerActivation("ClubMossInfo",FALSE)
Continue()
SetGlobal("CbClubMossInfoClicked","GLOBAL",3)
END

IF
Global("CbClubMossInfoClicked","GLOBAL",0)
THEN
RESPONSE #100
TriggerActivation("ClubMossInfo",TRUE)
ContainerEnable("ClubMossCont",FALSE)
Continue()
SetGlobal("CbClubMossInfoClicked","GLOBAL",1)
END

IF
Global("CbClubMossInfoClicked","GLOBAL",1)
THEN
RESPONSE #100
TriggerActivation("ClubMossInfo",FALSE)
ContainerEnable("ClubMossCont",TRUE)
Continue()
SetGlobal("CbClubMossInfoClicked","GLOBAL",0)
END

I am just guessing on those variables - it still looks pretty wacky because it uses the same one all over the place, but better than using none. I guess this is from CtB or something, judging from the prefix.

Infinity Engine Contributions
Aurora * BG1 NPC * BG1 Fixpack * Haiass * Infinity Animations * Level 1 NPCs * P5Tweaks
PnP Free Action * Thrown Hammers * Unique Containers * BG:EE * BGII:EE * IWD:EE
================================================================
Player & Modder Resources
BAM Batcher * Creature Lister * Creature Checker * Creature Fixer * Tutu/BGT Area Map & List * Tutu Mod List
================================================================
"Infinity turns out to be the opposite of what people say it is. It is not 'that which has nothing beyond itself' that is infinite, but 'that which always has something beyond itself'." -Aristotle


#5 Ranadiel

Ranadiel
  • Member
  • 174 posts

Posted 10 February 2010 - 02:36 AM

How old is your install? I had a similar problem to this two years ago. I think that it has been fixed in the current version of the BWP Fixpack, but if you either have a really old version of the install or did not install the Fixpack then this could be the problem.

My thread on the problem(solution in post 14)

#6 GreenFire

GreenFire
  • Member
  • 3 posts

Posted 10 February 2010 - 08:07 AM

Hey,

thanks for the quick help. It really was the wolfm.itm ot the Every Mod and Dog wolf that was causing the problem. The thread you, Ranadiel, pointed me to suggests that the bug was fixed long ago, so I don't know how it resurfaced. My install is fairly recent, less than 2 weeks old. Anyway, thanks for the help you two!

Greetings,
Green

#7 -asdf-

-asdf-
  • Guest

Posted 12 February 2010 - 07:40 PM

My 8.2 build had the same issue. I found that thread on my own and used the wolf itm in that thread to achieve a solution.

#8 -Fennek-

-Fennek-
  • Guest

Posted 13 February 2010 - 03:17 PM

Testified several times in the German Forum. Might be incompatibility between "eMaD" and "Refinements - Heal on shifting back to human (Default)" or a problem of just emod.

From here:

http://kerzenburg.ba...?t=38163&page=7

Mods affecting WOLFM.ITM:
00000: /* from game biffs */ ~SPELL_REV/SETUP-SPELL_REV.TP2~ 0 30 // Dispel Magic Fix
00001: ~SETUP-REVISEDBATTLES.TP2~ 0 0 // Improved Battles - "erebusant's Patching Version" v6
00002: ~SETUP-REFINEMENTS.TP2~ 0 30 // Heal on shifting back to human (Default)
00003: ~SCSII/SETUP-SCSII.TP2~ 0 1000 // Detectable spells (required for most other components)

Revised Battles - Improved Battles - "erebusant's Patching Version" v6: fine
Refinements - Heal on shifting back to human (Default): fine
SCSII - Detectable spells (required for most other components): bad!

#9 -Fennek-

-Fennek-
  • Guest

Posted 14 February 2010 - 02:22 PM

I meant backups from:

Revised Battles - Improved Battles - "erebusant's Patching Version" v6: fine
Refinements - Heal on shifting back to human (Default): fine
SCSII - Detectable spells (required for most other components): bad!

#10 Homer_S

Homer_S
  • Member
  • 31 posts

Posted 16 February 2010 - 11:29 AM

How old is your install? I had a similar problem to this two years ago. I think that it has been fixed in the current version of the BWP Fixpack, but if you either have a really old version of the install or did not install the Fixpack then this could be the problem.

My thread on the problem(solution in post 14)

Is this fix still needed with the current BWP 8.3?

Leomar replied no at first, but was really discussing a different CTD bug, not the slow to a crawl bug.

Thanks!
Homer

#11 pandomino

pandomino
  • Member
  • 1 posts

Posted 17 February 2010 - 02:55 AM


How old is your install? I had a similar problem to this two years ago. I think that it has been fixed in the current version of the BWP Fixpack, but if you either have a really old version of the install or did not install the Fixpack then this could be the problem.

My thread on the problem(solution in post 14)

Is this fix still needed with the current BWP 8.3?

Leomar replied no at first, but was really discussing a different CTD bug, not the slow to a crawl bug.

Thanks!
Homer


I don't know if the problem still exists in the new BWP 8.3. But there is a work-around. The cause for the bug seems to be an incompatibility between Refinements and Every Mod and Dog.
So just take a Wolfm.itm which wasn't patched by Refinements (e.g. from Refinements' backup-folder), copy it to your Override-folder and the Bug shouldn't appear.
If you are able to understand german, here is the link to the Kerzenburg-Thread: http://kerzenburg.ba...?t=38163&page=1
By the way, my install is a 8.2 and i still had the same issue.

Greetings, Henning

Edited by pandomino, 17 February 2010 - 02:59 AM.


#12 Homer_S

Homer_S
  • Member
  • 31 posts

Posted 18 February 2010 - 08:24 AM

I don't know if the problem still exists in the new BWP 8.3. But there is a work-around. The cause for the bug seems to be an incompatibility between Refinements and Every Mod and Dog.
So just take a Wolfm.itm which wasn't patched by Refinements (e.g. from Refinements' backup-folder), copy it to your Override-folder and the Bug shouldn't appear.
If you are able to understand german, here is the link to the Kerzenburg-Thread: http://kerzenburg.ba...?t=38163&page=1
By the way, my install is a 8.2 and i still had the same issue.

Greetings, Henning

I'll try that fix. I tried to babelfish the german page, but they have the IP address blocked! The bug definitely showed up in 8.2 just a few weeks ago. I started over because of that and the Boo bug, which is fixed in 8.3 BTW.

Thanks!
Homer

Edited by Homer_S, 18 February 2010 - 08:25 AM.


#13 AndrewB

AndrewB
  • Member
  • 147 posts

Posted 01 March 2010 - 05:02 AM

Just saw it in my 8.3 install. Thankfully an easy fix.

Edited by AndrewB, 01 March 2010 - 05:03 AM.

BEGIN BIFFING

ACTION_IF!(FILE_EXISTS ~McFly~) THEN BEGIN
SAY ~BUTTHEAD!~
Posted Image
END BIFFING

#14 Chevalier

Chevalier

    Knight of the Realms

  • Modder
  • 2390 posts

Posted 05 April 2011 - 03:54 AM

Thanks for the fix, I had the problem with my latest install.

My WeiDU.log:
Spoiler

I Ride for the King!


a.k.a. Chev