Jump to content


Photo

Aurora's Shoes and Boots v5.2.0


4 replies to this topic

#1 Sam.

Sam.
  • Modder
  • 1001 posts

Posted 13 November 2017 - 10:23 AM

Aurora's Shoes and Boots was patched some time ago with all of the latest fixes from BWFixpack and the forums here, but it seems my post about it was eaten by one of SHS's HD failures.  Note that EE compatibility HAS NOT BEEN ADDED to this version; only the existing bug fixes.

 

Aurora's Shoes and Boots v5.2.0 can be found on GitHub

Download

Readme [English] [French]


"Ok, I've just about had my FILL of riddle asking, quest assigning, insult throwing, pun hurling, hostage taking, iron mongering, smart-arsed fools, freaks, and felons that continually test my will, mettle, strength, intelligence, and most of all, patience! If you've got a straight answer ANYWHERE in that bent little head of yours, I want to hear it pretty damn quick or I'm going to take a large blunt object roughly the size of Elminster AND his hat, and stuff it lengthwise into a crevice of your being so seldom seen that even the denizens of the nine hells themselves wouldn't touch it with a twenty-foot rusty halberd! Have I MADE myself perfectly CLEAR?!"

-- to Portalbendarwinden

--------------------

post-10485-0-15080600-1348188745.jpg
___________Old pen and paper modules of the 70s and 80s.___________

CA Forums CA Homepage


#2 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 1743 posts

Posted 13 November 2017 - 10:56 AM

Are you going to work on EE version of Aurora? It's a pity there is no version of the mod for plain EE.



#3 Sam.

Sam.
  • Modder
  • 1001 posts

Posted 15 November 2017 - 09:53 AM

Are you going to work on EE version of Aurora? It's a pity there is no version of the mod for plain EE.

I would like to eventually, but I'm afraid my free time is about to get even more scarce so I can't make any promises.  Roxanne had an interim EET compatible version for a while and there was some discussion with Miloch about its release, but I guess that discussion might have gotten eaten by one of SHS's HD failures also.  Roxanne's version dropped compatibility with any version of the game except EET, and also dropped around half of what the original mod offered.  I wasn't a fan of that approach, but to each their own.


"Ok, I've just about had my FILL of riddle asking, quest assigning, insult throwing, pun hurling, hostage taking, iron mongering, smart-arsed fools, freaks, and felons that continually test my will, mettle, strength, intelligence, and most of all, patience! If you've got a straight answer ANYWHERE in that bent little head of yours, I want to hear it pretty damn quick or I'm going to take a large blunt object roughly the size of Elminster AND his hat, and stuff it lengthwise into a crevice of your being so seldom seen that even the denizens of the nine hells themselves wouldn't touch it with a twenty-foot rusty halberd! Have I MADE myself perfectly CLEAR?!"

-- to Portalbendarwinden

--------------------

post-10485-0-15080600-1348188745.jpg
___________Old pen and paper modules of the 70s and 80s.___________

CA Forums CA Homepage


#4 Lava Del'Vortel

Lava Del'Vortel

    Fiction Enforcer

  • Modder
  • 1743 posts

Posted 15 November 2017 - 10:18 AM

I know that version and I think I also took part in that discussion. But I never found out what was the problematic part. Animations? All that would need to be done is leaving the code to add animations for the original BG2 + copy the missing animations (from IWD EE / SoD) for BG2EE version of the game. EE uses the same animation list as any other EE game, so the ones used by Aurora are probably there, just bams must be copied.

 

Not sure what else could be problematic...



#5 Roxanne

Roxanne

    Modder

  • Member
  • 2839 posts

Posted 15 November 2017 - 10:58 AM

I would like to eventually, but I'm afraid my free time is about to get even more scarce so I can't make any promises.  Roxanne had an interim EET compatible version for a while and there was some discussion with Miloch about its release, but I guess that discussion might have gotten eaten by one of SHS's HD failures also.  Roxanne's version dropped compatibility with any version of the game except EET, and also dropped around half of what the original mod offered.  I wasn't a fan of that approach, but to each their own.

The part that was left out of the *reduced* Aurora was the main part that dealt with XP distribution, store prices, item prices etc. In one word all the tweaks the mod added for the old game.

 

Instead just the shops and mini-mod events were extracted. In discussion with Miloch etc it was clarified that this part was released as *Deep Gnomes on the Sword Coast* and was to be understood as a teaser for the 'real' Aurura mod. EET was still young at that tiime, and chances were that a dedicated tweak mod would take care about that other aspect of the mod.

 

Since then, there has not been any further development from any side, unless you count the latest update for EET_Tweaks.

*Deep Gnomes* was made EET exclusive because a) there is a fully functional Aurora mod for the classic game and no need for change (update made by Sam just recently) b) there was high interest from players to meet at least the gnomes again in EE c) A *split* version for BGEE and another for BG2EE makes no real sense because the remaining contents is per se continuous like EET. Also, EET provides for the necessary animations per default (former 1pp etc is part of the base), so there was no need to add all that to the mod.

 

This is my knowledge of the status. The *Deep Gnomes* is still considered interim, to be removed as soon as a full Aurora EE is released. It was also confirmed that this approach was in line with the original author's disclaimer for public use of this stuff.


Edited by Roxanne, 15 November 2017 - 11:02 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*




Reply to this topic